Bug 845378 - cartidge manifests should not contain versions in Requires
cartidge manifests should not contain versions in Requires
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Krishna Raman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-02 17:01 EDT by Andy Grimm
Modified: 2016-11-07 22:46 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-29 19:46:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Grimm 2012-08-02 17:01:27 EDT
From a crankcase source checkout, running "rake build_setup" generates a large yum install command, which appears to be based on requirements in manifest files.
some of these manifest files contain requirements like "php <= 5.3.2".  This results in warnings from yum like:

"No package 5.3.2 available"

Since the command uses "--skip-broken", it doesn't actually cause a fatal error, but it should be fixed nonetheless.
Comment 1 Krishna Raman 2013-12-09 19:37:20 EST
No longer valid.
Comment 2 Yujie Zhang 2013-12-11 01:53:50 EST
Since crankcase source does not exist, and openshift-origin-console can be installed correctly now, so verify this bug.

Note You need to log in before you can comment on or make changes to this bug.