Bug 845418 - [abrt] gphotoframe-1.5.1-1.fc17: parseexif.py:73:get_geo:ZeroDivisionError: float division by zero
[abrt] gphotoframe-1.5.1-1.fc17: parseexif.py:73:get_geo:ZeroDivisionError: f...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gphotoframe (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
abrt_hash:d9d4591388d86a0290baec075fc...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-02 23:14 EDT by Mamoru TASAKA
Modified: 2012-08-22 17:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-22 17:12:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mamoru TASAKA 2012-08-02 23:14:26 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
cmdline:        /usr/bin/python /usr/bin/gphotoframe
comment:        Looks like I was just lauching gphotoframe for some time and then it crashed, need investigating...
executable:     /usr/bin/gphotoframe
kernel:         3.4.6-2.fc17.i686
time:           2012年08月03日 12時10分59秒
uid:            500
username:       mtasaka

backtrace:
:parseexif.py:73:get_geo:ZeroDivisionError: float division by zero
:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/gphotoframe/liststore.py", line 81, in _start_timer
:    updated = self._change_photo()
:  File "/usr/lib/python2.7/site-packages/gphotoframe/liststore.py", line 104, in _change_photo
:    target().get_photo(self._show_photo_cb)
:  File "/usr/lib/python2.7/site-packages/gphotoframe/plugins/folder.py", line 47, in get_photo
:    cb(None, self.photo)
:  File "/usr/lib/python2.7/site-packages/gphotoframe/liststore.py", line 116, in _show_photo_cb
:    elif self.photoframe.set_photo(photo):
:  File "/usr/lib/python2.7/site-packages/gphotoframe/frame.py", line 70, in set_photo
:    if not self.photoimage.set_photo(photo): return False
:  File "/usr/lib/python2.7/site-packages/gphotoframe/image/gtkimage.py", line 28, in set_photo
:    if self.pixbuf.set(self.photo) is False:
:  File "/usr/lib/python2.7/site-packages/gphotoframe/image/gtkimage.py", line 96, in set
:    photo.get_exif()
:  File "/usr/lib/python2.7/site-packages/gphotoframe/plugins/base/base.py", line 214, in get_exif
:    geo = tags.get_geo()
:  File "/usr/lib/python2.7/site-packages/gphotoframe/plugins/base/parseexif.py", line 73, in get_geo
:    x = lon[0].num + lon[1].num/60 + lon[2].num/3600/lon[2].den
:ZeroDivisionError: float division by zero
:
:Local variables in innermost frame:
:lon_array: (0x0004) Ratio=[15, 347467/10000, 0/0] @ 936
:self: <gphotoframe.plugins.base.parseexif.ParseEXIF object at 0x9f6af0c>
:lon: [15, 347467/10000, 0/0]
:lat_array: (0x0002) Ratio=[27, 221941/5000, 0/0] @ 912
:lat: [27, 221941/5000, 0/0]
:geo: {}
Comment 1 Mamoru TASAKA 2012-08-03 00:35:14 EDT
/usr/share/backgrounds//gnome/SundownDunes.jpg seems to be the exact reproducer.
Comment 2 Fedora Update System 2012-08-13 04:13:20 EDT
gphotoframe-1.5.1-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/gphotoframe-1.5.1-2.fc17
Comment 3 Fedora Update System 2012-08-13 04:14:14 EDT
gphotoframe-1.5.1-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/gphotoframe-1.5.1-2.fc16
Comment 4 Fedora Update System 2012-08-13 20:59:37 EDT
Package gphotoframe-1.5.1-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gphotoframe-1.5.1-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11814/gphotoframe-1.5.1-2.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-08-22 17:05:54 EDT
gphotoframe-1.5.1-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2012-08-22 17:12:01 EDT
gphotoframe-1.5.1-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.