Bug 845437 - OOPS on USB unmount from Nautilus
OOPS on USB unmount from Nautilus
Status: CLOSED DUPLICATE of bug 768534
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-03 02:04 EDT by Bojan Smojver
Modified: 2012-08-07 11:15 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-07 11:15:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bojan Smojver 2012-08-03 02:04:18 EDT
Description of problem:
Was transferring some photos from Samsung Galaxy S2 in USB storage mode. When I pressed the eject button on the volume that represents the external SD card, I got an OOPS.

Version-Release number of selected component (if applicable):
kernel-3.5.0-2.fc17.x86_64

How reproducible:
Seen it once thus far.

Steps to Reproduce:
1. See decription.
2.
3.
  
Actual results:
OOPS.

Expected results:
Worked fine under 3.4.6-2.

Additional info:
[52909.387979] usb 1-1.1: new high-speed USB device number 8 using ehci_hcd
[52909.476815] usb 1-1.1: New USB device found, idVendor=04e8, idProduct=6860
[52909.476819] usb 1-1.1: New USB device strings: Mfr=2, Product=3, SerialNumber=4
[52909.476823] usb 1-1.1: Product: SAMSUNG_Android
[52909.476825] usb 1-1.1: Manufacturer: SAMSUNG
[52909.476828] usb 1-1.1: SerialNumber: 0019461b30a31f
[52912.278076] usb 1-1.1: USB disconnect, device number 8
[52926.510186] usb 1-1.1: new high-speed USB device number 9 using ehci_hcd
[52926.596783] usb 1-1.1: New USB device found, idVendor=04e8, idProduct=685b
[52926.596788] usb 1-1.1: New USB device strings: Mfr=2, Product=3, SerialNumber=4
[52926.596791] usb 1-1.1: Product: SAMSUNG_Android
[52926.596794] usb 1-1.1: Manufacturer: SAMSUNG
[52926.596797] usb 1-1.1: SerialNumber: 0019461b30a31f
[52926.597798] scsi7 : usb-storage 1-1.1:1.0
[52927.598495] scsi 7:0:0:0: Direct-Access     SAMSUNG  File-Stor Gadget 0001 PQ: 0 ANSI: 2
[52927.599182] scsi 7:0:0:1: Direct-Access     SAMSUNG  File-Stor Gadget 0001 PQ: 0 ANSI: 2
[52927.600360] sd 7:0:0:0: Attached scsi generic sg2 type 0
[52927.600705] sd 7:0:0:1: Attached scsi generic sg3 type 0
[52927.605123] sd 7:0:0:0: [sdb] Attached SCSI removable disk
[52927.605743] sd 7:0:0:1: [sdc] Attached SCSI removable disk
[52936.227370] sd 7:0:0:1: [sdc] 7739392 512-byte logical blocks: (3.96 GB/3.69 GiB)
[52936.228433] sd 7:0:0:1: [sdc] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[52936.232560]  sdc:
[52938.271104] sd 7:0:0:0: [sdb] 24133632 512-byte logical blocks: (12.3 GB/11.5 GiB)
[52938.272158] sd 7:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[52938.277150]  sdb:
[53292.147123] VFS: Busy inodes after unmount of sdc. Self-destruct in 5 seconds.  Have a nice day...
[53292.150351] BUG: unable to handle kernel NULL pointer dereference at 00000000000000f8
[53292.151822] IP: [<ffffffff816079be>] _raw_spin_lock+0xe/0x30
[53292.153291] PGD 224c79067 PUD 225523067 PMD 0 
[53292.154769] Oops: 0002 [#1] SMP 
[53292.156262] CPU 1 
[53292.156275] Modules linked in: vfat fat usb_storage nfs fscache fuse bnep bluetooth ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 nf_conntrack_ipv4 nf_defrag_ipv4 ip6table_filter xt_state ip6_tables nf_conntrack binfmt_misc uinput qcserial usb_wwan qmi_wwan uvcvideo cdc_wdm videobuf2_vmalloc videobuf2_memops videobuf2_core videodev media usbnet mii snd_hda_codec_hdmi coretemp snd_hda_codec_conexant snd_hda_intel snd_hda_codec arc4 kvm thinkpad_acpi iwlwifi mac80211 snd_hwdep snd_pcm snd_page_alloc snd_timer i2c_i801 microcode snd cfg80211 lpc_ich intel_ips e1000e mfd_core mei soundcore rfkill nfsd nfs_acl auth_rpcgss lockd sunrpc crc32c_intel ghash_clmulni_intel sdhci_pci firewire_ohci sdhci firewire_core mmc_core crc_itu_t mxm_wmi wmi i915 video i2c_algo_bit drm_kms_helper drm i2c_core [last unloaded: scsi_wait_scan]
[53292.164724] 
[53292.166229] Pid: 1622, comm: gvfsd-trash Not tainted 3.5.0-2.fc17.x86_64 #1 LENOVO 4313CTO/4313CTO
[53292.167862] RIP: 0010:[<ffffffff816079be>]  [<ffffffff816079be>] _raw_spin_lock+0xe/0x30
[53292.169460] RSP: 0000:ffff880225511e68  EFLAGS: 00010286
[53292.171024] RAX: 0000000000000100 RBX: ffff8801a5673790 RCX: 0000000000000004
[53292.172657] RDX: 0000000000000003 RSI: 0000000000000000 RDI: 00000000000000f8
[53292.174268] RBP: ffff880225511e68 R08: 5038000000000000 R09: 01a56738281c0000
[53292.175917] R10: fe3c993131b20a07 R11: 7fffffffffffffff R12: 0000000000000000
[53292.177527] R13: ffffffffa05e9640 R14: ffffffffa05e9640 R15: 0000000000000000
[53292.179158] FS:  00007f615b1ce800(0000) GS:ffff88023bc80000(0000) knlGS:0000000000000000
[53292.180843] CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
[53292.182497] CR2: 00000000000000f8 CR3: 000000020fb8d000 CR4: 00000000000007e0
[53292.184250] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
[53292.186016] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
[53292.187790] Process gvfsd-trash (pid: 1622, threadinfo ffff880225510000, task ffff880225508000)
[53292.189604] Stack:
[53292.191271]  ffff880225511e88 ffffffffa05e6650 ffff8801a5673790 ffff8801a5673888
[53292.193040]  ffff880225511ea8 ffffffffa05e66f8 ffff880222b54600 ffff8801a5673790
[53292.194806]  ffff880225511ed8 ffffffff8119e212 7fffffffffffffff ffff8801a5673790
[53292.196587] Call Trace:
[53292.198385]  [<ffffffffa05e6650>] fat_detach+0x30/0x80 [fat]
[53292.200169]  [<ffffffffa05e66f8>] fat_evict_inode+0x58/0x60 [fat]
[53292.202032]  [<ffffffff8119e212>] evict+0xa2/0x1a0
[53292.203873]  [<ffffffff8119e413>] iput+0x103/0x1f0
[53292.205697]  [<ffffffff811c35a0>] fsnotify_destroy_mark+0x140/0x150
[53292.207541]  [<ffffffff811c54ce>] sys_inotify_rm_watch+0x6e/0xb0
[53292.209311]  [<ffffffff8160fc29>] system_call_fastpath+0x16/0x1b
[53292.211149] Code: c2 ff ff ff ff be 01 00 00 00 48 89 e5 e8 8b fe ff ff 5d c3 90 90 90 90 90 90 90 90 90 55 48 89 e5 66 66 66 66 90 b8 00 01 00 00 <f0> 66 0f c1 07 0f b6 d4 38 c2 74 0f 66 0f 1f 44 00 00 f3 90 0f 
[53292.215406] RIP  [<ffffffff816079be>] _raw_spin_lock+0xe/0x30
[53292.217430]  RSP <ffff880225511e68>
[53292.219463] CR2: 00000000000000f8
[53292.243424] ---[ end trace 07d1462716f49963 ]---
[53292.251883] sdc: detected capacity change from 3962568704 to 0
[53315.249121] VFS: busy inodes on changed media or resized disk sdb
[53315.267811] sdb: detected capacity change from 12356419584 to 0
[53317.339881] usb 1-1.1: USB disconnect, device number 9
[53317.341457] sd 7:0:0:0: [sdb] Synchronizing SCSI cache
[53317.341520] sd 7:0:0:0: [sdb]  
[53317.341525] Result: hostbyte=DID_NO_CONNECT driverbyte=DRIVER_OK
[53317.342290] sd 7:0:0:1: [sdc] Synchronizing SCSI cache
[53317.342364] sd 7:0:0:1: [sdc]  
[53317.342370] Result: hostbyte=DID_NO_CONNECT driverbyte=DRIVER_OK
Comment 1 Stanislaw Gruszka 2012-08-07 11:15:49 EDT

*** This bug has been marked as a duplicate of bug 768534 ***

Note You need to log in before you can comment on or make changes to this bug.