Bug 845442 - ACPI Warning SystemIO/lpc_ich/iTCO_wdt conflict messages
ACPI Warning SystemIO/lpc_ich/iTCO_wdt conflict messages
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-03 02:15 EDT by Stan King
Modified: 2013-06-03 15:16 EDT (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-03 15:16:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output of an affected system (67.41 KB, text/plain)
2012-08-03 02:15 EDT, Stan King
no flags Details
Dmesg output from 3.4.6 (working) (52.50 KB, text/plain)
2012-08-09 16:54 EDT, Bob Richmond
no flags Details
Dmesg output from 3.5.0 (broken) (55.32 KB, text/plain)
2012-08-09 16:57 EDT, Bob Richmond
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 44991 None None None 2012-08-03 02:15:08 EDT

  None (edit)
Description Stan King 2012-08-03 02:15:08 EDT
Created attachment 602070 [details]
dmesg output of an affected system

Description of problem:

After upgrading to kernel 3.5.0-2.fc17.x86_64, I get the following message sequence visible in the dmesg output (timestamps jremoved for clarity):

ACPI Warning: 0x0000000000001060-0x000000000000107f SystemIO conflicts with Region \_SB_.PCI0.VID_.TCOI 1 (20120320/utaddress-251)
ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
lpc_ich: Resource conflict(s) found affecting iTCO_wdt

Other machines with the Intel chipset actually get more errors at this point; a machine with an AMD processor and chipset does not have the problem.

Version-Release number of selected component (if applicable):

3.5.0-2.fc17.x86_64


How reproducible:

Every time.


Steps to Reproduce:
1. Boot an Intel-chipset machinen with a 3.5.0-2.fc17.x86_64 kernel
2.
3.
  
Actual results:

Complaints about conflicts, as seen above.

Expected results:

Something more like this, at least for this machine:

iTCO_vendor_support: vendor-support=0
iTCO_wdt: Intel TCO WatchDog Timer Driver v1.07
iTCO_wdt: Found a ICH8M TCO device (Version=2, TCOBASE=0x1060)
iTCO_wdt: initialized. heartbeat=30 sec (nowayout=0)

Additional info:

I suspect this is not a duplicate of RHBZ #789643, but it may well be a duplicate of kernel bugzilla 44991, https://bugzilla.kernel.org/show_bug.cgi?id=44991, which I'll add below, hoping that won't cause too many problems.
Comment 1 Benjamin Bellec 2012-08-09 07:31:42 EDT
I have the same errors since I upgraded to 3.5.0-2.fc17.x86_64.

dmesg (on a Gigabyte G33M-DS2R / ICH9R):
[   11.706194] ACPI Warning: 0x0000000000000460-0x000000000000047f SystemIO conflicts with Region \TCOI 1 (20120320/utaddress-251)
[   11.706201] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   11.706203] lpc_ich: Resource conflict(s) found affecting iTCO_wdt
[   11.706206] ACPI Warning: 0x0000000000000428-0x000000000000042f SystemIO conflicts with Region \GP2C 1 (20120320/utaddress-251)
[   11.706209] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   11.706244] lpc_ich: Resource conflict(s) found affecting gpio_ich
Comment 2 Bob Richmond 2012-08-09 16:51:55 EDT
I also get the same conflict messages after upgrading to 3.5.0-2.fc17.x86_64. In addition I get a general protection fault, the integrated sound hardware is no longer detected, and the boot process hangs ~75% of the time. Last working kernel was kernel-3.4.6-2.fc17.x86_64, which I'm running right now in the mean time. Attaching dmesg output between the two kernels.
Comment 3 Bob Richmond 2012-08-09 16:54:18 EDT
Created attachment 603347 [details]
Dmesg output from 3.4.6 (working)

Working kernel's dmesg output. Notice lack of "Resource conflict(s)" message and general protection fault.
Comment 4 Bob Richmond 2012-08-09 16:57:06 EDT
Created attachment 603352 [details]
Dmesg output from 3.5.0 (broken)

Broken kernel's dmesg output. Notice "Resource conflict(s)" message and general protection fault. And snd_hda_intel doesn't initialize.
Comment 5 Andrea Oliveri 2012-08-10 18:53:23 EDT
I have the same bug after i updated to 3.4.5 on ThinkPad T430
Comment 6 Account closed by user 2012-08-16 10:56:29 EDT
ThinkPad T61 and T60 also show this warning with 3.5.1-1.fc17.x86_64 :

[    6.006327] ACPI Warning: 0x0000000000001060-0x000000000000107f SystemIO conflicts with Region \_SB_.PCI0.LPC_.PMIO 1 (20120320/utaddress-251)
[    6.008555] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[    6.011045] lpc_ich: Resource conflict(s) found affecting iTCO_wdt
[    6.013679] ACPI Warning: 0x0000000000001028-0x000000000000102f SystemIO conflicts with Region \_SB_.PCI0.LPC_.PMIO 1 (20120320/utaddress-251)
[    6.016046] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[    6.018426] ACPI Warning: 0x0000000000001180-0x00000000000011bf SystemIO conflicts with Region \_SB_.PCI0.LPC_.LPIO 1 (20120320/utaddress-251)
Comment 8 Mostafa Afgani 2012-09-05 05:38:13 EDT
Same with Thinkpad E530 and 3.5.3-1.fc17.x86_64:

[   14.146231] ACPI Warning: 0x0000000000000460-0x000000000000047f SystemIO conflicts with Region \PMIO 1 (20120320/utaddress-251)
[   14.146236] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   14.146238] lpc_ich: Resource conflict(s) found affecting iTCO_wdt
[   14.146240] ACPI Warning: 0x0000000000000428-0x000000000000042f SystemIO conflicts with Region \PMIO 1 (20120320/utaddress-251)
[   14.146242] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   14.146245] ACPI Warning: 0x0000000000000500-0x000000000000053f SystemIO conflicts with Region \GPIO 1 (20120320/utaddress-251)
[   14.146247] ACPI Warning: 0x0000000000000500-0x000000000000053f SystemIO conflicts with Region \_SB_.PCI0.PEG0.PEGP.GPIO 2 (20120320/utaddress-251)
[   14.146250] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   14.146250] lpc_ich: Resource conflict(s) found affecting gpio_ich
[   14.526240] ACPI Warning: 0x000000000000efa0-0x000000000000efbf SystemIO conflicts with Region \_SB_.PCI0.SBUS.SMBI 1 (20120320/utaddress-251)
[   14.526245] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
Comment 9 Jason Burgess 2012-10-08 14:09:56 EDT
Same here - systemd reaches local file system target boot point and boot sequence hangs, eventually times out with (notice the kernel message times):

Oct  8 14:33:13 jacknife2 kernel: [   12.009936] ppdev: user-space parallel port driver
Oct  8 14:33:13 jacknife2 kernel: [   12.422766] i2c i2c-3: >nForce2 SMBus adapter at 0x4c00
Oct  8 14:33:13 jacknife2 kernel: [   12.431779] i2c i2c-4: >nForce2 SMBus adapter at 0x4c40
Oct  8 14:33:13 jacknife2 kernel: [   12.504176] usbcore: registered new interface driver pl2303
Oct  8 14:33:13 jacknife2 kernel: [   12.508964] USB Serial support registered for pl2303
Oct  8 14:33:13 jacknife2 kernel: [   12.512802] pl2303 2-2:1.0: >pl2303 converter detected
Oct  8 14:33:13 jacknife2 kernel: [   12.548335] usb 2-2: >pl2303 converter now attached to ttyUSB0
Oct  8 14:33:13 jacknife2 kernel: [   13.931252] Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
Oct  8 14:33:13 jacknife2 kernel: [   15.001863] ACPI: PCI Interrupt Link [APCJ] enabled at IRQ 22
Oct  8 14:33:13 jacknife2 kernel: [   15.337044] intel8x0_measure_ac97_clock: measured 50214 usecs (2472 samples)
Oct  8 14:33:13 jacknife2 kernel: [   15.340876] intel8x0: clocking to 46801
Oct  8 14:33:13 jacknife2 kernel: [   15.604253] device label /smallfile_vol devid 1 transid 1759054 /dev/sda2
Oct  8 14:33:13 jacknife2 kernel: [   15.774584] btrfs: bdev /dev/sda2 errs: wr 0, rd 0, flush 0, corrupt 0, gen 0
Oct  8 14:33:13 jacknife2 kernel: [   15.815860] Adding 4040340k swap on /dev/sda4.  Priority:0 extents:1 across:4040340k 
Oct  8 14:33:13 jacknife2 kernel: [   16.056341] device label /largefile_vol devid 1 transid 174939 /dev/sda3
Oct  8 14:33:13 jacknife2 kernel: [   16.093328] btrfs: bdev /dev/sda3 errs: wr 0, rd 0, flush 0, corrupt 0, gen 0
Oct  8 14:33:13 jacknife2 kernel: [   16.227924] device label /backup devid 1 transid 64096 /dev/sdb1
Oct  8 14:33:13 jacknife2 kernel: [   16.303056] btrfs: bdev /dev/sdb1 errs: wr 0, rd 0, flush 0, corrupt 0, gen 0

[ system stops the boot sequence at this point and the system clock seems to stop, notice the date of the syslog entries ]

(tick tock tick tock)

[ eventually when system resumes these are the messages that occur]

Oct  8 14:33:13 jacknife2 kernel: [   99.457456] it87: Found IT8712F chip at 0x290, revision 7
Oct  8 14:33:13 jacknife2 kernel: [   99.457463] it87: VID is disabled (pins used for GPIO)
Oct  8 14:33:13 jacknife2 kernel: [   99.457838] ACPI Warning: 0x00000295-0x00000296 SystemIO conflicts with Region \IP__ 1 0120320/utaddress-251)
Oct  8 14:33:13 jacknife2 kernel: [   99.457844] ACPI Warning: 0x00000295-0x00000296 SystemIO conflicts with Region \_SB_.PCI0.ASOC.HWRE 2 (20120320/utaddress-251)
Oct  8 14:33:13 jacknife2 kernel: [   99.457848] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver


System is as follows:

Kernel: 3.5.5-2.fc17.i686
CPU: AMD Athlon(tm) 64 Processor 3200+ (yes its an old system)
Memory: 2GB, DDR 400
MB: ASUS A8N

/etc/sysconfig# lspci
00:00.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a3)
00:01.0 ISA bridge: nVidia Corporation CK804 ISA Bridge (rev a3)
00:01.1 SMBus: nVidia Corporation CK804 SMBus (rev a2)
00:02.0 USB Controller: nVidia Corporation CK804 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation CK804 USB Controller (rev a3)
00:04.0 Multimedia audio controller: nVidia Corporation CK804 AC'97 Audio Controller (rev a2)
00:06.0 IDE interface: nVidia Corporation CK804 IDE (rev f2)
00:07.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:08.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:09.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev a2)
00:0a.0 Bridge: nVidia Corporation CK804 Ethernet Controller (rev a3)
00:0b.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0c.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0d.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: ATI Technologies Inc RV370 [Sapphire X550 Silent]
01:00.1 Display controller: ATI Technologies Inc RV370 secondary [Sapphire X550 Silent]
05:06.0 Ethernet controller: Intel Corporation 82541PI Gigabit Ethernet Controller (rev 05)
05:0b.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22A IEEE-1394a-2000 Controller (PHY/Link) [iOHCI-Lynx]
05:0c.0 Ethernet controller: Marvell Technology Group Ltd. 88E8001 Gigabit Ethernet Controller (rev 13)
Comment 10 Albert Strasheim 2012-11-05 06:57:19 EST
Dell Latitude E6430

kernel 3.6.3-1.fc17.x86_64

[    9.321727] ACPI Warning: 0x000000000000f000-0x000000000000f01f SystemIO conflicts with Region \_SB_.PCI0.SBUS.SMBI 1 (20120711/utaddress-251)
[    9.321739] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[    9.321910] ACPI Warning: 0x0000000000000428-0x000000000000042f SystemIO conflicts with Region \PMIO 1 (20120711/utaddress-251)
[    9.321923] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[    9.321932] ACPI Warning: 0x0000000000000500-0x000000000000053f SystemIO conflicts with Region \GPIO 1 (20120711/utaddress-251)
[    9.321940] ACPI Warning: 0x0000000000000500-0x000000000000053f SystemIO conflicts with Region \_SB_.PCI0.PEG0.VID_.GPSP 2 (20120711/utaddress-251)
[    9.321947] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[    9.321949] lpc_ich: Resource conflict(s) found affecting gpio_ich
Comment 11 Albert Strasheim 2012-11-05 06:59:15 EST
Looks like the Dell one might be fixed:

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux.git;a=commitdiff;h=4f600ada70beeb1dfe08e11e871bf31015aa0a3d
Comment 12 Marc-Andre Laverdiere 2012-11-08 10:04:06 EST
I am having this bug too on Fedora 17 KDE on my Gateway system.

[   14.268225] ACPI Warning: 0x0000000000000428-0x000000000000042f SystemIO conflicts with Region \PMIO 1 (20120711/utaddress-251)
[   14.268234] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   14.268239] ACPI Warning: 0x0000000000000500-0x000000000000057f SystemIO conflicts with Region \GPIO 1 (20120711/utaddress-251)
[   14.268245] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   14.268247] lpc_ich: Resource conflict(s) found affecting gpio_ich

Note that I am having some random crashes which may or may not be due to this.
Comment 13 rick 2012-11-17 12:27:42 EST
#
# from dmesg
#
[   27.174422] ACPI Warning: 0x0000000000000828-0x000000000000082f SystemIO conflicts with Region \PMRG 1 (20120711/utaddress-251)
[   27.174424] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   27.174427] ACPI Warning: 0x0000000000000500-0x000000000000053f SystemIO conflicts with Region \GPS0 1 (20120711/utaddress-251)
[   27.174427] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   27.174428] lpc_ich: Resource conflict(s) found affecting gpio_ich
[   27.174479] ACPI Warning: 0x0000000000000400-0x000000000000041f SystemIO conflicts with Region \SMRG 1 (20120711/utaddress-251)
[   27.174480] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver


##########

...seems similar enough to add the above...an ASUS P6x58-e WS mobo...and also seeing intermittent hangs and spontaneous remounts of OS partitions to RO status...but as poster above stated, can't be sure 'SystemIO conflicts with' is the cause

...does anyone know if enabling ACPI 2.0 support in the BIOS is now a good thing or is 1.1 still preferred?
Comment 14 rick 2012-11-17 12:38:18 EST

WRT above, forget to include info: current F17 with 3.6.6-1.fc17.x86_64
Comment 15 John Paul Adrian Glaubitz 2012-12-23 08:34:21 EST
I get a similar message with an ASUS P8B-C/4L and a Soundblaster Live (PCI-ID: 1102:0002/7002)

[   27.171787] ACPI Warning: 0x0000000000000500-0x000000000000057f SystemIO conflicts with Region \_SB_.PCI0.SBRG.GPBX 1 (20120711/utaddress-251)
[   27.171940] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver

Kernel is 3.6.9.

Adrian
Comment 16 Iestyn Elfick 2013-03-14 08:08:28 EDT
Similar on 3.8.2-206 (Fedora 18) on Dell Studio 17:

[   13.920813] ACPI Warning: 0x0000000000000428-0x000000000000042f SystemIO conflicts with Region \PMIO 1 (20121018/utaddress-251)
[   13.920820] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   13.920824] ACPI Warning: 0x00000000000011c0-0x00000000000011cf SystemIO conflicts with Region \GPIO 1 (20121018/utaddress-251)
[   13.920829] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   13.920830] ACPI Warning: 0x00000000000011b0-0x00000000000011bf SystemIO conflicts with Region \GPIO 1 (20121018/utaddress-251)
[   13.920834] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   13.920836] ACPI Warning: 0x0000000000001180-0x00000000000011af SystemIO conflicts with Region \GPIO 1 (20121018/utaddress-251)
[   13.920839] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   13.920841] lpc_ich: Resource conflict(s) found affecting gpio_ich

Core i7 Q720 CPU.
Comment 17 Andrea Oliveri 2013-05-22 09:13:52 EDT
Similar on Fedora 18 3.9.2-200.fc18.x86_64 on ThinkPad T430 
ACPI Warning: 0x0000000000000428-0x000000000000042f SystemIO conflicts with Region \_SB_.PCI0.LPC_.PMIO 1 (20130117/utaddress-251)
ACPI Warning: 0x0000000000000530-0x000000000000053f SystemIO conflicts with Region \_SB_.PCI0.LPC_.LPIO 1 (20130117/utaddress-251)
ACPI Warning: 0x0000000000000500-0x000000000000052f SystemIO conflicts with Region \_SB_.PCI0.LPC_.LPIO 1 (20130117/utaddress-251
Comment 18 Josh Boyer 2013-06-03 15:16:42 EDT
As far as we can tell, these are just annoying informational messages.  If something is actually not working as expected, please open a new bug describing the actual error behavior.

Note You need to log in before you can comment on or make changes to this bug.