Bug 845457 - kdelibs-6:4.8.4-8.fc17.i686 requires docbook-style-xsl
kdelibs-6:4.8.4-8.fc17.i686 requires docbook-style-xsl
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-03 03:00 EDT by Nikolai Iorgov
Modified: 2014-01-21 18:23 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-20 16:23:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikolai Iorgov 2012-08-03 03:00:36 EDT
Description of problem:

After 'yum update' I get:

....

Resolving Dependencies
--> Running transaction check
---> Package kdelibs.i686 6:4.8.4-5.fc17 will be updated
---> Package kdelibs.i686 6:4.8.4-8.fc17 will be an update
---> Package kdelibs-common.i686 6:4.8.4-5.fc16 will be updated
---> Package kdelibs-common.i686 6:4.8.4-5.fc17 will be updated
---> Package kdelibs-common.i686 6:4.8.4-8.fc17 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package               Arch        Version                 Repository      Size
================================================================================
Updating:
 kdelibs               i686        6:4.8.4-8.fc17          updates         11 M
 kdelibs-common        i686        6:4.8.4-8.fc17          updates        1.8 M

Transaction Summary
================================================================================
Upgrade  2 Packages

Total size: 13 M
Is this ok [y/N]: Downloading Packages:
Running Transaction Check
ERROR with transaction check vs depsolve:
docbook-style-xsl is needed by kdelibs-6:4.8.4-8.fc17.i686

Version-Release number of selected component (if applicable):

yum --version

3.4.3

  Installed: rpm-4.9.1.3-7.fc17.i686 at 2012-08-02 23:28
  Built    : Fedora Project at 2012-05-07 10:06
  Committed: Panu Matilainen <pmatilai@redhat.com> at 2012-05-07

  Installed: yum-3.4.3-28.fc17.noarch at 2012-08-02 21:12
  Built    : Fedora Project at 2012-06-25 08:15
  Committed: Zdenek Pavlas <zpavlas at redhat.com> at 2012-06-25

  Installed: yum-plugin-fastestmirror-1.1.31-4.fc17.noarch at 2012-07-26 23:58
  Built    : Fedora Project at 2012-01-26 20:48
  Committed: James Antill <james@fedoraproject.org> at 2012-01-26



How reproducible:
every time

Steps to Reproduce:
1. yum update
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Nikolai Iorgov 2012-08-03 03:21:59 EDT
In fact I had a problem with docbook-style-xsl when I was upgrading from Fedora 16 to Fedora 17. Upgrading was stopped at this file and I tried to solve the problem manually (I do not remember details, maybe it was something like rpm --nodeps). Now I have installed kdelibs and there is no docbook-style-xsl at all.

Now I can not install docbook-style-xsl because of an error:

" ....
Error unpacking rpm package docbook-style-xsl-1.76.1-5.fc17.noarch
error: unpacking of archive failed on file /usr/share/sgml/docbook/xsl-stylesheets-1.76.1/common/bn_in.xml: cpio: rename
..."

but probably it is an another story/bug.
Comment 2 Nikolai Iorgov 2012-08-06 04:04:11 EDT
[root@localhost ~]# yum reinstall kdelibs-4.8.4-5.fc17.i686

Loaded plugins: auto-update-debuginfo, fastestmirror, langpacks, presto, refresh-packagekit
Loading mirror speeds from cached hostfile
 * fedora: ftp.colocall.net
 * fedora-debuginfo: ftp.tlk-l.net
 * rpmfusion-free: mirror.yandex.ru
 * rpmfusion-free-debuginfo: mirror.yandex.ru
 * rpmfusion-free-updates: mirror.yandex.ru
 * rpmfusion-free-updates-debuginfo: mirror.yandex.ru
 * rpmfusion-nonfree: mirror.yandex.ru
 * rpmfusion-nonfree-debuginfo: mirror.yandex.ru
 * rpmfusion-nonfree-updates: mirror.yandex.ru
 * rpmfusion-nonfree-updates-debuginfo: mirror.yandex.ru
 * updates: ftp.colocall.net
 * updates-debuginfo: mirror.yandex.ru
Installed package 6:kdelibs-4.8.4-5.fc17.i686 (from anaconda-0) not available.
Error: Nothing to do


[root@localhost ~]# yum check
Loaded plugins: auto-update-debuginfo, fastestmirror, langpacks, presto, refresh-packagekit
6:kdelibs-4.8.4-5.fc17.i686 has missing requires of docbook-style-xsl
Error: check all
Comment 3 Nikolai Iorgov 2012-08-06 05:29:32 EDT
[root@localhost ~]# yum erase kdelibs

.....
Removed:
  kdelibs.i686 6:4.8.4-5.fc17                                                                                                               

Dependency Removed:
  kate-part.i686 0:4.8.4-1.fc17            
  kde-baseapps.i686 0:4.8.4-1.fc17                 
  kde-baseapps-libs.i686 0:4.8.4-1.fc17         
  kde-runtime.i686 0:4.8.4-2.fc17          
  kde-runtime-flags.noarch 0:4.8.4-2.fc17          
  kde-runtime-libs.i686 0:4.8.4-2.fc17          
  kdepimlibs.i686 0:4.8.4-1.fc17           
  kdepimlibs-akonadi.i686 0:4.8.4-1.fc17           
  kile.i686 0:2.1.2-2.fc17                      
  kio_msits.i686 7:4.8.4-1.fc17            
  konsole.i686 0:4.8.4-1.fc17                      
  konsole-part.i686 0:4.8.4-1.fc17              
  kwrite.i686 0:4.8.4-1.fc17               
  okular.i686 0:4.8.4-1.fc17                       
  okular-libs.i686 0:4.8.4-1.fc17               
  okular-part.i686 0:4.8.4-1.fc17         

[root@localhost ~]# yum install kdelibs
....
Dependencies Resolved

============
Installing:
 kdelibs     i686      6:4.8.4-8.fc17    updates     11 M
Installing for dependencies:
 docbook-style-xsl   noarch 1.76.1-5.fc17  fedora    2.3 M
Updating for dependencies:
 kdelibs-common     i686   6:4.8.4-8.fc17  updates   1.8 M

Transaction Summary
===========================================================
Install  1 Package  (+1 Dependent package)
Upgrade             ( 1 Dependent package)

...


Transaction Test Succeeded
Running Transaction
  Installing : docbook-style-xsl-1.76.1-5.fc17.noarch                1/4 
Error unpacking rpm package docbook-style-xsl-1.76.1-5.fc17.noarch
error: unpacking of archive failed on file /usr/share/sgml/docbook/xsl-stylesheets-1.76.1/common/bn_in.xml: cpio: rename
  Updating   : 6:kdelibs-common-4.8.4-8.fc17.i686                    2/4 
error: docbook-style-xsl-1.76.1-5.fc17.noarch: install failed
  Installing : 6:kdelibs-4.8.4-8.fc17.i686                           3/4 
  Cleanup    : 6:kdelibs-common-4.8.4-5.fc17.i686                    4/4 
  Verifying  : 6:kdelibs-4.8.4-8.fc17.i686                           1/4 
  Verifying  : 6:kdelibs-common-4.8.4-8.fc17.i686                    2/4 
  Verifying  : 6:kdelibs-common-4.8.4-5.fc17.i686                    3/4 
  Verifying  : docbook-style-xsl-1.76.1-5.fc17.noarch                4/4 

Installed:
  kdelibs.i686 6:4.8.4-8.fc17                                                                                                               

Dependency Updated:
  kdelibs-common.i686 6:4.8.4-8.fc17                                                                                                        

Failed:
  docbook-style-xsl.noarch 0:1.76.1-5.fc17    

*******************

kdelibs.i686 of version 4.8.4-8.fc17 already requires 
docbook-style-xsl.noarch 0:1.76.1-5.fc17.
Maybe it was a problem with kdelibs.i686 of version 4.8.4-5.fc17 which is now not available.

I have such questions:
Is it normal that "kdelibs" can be installed without "docbook-style-xsl" ?
Will it lead in the future to the same problem
<ERROR with transaction check vs depsolve> when I will update to future versions of "kdelibs"?
Comment 4 Nikolai Iorgov 2012-08-20 07:02:58 EDT
With updating to a new version of kdelibs (4.8.5-1.fc17) I get the same problem:

"
....

ERROR with transaction check vs depsolve:
docbook-style-xsl is needed by kdelibs-6:4.8.5-1.fc17.i686
Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum

..."

The previous version of kdelibs-4.8.4-8.fc17.i686 was with a problem of installation of docbook-style-xsl.noarch 0:1.76.1-5.fc17 needed for dependencies.

Now when I am updating "kdelibs", I think, "yum" suppose that all was OK with previous version of "kdelibs" and this lead to "ERROR with transaction check vs depsolve".
Comment 5 James Antill 2012-08-20 16:23:56 EDT
Use: yum reinstall kdelibs ... or the newer option:

yum upgrade --setopt=recheck_installed_requires=true (not 100% that is in the F17 yum though).

...or just manually do:

yum install docbook-style-xsl

Note You need to log in before you can comment on or make changes to this bug.