This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 845507 - Remote-viewer zoom shortcuts not usable
Remote-viewer zoom shortcuts not usable
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-03 05:24 EDT by Tomas Jamrisko
Modified: 2012-08-03 06:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-03 05:36:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Jamrisko 2012-08-03 05:24:50 EDT
Description of problem:

remote-viewer has keyboard shortcuts assigned to zooming (in, out, normal size), the problem is, that they always get registered by the guest.

Version-Release number of selected component (if applicable):
virt-viewer-0.5.3-1.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Connect to a VM with any functional OS
2. Try Zooming using ctrl++ and ctrl+-
  
Actual results:

Keyboard shortcuts get grabbed by the guest, thus remote-viewer doesn't do anything


Expected results:
Shortcuts for zooming should not be assigned/displayed in remote-viewer as they are misleading
Comment 1 Daniel Berrange 2012-08-03 05:36:05 EDT
The guest only gets the keyboard input if the mouse is explicitly over the guest window region. If the virt-viewer window has keyboard focus and the mouse is over the desktop, or over the menu bar the short cuts work just fine.
Comment 2 Tomas Jamrisko 2012-08-03 06:01:43 EDT
Ok, so a minor update. It does work with +/- on alfanumerical keyboard, doesn't work with +/- on numerical one

Note You need to log in before you can comment on or make changes to this bug.