Bug 845611 - Subscriptions are not current message is confusing for system with insufficient subscriptions
Subscriptions are not current message is confusing for system with insufficie...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Adam Price
Og Maciel
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-03 11:07 EDT by Og Maciel
Modified: 2013-08-16 14:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-12 10:20:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (133.76 KB, image/png)
2012-08-03 11:07 EDT, Og Maciel
no flags Details
The other screenshot is incorrect, use this one (62.57 KB, image/png)
2012-08-03 11:22 EDT, Og Maciel
no flags Details

  None (edit)
Description Og Maciel 2012-08-03 11:07:47 EDT
Created attachment 602148 [details]
Screenshot

Description of problem:

If a system does not have sufficient subscriptions to make it compliant ("green"), we current display the following message in the system's Subscription panel:

Subscriptions are not Current

I'd argue that a better message could be:

"System does not have sufficient subscriptions to make it compliant" but better worded :)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Subscribe a system with multiple cpu sockets
2. Subscribe to products that do not provide enough sockets
3.
  
Actual results:

See screenshot attached

Expected results:

Clear/better message

Additional info:
Comment 1 Og Maciel 2012-08-03 11:11:36 EDT
Version-Release number of selected component (if applicable):
* candlepin-0.5.32-1.el6.noarch
* candlepin-tomcat6-0.5.32-1.el6.noarch
* katello-1.1.2-1.git.2.22b3375.el6_3.noarch
* katello-all-1.1.2-1.git.2.22b3375.el6_3.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.1.6-1.el6.noarch
* katello-cli-1.1.0-1.git.13.d10e8a3.el6_3.noarch
* katello-cli-common-1.1.0-1.git.13.d10e8a3.el6_3.noarch
* katello-common-1.1.2-1.git.2.22b3375.el6_3.noarch
* katello-configure-1.1.1-1.git.0.3794e67.el6_3.noarch
* katello-glue-candlepin-1.1.2-1.git.2.22b3375.el6_3.noarch
* katello-glue-foreman-1.1.2-1.git.2.22b3375.el6_3.noarch
* katello-glue-pulp-1.1.2-1.git.2.22b3375.el6_3.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-0.2.6-1.el6.noarch
* pulp-1.1.11-1.el6.noarch
* pulp-common-1.1.11-1.el6.noarch
* pulp-selinux-server-1.1.11-1.el6.noarch
Comment 2 Og Maciel 2012-08-03 11:22:07 EDT
Created attachment 602158 [details]
The other screenshot is incorrect, use this one

The other screenshot is incorrect, use this one
Comment 5 Dmitri Dolguikh 2012-09-27 11:55:13 EDT
marking as 'on_qa'
Comment 6 Og Maciel 2012-09-28 17:50:55 EDT
Insufficient Subscriptions are Attached to This System is what shows up now.

Verified using:

* candlepin-0.7.8-1.el6cf.noarch
* candlepin-selinux-0.7.8-1.el6cf.noarch
* candlepin-tomcat6-0.7.8-1.el6cf.noarch
* katello-1.1.12-9.el6cf.noarch
* katello-all-1.1.12-9.el6cf.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.1.8-1.el6cf.noarch
* katello-cli-1.1.8-5.el6cf.noarch
* katello-cli-common-1.1.8-5.el6cf.noarch
* katello-common-1.1.12-9.el6cf.noarch
* katello-configure-1.1.9-4.el6cf.noarch
* katello-glue-candlepin-1.1.12-9.el6cf.noarch
* katello-glue-pulp-1.1.12-9.el6cf.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.1.1-1.el6cf.noarch
* pulp-1.1.12-1.el6cf.noarch
* pulp-common-1.1.12-1.el6cf.noarch
* pulp-selinux-server-1.1.12-1.el6cf.noarch
Comment 7 James Laska 2012-12-12 10:20:05 EST
CloudForms-1.1 shipped with katello-1.1.12-22.el6cf, candlepin-0.7.8.1-1.el6cf  and pulp-1.1.14-1.el6cf

Marking this bug CLOSED CURRENTRELEASE.  Please reopen if the problem has not   been addressed in the 1.1 product.
Comment 8 Mike McCune 2013-08-16 14:13:53 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.