Bug 845618 - [abrt] Incorrect symbol resolution, load_interfaces()
[abrt] Incorrect symbol resolution, load_interfaces()
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openchange (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:04f8c4d0716e8812d2055e309a1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-03 11:20 EDT by Canyon Bliss
Modified: 2012-08-17 21:25 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-17 21:25:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (81.94 KB, text/plain)
2012-08-03 11:20 EDT, Canyon Bliss
no flags Details
File: maps (85.33 KB, text/plain)
2012-08-03 11:20 EDT, Canyon Bliss
no flags Details
File: dso_list (18.98 KB, text/plain)
2012-08-03 11:20 EDT, Canyon Bliss
no flags Details
File: build_ids (7.85 KB, text/plain)
2012-08-03 11:20 EDT, Canyon Bliss
no flags Details

  None (edit)
Description Canyon Bliss 2012-08-03 11:20:20 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/libexec/evolution-addressbook-factory
comment:        Start evolution and it imediately seg faults.
core_backtrace: 
crash_function: load_interfaces
executable:     /usr/libexec/evolution-addressbook-factory
kernel:         3.5.0-2.fc17.x86_64
pid:            5278
pwd:            /
remote_result:  NOTFOUND
time:           Fri 03 Aug 2012 11:04:02 AM EDT
uid:            1014
username:       canyon
xsession_errors: 

backtrace:      Text file, 83908 bytes
build_ids:      Text file, 8036 bytes
dso_list:       Text file, 19435 bytes
maps:           Text file, 87381 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/canyon/2

environ:
:SHELL=/bin/bash
:DBUS_STARTER_ADDRESS=unix:abstract=/tmp/dbus-ejERQa0XrF,guid=1f5220be7678a4b5f49cb9230000007e
:XDG_RUNTIME_DIR=/run/user/canyon
:DISPLAY=:0
:DESKTOP_SESSION=gnome
:SSH_AUTH_SOCK=/run/user/canyon/keyring-HX0L2L/ssh
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1418,unix/unix:/tmp/.ICE-unix/1418
:WINDOWPATH=1
:PATH=/usr/local/bin:/usr/bin:/bin
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:GDMSESSION=gnome
:XDG_VTNR=1
:USERNAME=canyon
:XDG_SESSION_ID=2
:GPG_AGENT_INFO=/run/user/canyon/keyring-HX0L2L/gpg:0:1
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-ejERQa0XrF,guid=1f5220be7678a4b5f49cb9230000007e
:XDG_SEAT=seat0
:XAUTHORITY=/var/run/gdm/auth-for-canyon-DlhH4i/database
:USER=canyon
:DBUS_STARTER_BUS_TYPE=session
:GNOME_KEYRING_PID=1414
:SHLVL=1
:PWD=/home/canyon
:GDM_LANG=en_US.utf8
:GNOME_KEYRING_CONTROL=/run/user/canyon/keyring-HX0L2L
:LANG=en_US.utf8
:_=/usr/bin/dbus-launch
:LOGNAME=canyon
:HOME=/home/canyon

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 31365                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       31365                31365                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100002
:1:/dev/null
:pos:	0
:flags:	0100002
:2:/dev/null
:pos:	0
:flags:	0100002
:3:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:4:/dev/null
:pos:	0
:flags:	0100002
:5:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:6:socket:[457594]
:pos:	0
:flags:	04002
:7:socket:[457595]
:pos:	0
:flags:	02004002
:8:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:9:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:10:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:11:/dev/urandom
:pos:	0
:flags:	02100000
:12:socket:[457607]
:pos:	0
:flags:	02000002

smolt_data:
:
:
:General
:=================================
:UUID: 41e9d09c-77bf-4130-8af0-3d20ce1c4d1b
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: x86_64
:BogoMIPS: 6784.24
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz
:CPU Stepping: 9
:CPU Family: 6
:CPU Model Num: 58
:Number of CPUs: 8
:CPU Speed: 3401
:System Memory: 3932
:System Swap: 8191
:Vendor: Unknown
:System:  
:Form factor: Desktop
:Kernel: 3.5.0-2.fc17.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4147:404:32902:8194) pci, xhci_hcd, USB, uPD720200 USB 3.0 Host Controller
:(32902:7202:32902:8194) pci, i801_smbus, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(32902:7190:32902:8194) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 4
:(32902:7184:32902:8194) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7242:32902:8194) pci, lpc_ich, PCI/ISA, H67 Express Chipset Family LPC Controller
:(4318:4160:6618:4629) pci, nouveau, VIDEO, N/A
:(32902:7200:32902:8194) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(32902:5379:32902:8194) pci, e1000e, ETHERNET, 82579V Gigabit Network Connection
:(4318:3592:6618:4629) pci, snd_hda_intel, MULTIMEDIA, HDMI Audio stub
:(4739:34962:32902:8194) pci, None, PCI/PCI, N/A
:(32902:7170:32902:8194) pci, ahci, STORAGE, 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller
:(32902:7213:32902:8194) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2
:(32902:7206:32902:8194) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(32902:336:32902:8194) pci, None, HOST/PCI, Ivy Bridge DRAM Controller
:(32902:7226:32902:8194) pci, mei, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:(32902:337:32902:8194) pci, pcieport, PCI/PCI, Ivy Bridge PCI Express Root Port
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_odic-lv_root / ext4 4096 4096 13081025 5529075 4873715 3276800 2858790 2858790
:/dev/sdb1 /boot ext4 4096 4096 261305 230269 217162 65536 65131 65131
:/dev/mapper/luks-d35664e9-b1cb-4a6c-b6ab-c7db5167b5e5 /home ext4 4096 4096 23031194 20180013 19026605 5767168 5398464 5398464
:/dev/sr0 WITHHELD udf 2048 2048 20012 0 0 4 0 0
:

var_log_messages:
:Aug  2 11:43:35 canyon abrt[1905]: Saved core dump of pid 1857 (/usr/libexec/evolution-addressbook-factory) to /var/spool/abrt/ccpp-2012-08-02-11:43:34-1857 (94810112 bytes)
:Aug  2 15:55:18 canyon abrt[1878]: Saved core dump of pid 1792 (/usr/libexec/evolution-addressbook-factory) to /var/spool/abrt/ccpp-2012-08-02-15:55:17-1792 (68997120 bytes)
:Aug  2 16:03:13 canyon abrt[1886]: Saved core dump of pid 1800 (/usr/libexec/evolution-addressbook-factory) to /var/spool/abrt/ccpp-2012-08-02-16:03:13-1800 (69001216 bytes)
:Aug  3 11:04:03 canyon abrt[5294]: Saved core dump of pid 5278 (/usr/libexec/evolution-addressbook-factory) to /var/spool/abrt/ccpp-2012-08-03-11:04:02-5278 (87445504 bytes)
Comment 1 Canyon Bliss 2012-08-03 11:20:27 EDT
Created attachment 602154 [details]
File: backtrace
Comment 2 Canyon Bliss 2012-08-03 11:20:29 EDT
Created attachment 602155 [details]
File: maps
Comment 3 Canyon Bliss 2012-08-03 11:20:32 EDT
Created attachment 602156 [details]
File: dso_list
Comment 4 Canyon Bliss 2012-08-03 11:20:34 EDT
Created attachment 602157 [details]
File: build_ids
Comment 5 Milan Crha 2012-08-06 04:42:19 EDT
Thanks for a bug report. I see from the backtrace that this crashed in nss_wins_init() call being done by samba or samba4 code. It calls load_interfaces(), which is defined in two modules, one is openchange, the other is samba itself. The problem is that the system decided to call function from openchange, while it should call the one from samba.

A workaround would be to uninstall openchange, though if you are using evolution-mapi, then it's not an option, probably.
Comment 6 Alexander Bokovoy 2012-08-06 05:04:21 EDT
From what I see this is purely libmapi issue. jkerihuel imported incompatible load_interfaces() from samba4 at some point. Since then Samba went different way and when samba 3 and samba 4 code bases were merged, there is only single load_interfaces() in Samba, with (void) parameter list.

Here is the commit:
http://websvn.openchange.org/comp.php?repname=OpenChange&path=%2F&compare[]=%2Ftrunk%2Flibmapi%2Fsocket@298&compare[]=%2Ftrunk%2Flibmapi%2Fsocket%2F@342

I'd suggest to work with Openchange upstream to rename load_interfaces to something different. As libmapi/socket/interface.c was imported from Samba but is not the same anymore, it is little sense to maintain compatibility within the file. Also, libmapi will likely get into this conflict on almost all systems where wins NSS module is in use, even with older Samba.
Comment 7 Alexander Bokovoy 2012-08-06 05:09:12 EDT
Moving to openchange component, I believe it is upstream OpenChange issue.

Milan, please discuss it with Julien. I'm on vacation this week but will be back by August 10th.
Comment 8 Milan Crha 2012-08-06 06:01:56 EDT
Sure, thanks. I'll file a bug at upstream OpenChange tracker and provide updated package for F17 and rawhide.
Comment 9 Milan Crha 2012-08-06 06:31:09 EDT
You can see the upstream filled bug here [1], and I'm currently building new OpenChange packages. When it's done, I'll create an update for Fedora 17.

[1] http://tracker.openchange.org/issues/398
Comment 10 Fedora Update System 2012-08-06 06:42:42 EDT
openchange-1.0-9.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/openchange-1.0-9.fc17
Comment 11 Canyon Bliss 2012-08-06 11:42:56 EDT
(In reply to comment #5)
> Thanks for a bug report. I see from the backtrace that this crashed in
> nss_wins_init() call being done by samba or samba4 code. It calls
> load_interfaces(), which is defined in two modules, one is openchange, the
> other is samba itself. The problem is that the system decided to call
> function from openchange, while it should call the one from samba.
> 
> A workaround would be to uninstall openchange, though if you are using
> evolution-mapi, then it's not an option, probably.

That makes sense about samba4; the problem did start after I upgraded to samba4. Unfortunately, I am using evolution-mapi so uninstalling openchange is not an option. I could move to evolution-ews, which seems to work fine on another system.
Comment 12 Canyon Bliss 2012-08-06 11:53:29 EDT
(In reply to comment #10)
> openchange-1.0-9.fc17 has been submitted as an update for Fedora 17.
> https://admin.fedoraproject.org/updates/openchange-1.0-9.fc17

The openchange-1.0-9.fc17 update seems to have fixed the issue, thanks! I already left karma/feedback.
Comment 13 Milan Crha 2012-08-07 03:21:30 EDT
(In reply to comment #12)
> The openchange-1.0-9.fc17 update seems to have fixed the issue, thanks! I
> already left karma/feedback.

Thanks. The update will be pushed for stable in a week or two, unless karma makes it sooner.
Comment 14 Fedora Update System 2012-08-09 18:49:00 EDT
Package openchange-1.0-9.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openchange-1.0-9.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11549/openchange-1.0-9.fc17
then log in and leave karma (feedback).
Comment 15 Fedora Update System 2012-08-17 21:25:38 EDT
openchange-1.0-9.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.