Bug 845630 - Subscription links for auto-subscribed system were pointing to incorrect destination
Subscription links for auto-subscribed system were pointing to incorrect dest...
Status: CLOSED WORKSFORME
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Adam Price
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-03 11:54 EDT by Og Maciel
Modified: 2013-08-16 14:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-26 16:35:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Og Maciel 2012-08-03 11:54:28 EDT
Description of problem:

Somehow, when I registered one of my systems and it got automatically subscribed (default behavior) to the organization's available subscriptions, clicking the individual subscriptions' link in the Subscriptions panel took me to the Custom Provider's page. The correct behavior is to take me to the Red Hat Subscriptions page and select the corresponding subscription.

Version-Release number of selected component (if applicable):

* candlepin-0.5.32-1.el6.noarch
* candlepin-tomcat6-0.5.32-1.el6.noarch
* katello-1.1.2-1.git.2.22b3375.el6_3.noarch
* katello-all-1.1.2-1.git.2.22b3375.el6_3.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.1.6-1.el6.noarch
* katello-cli-1.1.0-1.git.13.d10e8a3.el6_3.noarch
* katello-cli-common-1.1.0-1.git.13.d10e8a3.el6_3.noarch
* katello-common-1.1.2-1.git.2.22b3375.el6_3.noarch
* katello-configure-1.1.1-1.git.0.3794e67.el6_3.noarch
* katello-glue-candlepin-1.1.2-1.git.2.22b3375.el6_3.noarch
* katello-glue-foreman-1.1.2-1.git.2.22b3375.el6_3.noarch
* katello-glue-pulp-1.1.2-1.git.2.22b3375.el6_3.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-0.2.6-1.el6.noarch
* pulp-1.1.11-1.el6.noarch
* pulp-common-1.1.11-1.el6.noarch
* pulp-selinux-server-1.1.11-1.el6.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Adam Price 2012-08-13 17:28:30 EDT
Og, could verify this issue is still present? I registered a system on auto and then clicked on its subscription link, which took me to the corresponding subscription on the Subscriptions page. thanks.
Comment 2 Og Maciel 2012-08-14 10:09:43 EDT
17:33 < omaciel> adprice: hey, that issue you asked for info... I remember thomasmckay saying it was sort of hard to reproduce it but he knew what caused it
17:33 < omaciel> thomasmckay: https://bugzilla.redhat.com/show_bug.cgi?id=845630
17:33 < thomasmckay> omaciel: adprice: i have a guess at cause, though repro will be key
17:34 < omaciel> thomasmckay: mind providing info?
17:36 < thomasmckay> omaciel: if the code doesn't think the sub came from red hat, then it links over to a custom provider
Comment 3 Adam Price 2012-09-26 16:05:10 EDT
Og, I'm unable to reproduce.
Comment 4 Og Maciel 2012-09-26 16:35:16 EDT
Closing it as I cannot reproduce it either.

Verified using:

* candlepin-0.7.8-1.el6cf.noarch
* candlepin-selinux-0.7.8-1.el6cf.noarch
* candlepin-tomcat6-0.7.8-1.el6cf.noarch
* katello-1.1.12-9.el6cf.noarch
* katello-all-1.1.12-9.el6cf.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.1.8-1.el6cf.noarch
* katello-cli-1.1.8-5.el6cf.noarch
* katello-cli-common-1.1.8-5.el6cf.noarch
* katello-common-1.1.12-9.el6cf.noarch
* katello-configure-1.1.9-4.el6cf.noarch
* katello-glue-candlepin-1.1.12-9.el6cf.noarch
* katello-glue-pulp-1.1.12-9.el6cf.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.1.1-1.el6cf.noarch
* pulp-1.1.12-1.el6cf.noarch
* pulp-common-1.1.12-1.el6cf.noarch
* pulp-selinux-server-1.1.12-1.el6cf.noarch
Comment 5 Mike McCune 2013-08-16 14:21:48 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.