Bug 845639 - Kernel 3.5.0 breaks screen repaint on radeon
Kernel 3.5.0 breaks screen repaint on radeon
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
i386 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-03 12:56 EDT by Andrea
Modified: 2012-10-10 11:15 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-10 11:15:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/messages of 3.5.0 and 3.4.6. (31.63 KB, application/x-gzip)
2012-08-03 12:56 EDT, Andrea
no flags Details
Screenshot of bad rendering (80.34 KB, image/jpeg)
2012-08-12 17:56 EDT, Andrea
no flags Details
Other example of bad rendering (57.74 KB, image/jpeg)
2012-08-12 17:56 EDT, Andrea
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 54129 None None None 2012-08-27 15:41:33 EDT

  None (edit)
Description Andrea 2012-08-03 12:56:53 EDT
Created attachment 602170 [details]
/var/log/messages of 3.5.0 and 3.4.6.

Description of problem:

Today's update of kernel from 3.4.6-2.fc17.i686 to 3.5.0-2.fc17.i686
causes my screen to show many big black rectangular-ish areas.
They are not fixed, but they come and go when I open or move windows on the desktop.

I have a fully updated Fedora 17 system using KDE.
Moreover, the laptop does not poweroff nicely anymore.
I need to use the power button.

This is a Thinkpad R50, with
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV250 [Mobility FireGL 9000] (rev 02)

Version-Release number of selected component (if applicable):

kernel-3.5.0-2.fc17.i686

How reproducible:

Always

Steps to Reproduce:
1. Select 3.5.0 in grub
2. Log on my account
  
Actual results:

Background is not completely repainted, it contais a few big black rectangular areas.

Expected results:

Normal background as in 3.4.6

Additional info:

I attach /var/log/messages containing 2 full cycles with 3.5.0 and 3.4.6.
Comment 1 Andrea 2012-08-04 14:04:42 EDT
I've tried with official kernel 3.5.0 + localmodconfig and black areas are the same.
Only advantage is that it powers off properly.

Reading inside the /var/log/messages I was only able to find some cosmetic differences in the [drm] sections, when the names have a "-1" at the end.

3.4.6

[drm] Connector 0:
[drm]   VGA
[drm]   DDC: 0x60 0x60 0x60 0x60 0x60 0x60 0x60 0x60
[drm]   Encoders:
[drm]     CRT1: INTERNAL_DAC1
[drm] Connector 1:
[drm]   DVI-D
[drm]   HPD1
[drm]   DDC: 0x64 0x64 0x64 0x64 0x64 0x64 0x64 0x64
[drm]   Encoders:
[drm]     DFP1: INTERNAL_TMDS1
[drm] Connector 2:
[drm]   LVDS
[drm]   Encoders:
[drm]     LCD1: INTERNAL_LVDS
[drm] Connector 3:
[drm]   S-video
[drm]   Encoders:
[drm]     TV1: INTERNAL_DAC2

3.5.0

[drm] Connector 0:
[drm]   VGA-1
[drm]   DDC: 0x60 0x60 0x60 0x60 0x60 0x60 0x60 0x60
[drm]   Encoders:
[drm]     CRT1: INTERNAL_DAC1
[drm] Connector 1:
[drm]   DVI-D-1
[drm]   HPD1
[drm]   DDC: 0x64 0x64 0x64 0x64 0x64 0x64 0x64 0x64
[drm]   Encoders:
[drm]     DFP1: INTERNAL_TMDS1
[drm] Connector 2:
[drm]   LVDS-1
[drm]   Encoders:
[drm]     LCD1: INTERNAL_LVDS
[drm] Connector 3:
[drm]   SVIDEO-1
[drm]   Encoders:
[drm]     TV1: INTERNAL_DAC2
Comment 2 Per Sjoholm 2012-08-05 18:04:30 EDT
I have same problem on a Thinkpad R50
Comment 3 Taunus 2012-08-10 11:03:20 EDT
Me too on T41

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV250 [Mobility FireGL 9000] (rev 02) (prog-if 00 [VGA controller])
	Subsystem: IBM Device 0531
	Flags: bus master, stepping, fast Back2Back, 66MHz, medium devsel, latency 66, IRQ 11
	Memory at e0000000 (32-bit, prefetchable) [size=128M]
	I/O ports at 3000 [size=256]
	Memory at c0100000 (32-bit, non-prefetchable) [size=64K]
	[virtual] Expansion ROM at c0120000 [disabled] [size=128K]
	Capabilities: [58] AGP version 2.0
	Capabilities: [50] Power Management version 2
	Kernel driver in use: radeon
Comment 4 Andrea 2012-08-12 17:56:04 EDT
Created attachment 603829 [details]
Screenshot of bad rendering
Comment 5 Andrea 2012-08-12 17:56:37 EDT
Created attachment 603830 [details]
Other example of bad rendering
Comment 6 Marcin 2012-08-16 08:29:19 EDT
The same on another Thinkpad T41. The same hardware as listed by Taunus.
Comment 7 Andrea 2012-08-27 15:41:33 EDT
I've opened a bug @ freedesktop.

There you can find more information.
I managed to bisect the issue and I found that passing 

radeon.modeset=0

to the kernel avoids this issue (but there is not XV support in X).

Please report your experience over there as they should be in a much better position to understand the problem.
Comment 8 Rolf Fokkens 2012-09-16 16:13:44 EDT
Same problem here with HP NC8430.

The radeon.modeset=0 helps, but also results in a lower screen resolution 1400x1050 instead of 1680x1050.

Also potentially relevant: there is long wait (10 seconds) during boot when the display is black. Looks like the lockup_timeout is exceeded or so.
Comment 9 Andrea 2012-09-17 15:16:44 EDT
Upstream bug has been fixed for me.

Check out

http://bugs.freedesktop.org/show_bug.cgi?id=54129
Comment 10 Fedora Update System 2012-09-27 12:25:48 EDT
kernel-3.5.4-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.5.4-2.fc17
Comment 11 Fedora Update System 2012-09-28 04:19:37 EDT
Package kernel-3.5.4-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.5.4-2.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14952/kernel-3.5.4-2.fc17
then log in and leave karma (feedback).
Comment 12 Taunus 2012-09-29 15:23:58 EDT
Package kernel-3.5.4-2.fc17 works here.
Comment 13 Rolf Fokkens 2012-09-30 07:24:02 EDT
Works for me as well.
Comment 14 Marcin 2012-09-30 08:04:08 EDT
kernel-3.5.4-2.fc17 works with IBM T41.
Comment 15 Per Sjoholm 2012-09-30 09:47:03 EDT
(In reply to comment #2)
> I have same problem on a Thinkpad R50

kernel-3.5.4-2.fc17 works for me. 
Thanks.
Comment 16 Josh Boyer 2012-10-10 11:15:19 EDT
Not sure why bodhi didn't close the bug.

Note You need to log in before you can comment on or make changes to this bug.