Bug 84565 - IrDA doesn't work out of box
IrDA doesn't work out of box
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: irda-utils (Show other bugs)
phoebe
All Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-18 18:59 EST by Peter Bowen
Modified: 2015-01-07 19:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-18 20:11:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bowen 2003-02-18 18:59:01 EST
In order to get IrDA working I had to do two things:

1) change DEVICE to /dev/ttyS1 in /etc/sysconfig/irda.  The default of
/dev/ttyS2 didn't work.  irattach didn't do any when it was set to this.

2) Add the modules to modules.conf.  Some program should add the alias to
modules.conf:

alias char-major-161 ircomm-tty
Comment 1 Peter Bowen 2003-02-18 19:02:03 EST
OK, I take back point 2.  It looks like modprobe has the necessary aliases built in.
Comment 2 Bill Nottingham 2003-02-18 19:43:48 EST
DEVICE= sounds very much specific to your particular hardware. Not sure if
there's really anything we can do about that.
Comment 3 Peter Bowen 2003-02-18 20:11:40 EST
Ok, you are right.  I just misread the docs, or general lack there of.  I was
under the impression it emulated a serial port on the specified device, but it
is the other way around.  It looks at that device and uses it as an irport, as
the BIOS emulates a serial port with a IR device attached, similar to a modem.

I'm going to open this so that others can find the answer on their hardware.

Note You need to log in before you can comment on or make changes to this bug.