Bug 845721 - Cannot enter a message in the message bar after startup
Cannot enter a message in the message bar after startup
Status: CLOSED DUPLICATE of bug 843296
Product: Fedora
Classification: Fedora
Component: pidgin (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stu Tomlinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-04 04:24 EDT by alberth289346
Modified: 2012-08-06 01:18 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-06 01:18:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description alberth289346 2012-08-04 04:24:40 EDT
Description of problem:
Since some time I cannot start entering a message in the pidgin message bar directly after start-up.

Version-Release number of selected component (if applicable):
Pidgin 2.10.5-1.fc17 (libpurple 2.10.5)
d8e716bfd316e584f9d68582b08b5a05e2d54c88

Running in KDE 4.8.4


How reproducible:
I start pidgin manually into offline mode. Switch to 'online', wait for the servers to get registered, and open a number of IRC chats.

In the past, I could then start typing messages, and press 'enter' to post them. Currently, I can select the window (mouse follows focus), place the cursor in the message bar, but key-strokes are not echo-ed in the bar.

The application seems to work otherwise, messages from people get copied into the chat display, and they 'see' me getting online.

I have tried to determine the cause, but mostly failed. It does not seem time related. When I open the windows, and leave them alone for a while, the problem does not fix itself. Switching desktops, focus switching (by moving the mouse around) doesn't help either. It is also not busy, running 'top' doesn't give huge CPU use. The disk also doesn't seem to be used.

A thing that does work is to open a menu of the application. After clicking outside the menu, or pressing escape, the program responds as it should; key-strokes are copied in the message bar, and I can post the messages.
Comment 1 Volker Sobek 2012-08-05 16:05:03 EDT
Same here, running F17 with gnome-shell. The input field gets unresponsive (but the cursor keeps blinking) after changing the status in pidgin.

sudo yum downgrade gtk2 gtk2-devel gtk2-devel-docs gtk2-immodule-xim

fixed it, so I suspect it's an issue that came with the last gtk2 update.
Comment 2 Volker Sobek 2012-08-05 16:10:54 EDT
This issue was fixed in gtk2 recently, but no new version has been released yet.

http://git.gnome.org/browse/gtk+/commit/?h=gtk-2-24&id=a9fb816a3f64227936f4b25882e4f20ab5018c9c
Comment 3 Volker Sobek 2012-08-05 16:33:38 EDT
Could you mark this bug as a duplicate of the https://bugzilla.redhat.com/show_bug.cgi?id=843296 please?
Comment 4 Jan Synacek 2012-08-06 01:18:47 EDT

*** This bug has been marked as a duplicate of bug 843296 ***

Note You need to log in before you can comment on or make changes to this bug.