Bug 845744 - Dracut doesn't load keytable/keymap when booting
Dracut doesn't load keytable/keymap when booting
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
17
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-04 08:09 EDT by htd
Modified: 2012-08-14 17:57 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-14 17:57:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A screenshot showing what happens (661.81 KB, image/jpeg)
2012-08-13 14:07 EDT, htd
no flags Details

  None (edit)
Description htd 2012-08-04 08:09:25 EDT
Description of problem:
When dracut.noarch 0:018-96.git20120724.fc17 is installed, loading of the proper keyboard table via dracut doesn't work when booting. The message is:

loadkeys: /lib/kbd/keymaps/i386/qwerty/no.map:2: cannot open include file qwerty-layout

This is fatal when the root partition is encrypted, because the password entered is translated via a wrong keytable (US?).

Version-Release number of selected component (if applicable):

dracut.noarch 0:018-96.git20120724.fc17

How reproducible:

Install the mentioned version and boot.

Steps to Reproduce:
1. Install dracut.noarch 0:018-96.git20120724.fc17
2. Build a new kernel or install latest F17 one 
3. Problem occurs
  
Actual results:

Proper keytable doesn't get loaded.

Expected results:

Proper keytable gets loaded.

Additional info:

Doing a "yum downgrade" to dracut.noarch 0:018-35.git20120510.fc17 and recreating the initramfs via "dracut -f" solves the problem.
Comment 1 Fedora Update System 2012-08-13 05:08:43 EDT
dracut-018-98.git20120813.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/dracut-018-98.git20120813.fc17
Comment 2 htd 2012-08-13 13:54:19 EDT
Updating to the new version doesn't help. The same as described before is happening. Downgrading to dracut.noarch 0:018-35.git20120510.fc17 and recreating the initramfs ("dracut -f") resolves the problem.
Comment 3 htd 2012-08-13 14:07:50 EDT
Created attachment 604064 [details]
A screenshot showing what happens

Here's a screenshot what happens. Last working dracut is dracut-018-35.git20120510.fc17.noarch.
Comment 4 htd 2012-08-13 15:53:21 EDT
FYI: the bug is no longer present in dracut-018-98.git20120813.fc17.noarch from koji.
Comment 5 Fedora Update System 2012-08-13 21:02:58 EDT
Package dracut-018-98.git20120813.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dracut-018-98.git20120813.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11828/dracut-018-98.git20120813.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-08-14 17:57:46 EDT
dracut-018-98.git20120813.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.