Bug 845764 - gstreamer should be compiled against libopus
gstreamer should be compiled against libopus
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gstreamer-plugins-bad-free (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Benjamin Otte
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-04 14:29 EDT by Romain DEP.
Modified: 2012-09-22 23:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-20 16:36:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add opus codec element (against master) (1.06 KB, patch)
2012-09-06 12:52 EDT, Fabian Deutsch
no flags Details | Diff

  None (edit)
Description Romain DEP. 2012-08-04 14:29:53 EDT
Description of problem:

The Opus audio codec is getting more and more attraction as it starts being used in a brunch of browsers (firefox 15, opera 12, Webkit, …) and reached in unifying high quality codecs (for HQ sound restitution) with low latency ones (audio/phone conversations) what makes it a perfect match for any audio web content and communication (WebRTC).
But for opera and webkit to deal with the opus format they need an underlying gstreamer which can decode it, that's why there is a need for gstreamer to be compiled against opus.


Additional info:

I think this should be backported to f17 too
I stay around for testing
Comment 1 Fabian Deutsch 2012-09-06 06:48:18 EDT
Opus seems to be part of upstream gstreamer-plugins-bad. Is there a reason why it's not packaged, any legal reasons?
Or maybe just a configure switch is missing.
Comment 2 Fabian Deutsch 2012-09-06 12:52:54 EDT
Created attachment 610423 [details]
Add opus codec element (against master)

The patch adds the opus plugin to gstreamer-plugins-bad-free.

Or should it go into extras?
Comment 3 Benjamin Otte 2012-09-10 07:21:43 EDT
Feel free to push that and do a rebuild.
Comment 4 Fedora Update System 2012-09-12 14:34:05 EDT
gstreamer-plugins-bad-free-0.10.23-8.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/gstreamer-plugins-bad-free-0.10.23-8.fc17
Comment 5 Fedora Update System 2012-09-12 14:34:20 EDT
gstreamer-plugins-bad-free-0.10.23-11.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gstreamer-plugins-bad-free-0.10.23-11.fc18
Comment 6 Fedora Update System 2012-09-13 12:46:21 EDT
Package gstreamer-plugins-bad-free-0.10.23-11.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gstreamer-plugins-bad-free-0.10.23-11.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13919/gstreamer-plugins-bad-free-0.10.23-11.fc18
then log in and leave karma (feedback).
Comment 7 Romain DEP. 2012-09-18 12:32:33 EDT
Nice ! I got the update on f17, it works nice. You got my karma ;)

Thanks for having fixed this, now opera and midori browsers should be able to decode opus files (thus I didn't tried by myself).
Comment 8 Fedora Update System 2012-09-20 16:36:11 EDT
gstreamer-plugins-bad-free-0.10.23-11.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2012-09-22 23:24:14 EDT
gstreamer-plugins-bad-free-0.10.23-8.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.