Bug 845770 - Broadcom Bluetooth HID proxy creates broken battery device
Broadcom Bluetooth HID proxy creates broken battery device
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-04 16:26 EDT by tkrille
Modified: 2014-06-16 08:59 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 11:07:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dmes Output after Reboot (61.49 KB, text/plain)
2012-08-05 16:34 EDT, tkrille
no flags Details

  None (edit)
Description tkrille 2012-08-04 16:26:14 EDT
User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.1 (KHTML, like Gecko) Chrome/21.0.1180.57 Safari/537.1
Build Identifier: 

i just updated to the new kernel and now my Lenovo IdeaCentre B500 has a battery (at least the kernel thinks so). Main problem is that every some seconds i get a message in the dmesg log saying:

"[ 1110.030101] power_supply hid--battery: driver failed to report `capacity' property: -110"

what is wrong with that and how can i solve this?

worked fine with the former kernels and system is fully updated and a clean install.

Reproducible: Always

Steps to Reproduce:
update to kernel 3.5.0-2 on a lenovo thinkcentre B500
Actual Results:  
 - battery icon in the gnome-shell panel, showing battery is empty
 - strange dmesg output

Expected Results:  
nothing of the actual results, because the pc has no battery

i don't know much about the acpi sytem, so i don't know what kind of debug output you need. i will provide this when asked for.
Comment 1 Josh Boyer 2012-08-05 10:25:42 EDT
You're probably using a wireless keyboard or mouse that has a battery in it.  Do you have the latest upower update?  Can you attach the dmesg output for the kernel that is exhibiting this?
Comment 2 Jeremy Fitzhardinge 2012-08-05 13:36:15 EDT
upower-0.9.17-1.fc17.x86_64 doesn't pay attention to the scope, so my mouse is appearing as a "laptop battery".
Comment 3 Jeremy Fitzhardinge 2012-08-05 13:38:47 EDT
Or perhaps other things are not paying attention to the "power supply: no" flag?
It shows up on the desktop battery meter, when it probably shouldn't.
Comment 4 tkrille 2012-08-05 16:34:49 EDT
Created attachment 602384 [details]
Dmes Output after Reboot
Comment 5 tkrille 2012-08-05 16:35:08 EDT
i have a wireless mouse and keyboard on 2 different receivers. i think there is also some kind of locked bluetooth hid device that was the receiver for mouse and keyboard that shipped with the pc.

i attached the dmesg output after a reboot.

maybe i can try to turn some hid devices off and see if the batter is still there. how can i do this?
Comment 6 tkrille 2012-08-05 16:36:22 EDT
i have the latest upower package the fedora update system offers me.
Comment 7 Josh Boyer 2012-08-06 10:03:36 EDT
Richard, any ideas on this one?
Comment 8 Ilkka Tengvall 2012-10-22 05:44:37 EDT
I get the very same on fedora 17 . I believe it's caused by incorrect polling of the apple bt keyboard and bt touchpad (tragic mackpad) mouse. It's trashing the logs with this:

[349847.631435] power_supply hid-7C:C3:A1:XX:XX:XX-battery: driver failed to report `capacity' property: -5
[349877.481202] power_supply hid-7C:C3:A1:XX:XX:XX-battery: driver failed to report `capacity' property: -5
[349907.431923] power_supply hid-7C:C3:A1:XX:XX:XX-battery: driver failed to report `capacity' property: -5



upower-0.9.17-1.fc17.x86_64
kernel-3.6.2-4.fc17.x86_64
Comment 9 Ilkka Tengvall 2012-10-22 06:04:39 EDT
oops, it seems there are several bugs open about the same apple trackpad:

It seems there are several tickets open related to the same issue. At least:

812625, 830046, 845770, 806295, 863524
Comment 10 Daniel Nicoletti 2012-10-22 08:44:17 EDT
Can you please attach the lsinput output, there are some devices that do not report the correct info about how to grab the information, resulting in the error you get, in those cases I need to add a quirk to the kernel, I just need to make sure you are having the same case..
Comment 11 Ilkka Tengvall 2012-11-16 03:36:39 EST
Here you are, please check my lsinput output in the other bug report:

https://bugzilla.redhat.com/show_bug.cgi?id=806295#c45
Comment 12 Bastien Nocera 2012-11-16 12:57:56 EST
It's a kernel problem. Without upowerd running, I still get:
Nov 16 18:55:19 novo kernel: [41889.765728] power_supply hid--battery: driver failed to report `capacity' property: -110
every 5 seconds.

With help from Benjamin Tissoires.

The error comes from:
drivers/power/power_supply_sysfs.c:85 dev_err(dev, "driver failed to report `%s' property: %zd\n",
and -110 means ETIMEDOUT /* Connection timed out */

And it looks like the error would be returned from:
drivers/platform/x86/intel_scu_ipc.c:150

The problem would be the way the ACPI _HID is handled.
Comment 13 Bastien Nocera 2012-11-16 13:02:24 EST
By the way, this is a Lenovo Ideacentre A700 (an all-in-one), running F18:
kernel-3.6.6-3.fc18.x86_64
Comment 14 Bastien Nocera 2012-11-21 05:49:48 EST
Actually. upower -d shows:
Device: /org/freedesktop/UPower/devices/battery_hid__battery
  native-path:          /sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.5/1-1.5.1/1-1.5.1:1.0/0003:0A5C:4502.0004/power_supply/hid--battery
  model:                HID 0a5c:4502

and this device is:
$ lsusb  | grep 0a5c:4502
Bus 001 Device 009: ID 0a5c:4502 Broadcom Corp. Keyboard (Boot Interface Subclass)

This HID proxy from Broadcom hasn't been put into HCI mode (we don't have code for it to do that) and the HID sub-system is trying to poke the Bluetooth keyboard over the wire. Except that the keyboard is empty of batteries and in a case with all my other hardware junk.

This malfunction causes:
- broken battery device advertised by upower to the desktop
- udev hangs with some queries (https://bugzilla.gnome.org/show_bug.cgi?id=686202)
Comment 15 lnxslck 2013-02-23 09:45:02 EST
I also have this problem. I have a wireless keyboard and mouse from apple connected through bluetooth. My keyboard works fine, but my mouse after using it for a while (the time varies) stops working, sometimes it causes my X server to hang other it simply stops working.

I have:
Fedora 18 64 bits
Kernel:  3.7.9-201.fc18.x86_64
Upower : upower-0.9.19-1.fc18.x86_64

Error: [10700.258063] power_supply hid-60:C5:47:21:88:71-battery: driver failed to report `capacity' property: -5

upower -d shows:

Device: /org/freedesktop/UPower/devices/battery_hid_78oCAo39oF0oF8oDD_battery
  native-path:          /sys/devices/pci0000:00/0000:00:1c.3/0000:04:00.0/usb3/3-1/3-1.3/3-1.3:1.0/bluetooth/hci0/hci0:12/0005:05AC:030D.0004/power_supply/hid-78:CA:39:F0:F8:DD-battery
  power supply:         no

Wich is my wireless mouse: Bus 003 Device 004: ID 0a5c:4503 Broadcom Corp. Mouse (Boot Interface Subclass)


Is there a fix for this? This is very annoying, not beeing able to use the wireless mouse, and this problem has been manifesting since Fedora 17
Comment 16 vasilis 2013-03-19 12:51:25 EDT
Same problem here. I have an Apple Bluetooth keyboard and my dmesg is full with 

[11425.830913] power_supply hid-28:37:37:36:88:7f-battery: driver failed to report `capacity' property: -5

trying to get the keyboard to report the battery level, several times per second!

kernel  3.8.3-201.fc18.x86_64
Comment 17 Bastien Nocera 2013-03-19 13:01:23 EDT
This isn't the same problem:
- Your sysfs path does include information about the device (the "filename" part of the path), because the device is actually connected
- The error is different (-5 is I/O error, -110 is connection timed out)

Please file new bugs for your problem.
Comment 18 Alan Pevec 2013-06-18 07:04:04 EDT
> - Your sysfs path does include information about the device (the "filename"
> part of the path), because the device is actually connected
> - The error is different (-5 is I/O error, -110 is connection timed out)
> 
> Please file new bugs for your problem.

that's bug 903741
Comment 19 Justin M. Forbes 2013-10-18 17:02:56 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 18 kernel bugs.

Fedora 18 has now been rebased to 3.11.4-101.fc18.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 19, and are still experiencing this issue, please change the version to Fedora 19.

If you experience different issues, please open a new bug report for those.
Comment 20 Justin M. Forbes 2013-11-27 11:07:12 EST
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  

It has been over a month since we asked you to test the 3.11 kernel updates and let us know if your issue has been resolved or is still a problem. When this happened, the bug was set to needinfo.  Because the needinfo is still set, we assume either this is no longer a problem, or you cannot provide additional information to help us resolve the issue.  As a result we are closing with insufficient data. If this is still a problem, we apologize, feel free to reopen the bug and provide more information so that we can work towards a resolution

If you experience different issues, please open a new bug report for those.
Comment 21 tkrille 2014-06-16 08:03:22 EDT
Seems to be fixed since 3.10.
Comment 22 Josh Boyer 2014-06-16 08:59:13 EDT
Thanks.

Note You need to log in before you can comment on or make changes to this bug.