This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 845803 - wrong monitor resolution on wake from suspend with kernel 3.5.0-2.fc17.x86_64
wrong monitor resolution on wake from suspend with kernel 3.5.0-2.fc17.x86_64
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-05 03:16 EDT by paul59584
Modified: 2012-11-02 05:05 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-05 08:33:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log before suspend (45.92 KB, text/x-log)
2012-08-05 04:02 EDT, paul59584
no flags Details
Xorg.0.log after suspend (54.12 KB, text/x-log)
2012-08-05 04:05 EDT, paul59584
no flags Details

  None (edit)
Description paul59584 2012-08-05 03:16:16 EDT
Description of problem:
on wake from suspend, monitor resolution is wrong and only have 2 very low resolution options in system settings -> displays. resolution back to normal with restart.
 

Version-Release number of selected component (if applicable):
kernel 3.5.0-2.fc17.x86_64

How reproducible:
every time use suspend

Steps to Reproduce:
1. suspend computer
2. wake from suspend
3.
  
Actual results:
wrong (very low) resolution on wake from suspend

Expected results:
same resolution (and choices of resolution in system settings -> displays) as before suspending)

Additional info:
in logs see:
kernel: [ 1372.157025] [drm] GMBUS [i915 gmbus dpb] timed out, falling back to bit banging on pin 5


works as it should with previous kernel 3.4.6-2.fc17.x86_64

$ sudo lspci -v -s 00:02.0
[sudo] password for paul: 
00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03) (prog-if 00 [VGA controller])
	Subsystem: ASUSTeK Computer Inc. Device 836d
	Flags: bus master, fast devsel, latency 0, IRQ 42
	Memory at fe400000 (64-bit, non-prefetchable) [size=4M]
	Memory at e0000000 (64-bit, prefetchable) [size=256M]
	I/O ports at cc00 [size=8]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
	Capabilities: [d0] Power Management version 2
	Capabilities: [a4] PCI Advanced Features
	Kernel driver in use: i915
Comment 1 paul59584 2012-08-05 04:02:54 EDT
Created attachment 602339 [details]
Xorg.0.log before suspend

Xorg.0.log from before suspend
Comment 2 paul59584 2012-08-05 04:05:30 EDT
Created attachment 602340 [details]
Xorg.0.log after suspend

Xorg.0.log from after suspend
last line has
[  3546.288] (II) intel(0): Allocated new frame buffer 1024x768 stride 4096, tiled
before suspend was
[    25.968] (II) intel(0): Allocated new frame buffer 1920x1080 stride 7680, tiled
Comment 3 paul59584 2012-08-11 01:36:46 EDT
still broken with kernel 3.5.1-1.fc17.x86_64
Comment 4 cblaauw 2012-08-13 13:26:55 EDT
does not happen all the time, but consistently every other resume.

Kernel 3.4.6 works flawless in that respect
Comment 5 paul59584 2012-08-17 08:18:16 EDT
still broken with kernel-3.5.2-1.fc17.x86_64
last working kernel is 3.4.6-2.fc17.x86_64
Comment 6 paul59584 2012-08-23 01:47:05 EDT
still broken with kernel-3.4.6-2.fc17.x86_64
last working kernel is 3.4.6-2.fc17.x86_64

is anybody there?
Comment 7 paul59584 2012-08-23 04:36:14 EDT
comment 6 should have been
still broken with kernel-3.4.6-2.fc17.x86_64
Comment 8 paul59584 2012-08-23 04:37:31 EDT
sorry
comment 6 and 7 should have been
still broken with kernel-3.5.2-3.fc17.x86_64
Comment 9 paul59584 2012-09-03 06:52:50 EDT
still have wrong monitor resolution on wake from suspend with
kernel-3.5.3-1.fc17.x86_64
last working kernel is
kernel-3.4.6-2.fc17.x86_64
Comment 10 paul59584 2012-09-22 08:39:27 EDT
still have wrong monitor resolution on wake from suspend with
kernel-3.5.4-1.fc17.x86_64
last working kernel is
kernel-3.4.6-2.fc17.x86_64
Comment 11 paul59584 2012-10-02 07:53:11 EDT
still have wrong monitor resolution on wake from suspend with
kernel-3.5.4-2.fc17.x86_64
last working kernel is
kernel-3.4.6-2.fc17.x86_64
Comment 12 cblaauw 2012-10-04 09:07:25 EDT
3.6.0-1.fc18 works fine, so I'm using that kernel.
Comment 13 paul59584 2012-10-04 23:47:36 EDT
seems to be working with kernel 3.5.5-1.fc17.x86_64 as well
Comment 14 Josh Boyer 2012-10-05 08:33:50 EDT
Thank you for letting us know.

Note You need to log in before you can comment on or make changes to this bug.