Bug 845807 - No RHEVM package depends on rhevm-spice-client* RPMs, therefore they are not implicitly installed as part of RHEVM installation.
No RHEVM package depends on rhevm-spice-client* RPMs, therefore they are not ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.1.0
x86_64 Linux
urgent Severity high
: ---
: ---
Assigned To: Kiril Nesenko
Marian Krcmarik
integration
: Regression
: 846649 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-05 05:10 EDT by Yaniv Kaul
Modified: 2015-09-22 09 EDT (History)
13 users (show)

See Also:
Fixed In Version: si14
Doc Type: Release Note
Doc Text:
Previously no <package>rhevm*</package> package included a dependency on the <package>rhevm-spice-client*</package> packages, which contain the SPICE clients. As a result the SPICE clients were not automatically installed during Manager installation, and users of the User Portal were not automatically prompted to install them when accessing virtual machines. The missing dependencies have been added, resolving this issue.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:02:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaniv Kaul 2012-08-05 05:10:39 EDT
Description of problem:
None of the following packages is installed as part of 'yum install rhevm', so you don't get any of the spice client CABs or MSIs installed.

I'm not even sure if those actually deliver anything useful (shouldn't they be the new mingw virt-viewer based ones?), but bottom line is - no spice client delivery to the clients via RHEVM, which is a regression from 3.0.

rhevm-spice-client-x64-cab-3.0-24.el6.noarch.rpm
rhevm-spice-client-x64-msi-3.0-24.el6.noarch.rpm
rhevm-spice-client-x86-cab-3.0-24.el6.noarch.rpm
rhevm-spice-client-x86-msi-3.0-24.el6.noarch.rpm

Version-Release number of selected component (if applicable):
rhevm-webadmin-portal-3.1.0-10.el6ev.noarch.rpm

How reproducible:


Steps to Reproduce:
1. 'yum install rhevm' - no spice relevant packages are installed.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Kiril Nesenko 2012-08-06 16:45:56 EDT
Patch posted for review: http://gerrit.ovirt.org/#/c/6961/
Comment 3 Kiril Nesenko 2012-08-07 03:08:37 EDT
(In reply to comment #2)
> Patch posted for review: http://gerrit.ovirt.org/#/c/6961/

This patch was canceled. Posted new patch for review: https://gerrit.eng.lab.tlv.redhat.com/#/c/1064/
Comment 4 Yaniv Kaul 2012-08-08 07:04:24 EDT
*** Bug 846649 has been marked as a duplicate of this bug. ***
Comment 8 Stephen Gordon 2012-08-09 12:23:07 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Currently no rhevm* package includes a dependency on the rhevm-spice-client* packages, which contain the SPICE clients. As a result the SPICE clients are not automatically installed during Manager installation, and are users of the User Portal are not automatically prompted to install them when accessing virtual machines.

To work around this issue, following successful Red Hat Enterprise Virtualization Manager installation, log in as root and use the yum command to install the missing packages:

# yum install rhevm-spice-client\*
Comment 9 Marian Krcmarik 2012-09-12 08:52:07 EDT
Verified on rhevm-3.1.0-14.el6ev.noarch

# yum deplist rhevm | grep spice-client
  dependency: rhevm-spice-client-x86-cab
   provider: rhevm-spice-client-x86-cab.noarch 3.1-4.el6
  dependency: rhevm-spice-client-x64-cab
   provider: rhevm-spice-client-x64-cab.noarch 3.1-4.el6

Note You need to log in before you can comment on or make changes to this bug.