Bug 845824 - [engine-core] auto-recovery: DisconnectStorageServer (umount) is not sent after failed attempt to Activate Storage Domain
[engine-core] auto-recovery: DisconnectStorageServer (umount) is not sent aft...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.1.0
Assigned To: Ayal Baron
Haim
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-05 07:45 EDT by Gadi Ickowicz
Modified: 2016-02-10 12:17 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-22 10:46:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine + vdsm logs (1.11 MB, application/x-gzip)
2012-08-05 07:45 EDT, Gadi Ickowicz
no flags Details

  None (edit)
Description Gadi Ickowicz 2012-08-05 07:45:32 EDT
Created attachment 602353 [details]
engine + vdsm logs

Description of problem:
When AutoRecover fails to recover a storage domain, DisconnectStorageServer is not sent.


Version-Release number of selected component (if applicable):
rhevm-3.1.0-10.el6ev.noarch


How reproducible:
100%

Steps to Reproduce:
1. On a cluster with 2 domains, edit metadata of master storage domain to corrput it
2. Reconstruct is done automatically and 2nd domain is set as master
3. every 5 minutes AutoRecover flow runs automatically and should disconnectStorageServer but it doesn't
  
Actual results:
On AutoRecover flow (every 5 minutes) connectStorageServer is sent, and after failure to reconnect to domain due to corrupt metadata, disconnectStorageServer is not sent, and the connection remains active

Expected results:
disconnectStorageServer should be sent to disconnect when failed to connect to a host

Additional info:
Comment 1 Ayal Baron 2012-08-22 10:46:40 EDT
no it shouldn't.
disconnecting all the time is a bug.

Note You need to log in before you can comment on or make changes to this bug.