This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 845836 - Add rhevm-cli as a dependency to RHEVM
Add rhevm-cli as a dependency to RHEVM
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity high
: ---
: 3.1.0
Assigned To: Kiril Nesenko
Yaniv Kaul
integration
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-05 10:38 EDT by Yaniv Kaul
Modified: 2015-09-22 09 EDT (History)
9 users (show)

See Also:
Fixed In Version: si14
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:01:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Yaniv Kaul 2012-08-05 10:38:35 EDT
Description of problem:
Currently, when installing rhevm via 'yum install rhevm' the user does not get the 'rhevm-cli' package. It does get 'rhevm-sdk', but that's because the tools are dependent on it (and I guess 'rhevm' packages depends on them).
However, that makes it harder for the user to get 'rhevm-cli'.

Please make it a dependency, so users will automatically have it as well (even though I understand it's not really needed).

This was discussed with PM (Miki).

Version-Release number of selected component (if applicable):
SI13.1

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Kiril Nesenko 2012-08-12 08:43:28 EDT
Patch posted for review: http://gerrit.ovirt.org/#/c/7100/
Comment 4 Yaniv Kaul 2012-08-19 04:22:28 EDT
SI14: was it intended not to have the cli on a specific version, as was done to the rest of RHEVM dependencies?
For example:
[root@ykaul-rhevm3 ~]# rpm -qR rhevm |grep rest
rhevm-restapi = 3.1.0-12.el6ev

vs:
[root@ykaul-rhevm3 ~]# rpm -qR rhevm |grep cli
rhevm-cli 


The full list (note some utils are not fixed, some are):

[root@ykaul-rhevm3 ~]# rpm -qR rhevm |grep rhev |sort
config(rhevm) = 3.1.0-12.el6ev
rhev-guest-tools-iso  
rhevm-backend = 3.1.0-12.el6ev
rhevm-cli  
rhevm-config = 3.1.0-12.el6ev
rhevm-dbscripts = 3.1.0-12.el6ev
rhevm-doc >= 3.1.0
rhevm-genericapi = 3.1.0-12.el6ev
rhevm-image-uploader  
rhevm-iso-uploader  
rhevm-log-collector  
rhevm-notification-service = 3.1.0-12.el6ev
rhevm-restapi = 3.1.0-12.el6ev
rhevm-setup >= 3.1.0-12.el6ev
rhevm-spice-client-x64-cab  
rhevm-spice-client-x86-cab  
rhevm-userportal = 3.1.0-12.el6ev
rhevm-webadmin-portal = 3.1.0-12.el6ev

Note You need to log in before you can comment on or make changes to this bug.