Bug 845860 - Avahi's ssh.service can't be permanently disabled
Avahi's ssh.service can't be permanently disabled
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: avahi (Show other bugs)
17
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-05 20:37 EDT by Robert Scheck
Modified: 2012-08-24 23:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-24 23:04:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2012-08-05 20:37:24 EDT
Description of problem:
From what I got, avahi is that broken by design that the only way to disable
a single service from being announced is "rm /etc/avahi/services/ssh.service".
However, the next avahi RPM update brings that file again. So from my point of
view and from what I can read in the documentation, it is unfortunately not 
possible to permantely disable ssh.service in a real safe way. Please either
make the broken stuff configurable or (preferred by me) don't ship ssh.service
by default.

Version-Release number of selected component (if applicable):
avahi-0.6.31-3.fc17.armv5tel

How reproducible:
Everytime, see above and below.
  
Actual results:
Avahi's ssh.service can't be permanently disabled.

Expected results:
Possibility to really permanently disable ssh.service while other services
are announced nevertheless.

Additional info:
Seriously, nobody (except maybe some Mac users) ever requires ssh.service...
Comment 1 Fedora Update System 2012-08-09 09:21:06 EDT
avahi-0.6.31-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/avahi-0.6.31-5.fc17
Comment 2 Fedora Update System 2012-08-09 18:50:39 EDT
Package avahi-0.6.31-5.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing avahi-0.6.31-5.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11559/avahi-0.6.31-5.fc17
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2012-08-24 23:04:37 EDT
avahi-0.6.31-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.