Bug 845905 - Standalone installation process 2.1 is inaccurate
Standalone installation process 2.1 is inaccurate
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: Documentation (Show other bugs)
BRMS 5.3.0.GA
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: lcarlon
Petr Široký
: Documentation
Depends On:
Blocks: 851365
  Show dependency treegraph
 
Reported: 2012-08-06 02:05 EDT by Morgan Weetman
Modified: 2013-01-20 22:41 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Instance Name: Not Defined Build: CSProcessor Builder Version 1.5 Build Filter: null Build Name: Build Date: 31-07-2012 13:50:38
Last Closed: 2013-01-20 22:41:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Morgan Weetman 2012-08-06 02:05:55 EDT
Description of problem:
Step 4 in procedure 2.1 suggests editing brms-standalone-5.3.0/jboss-as/server/default/deploy/business-central/WEB-INF/jboss-web.xml, but the actual directories present are:
---------------------------------------------
business-central.war
business-central-server.war
---------------------------------------------

Adding the relevant line to brms-standalone-5.3.0/jboss-as/server/default/deploy/business-central.war/WEB-INF/jboss-web.xml like:
---------------------------------------------
...
<jboss-web>
  <context-root>business-central</context-root>
  <security-domain>java:/jaas/brms</security-domain>
</jboss-web>
---------------------------------------------

.. results in a deployment failure when starting BRMS:
---------------------------------------------
...
DEPLOYMENTS IN ERROR:
  Deployment "vfsfile:/home/labops/brms-standalone-5.3.0/jboss-as/server/default/deploy/business-central.war/" is in error due to the following reason(s): org.xml.sax.SAXException: The content of element type "jboss-web" must match "(class-loading?,security-domain?,context-root?,virtual-host*,use-session-cookies?,replication-config?,resource-env-ref*,resource-ref*,security-role*,ejb-ref*,ejb-local-ref*,message-destination-ref*,message-destination*,webservice-description*,service-ref*,depends*,servlet*,authenticators*)". @ vfsfile:/home/labops/brms-standalone-5.3.0/jboss-as/server/default/deploy/business-central.war/WEB-INF/jboss-web.xml[10,13]
---------------------------------------------

Removing the change seems to generate a successful startup but I'm unsure how to confirm.

Checking the same file under business-central-server.war shows that the change is already present.

Also I dont understand why the procedure number is 2.1 when there are no previous procedures and it's in section 2.2 .. ?


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 lcarlon 2012-08-06 22:50:23 EDT
Thanks for reporting, Morgan.

I've removed step 4 from the procedure. There was some confusion with last minutes changes regarding this.

re: procedure numbers. The tools we use numbers the procedures based on the chapter number and the number of procedures in the chapter. This is the first procedure in chapter 2, so it gets numbered 2.1. I hope that helps.

- Lee
Comment 3 Morgan Weetman 2012-08-06 22:54:25 EDT
Thanks for the update Lee .. not sure if it matters but I stuffed up the version - it should have been 5.3.0 GA
Comment 4 lcarlon 2012-08-06 23:21:47 EDT
That's okay and easily changed.

Thanks
Comment 6 lcarlon 2012-08-23 20:51:06 EDT
This procedure has been rewritten to include all supported containers, see BZ851365. I'll leave this one open but as a blocker so the issue here is reviewed.

Note You need to log in before you can comment on or make changes to this bug.