Bug 845931 - Guest fail to boot from hard disk correctly at the first time with gpxe if we select network in BIOS
Guest fail to boot from hard disk correctly at the first time with gpxe if we...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gpxe (Show other bugs)
5.9
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-06 03:24 EDT by Sibiao Luo
Modified: 2013-04-17 11:06 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-17 11:06:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sibiao Luo 2012-08-06 03:24:37 EDT
Description of problem:
   Boot guest with gpxe in boot menu(F12), KVM cann't read hard disk correctly at the first time booting, after guest reboot (the second time) automatically, it then can boot from hard disk successfully.

Version-Release number of selected component (if applicable):
host info:
# uname -r && rpm -q kvm
2.6.18-333.el5
kvm-83-258.el5
# rpm -qa | grep  gpxe
gpxe-roms-qemu-0.9.7-9.el5
guest info:
# uname -r
2.6.18-333.el5

How reproducible:
almost every time

Steps to Reproduce:
1.prepare image installed with rhel5.9 64bit guest.
2.# alternatives --config qemu-pxe-roms

There are 2 programs which provide 'qemu-pxe-roms'.

  Selection    Command
-----------------------------------------------
*  1           /usr/share/etherboot
 + 2           /usr/share/gpxe

Enter to keep the current selection[+], or type selection number: 2
3.boot rhel 5.9 64bit guest.
eg: # /usr/libexec/qemu-kvm -m 2G -smp 2,cores=2,threads=1,sockets=1 -M rhel5.6.0 -cpu qemu64,+sse2 -name virtio_nic_test -drive file=/home/RHEL-Server-5.9-64-virtio.qcow2,format=qcow2,media=disk,if=virtio,cache=none,werror=stop,boot=on -uuid `uuidgen` -balloon virtio -monitor unix:/tmp/virt-nic-sluo,server,nowait -spice port=5931,disable-ticketing -qxl 1 -usbdevice tablet -soundhw ac97 -no-hpet -rtc-td-hack -no-kvm-pit-reinjection -monitor stdio -boot nc -net nic,vlan=0,model=virtio,macaddr=08:2E:5F:0A:0D:1B -net tap,sndbuf=0,vlan=0,script=/etc/qemu-ifup,downscript=no
4.press F12 and select "Network [gPXE (PCI 00:00.0)]" from boot menu.
  
Actual results:
after the step 4, guest fail to boot from hard disk at the first time with gpxe, it will reboot automatically. after rebooting, it then can boot from hard disk successfully.

Expected results:
guest should read hard disk correctly at the first time booting.

Additional info:
Comment 1 RHEL Product and Program Management 2012-08-06 03:29:17 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 4 RHEL Product and Program Management 2013-04-17 11:06:16 EDT
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.