Bug 845946 - libtevent owns the system level manpage directory and does not build man pages
libtevent owns the system level manpage directory and does not build man pages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libtevent (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Simo Sorce
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-06 04:14 EDT by Jakub Hrozek
Modified: 2012-08-17 09:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-17 09:44:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a spec file patch. (1.86 KB, patch)
2012-08-06 04:14 EDT, Jakub Hrozek
sgallagh: review+
Details | Diff

  None (edit)
Description Jakub Hrozek 2012-08-06 04:14:18 EDT
Created attachment 602457 [details]
a spec file patch.

Description of problem:
libtevent in rawhide seems to be owning the top-level directory for man page section 3:

%{_mandir}/man3/

It also doesn't build man pages, because it lacks the proper BuildRequries. 

Including the man pages might be questionable because the same information is mostly included in the header file and completely included in the upstream HTML documentation.

Version-Release number of selected component (if applicable):
0.9.16-2

How reproducible:
specfile inspection, rpmlint

Additional info:
a patch is attached. Andreas already fixed the issue with exclude patterns in tevent upstream.
Comment 1 Stephen Gallagher 2012-08-06 07:57:21 EDT
Comment on attachment 602457 [details]
a spec file patch.

The patch looks good. Despite the upstream documentation being good, I'd still prefer to have the manpages included in the package simply because this way they are viewable while disconnected. The comments in the header file are good, but somewhat less easily-readable.
Comment 2 Jakub Hrozek 2012-08-17 09:44:10 EDT
Fixed in libtevent-0.9.16-3

Note You need to log in before you can comment on or make changes to this bug.