Bug 845953 - in some applications, text fields don't accept keyboard input.
in some applications, text fields don't accept keyboard input.
Status: CLOSED DUPLICATE of bug 843296
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-06 05:05 EDT by morrigan
Modified: 2012-10-11 21:31 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-11 21:31:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description morrigan 2012-08-06 05:05:39 EDT
Description of problem:

I don't know what component to file this against - it's about input methods.

In some apps, keyboard input in text fields doesn't work - the cursor is visible, but no keystrokes are accepted. I observe this mainly with pidgin (both the window for status messages and conversation windows) and the network manager applet in KDE when it asks for the secret of a wireless connection.

This behaviour is not window manager dependant (reproduced under kde, xfce, gnome) and not user dependant (tried with freshly created user)

workaround is the context menu that's bount to right mouse button where input methods can be selected. This is set to System(Simple) by default. Set it to anything else (Simple will do) and keyboard input works again. Set it back to System(Simple) and it will continue to work. 

I don't know yet whether it is permanently fixed by this or whether it will have to be set again in a new x session.

Version-Release number of selected component (if applicable):


How reproducible:

with fresh user, every time

Steps to Reproduce:
1. open pidgin, set status
2. get status window, try to write anything in there. 

  
Actual results:

keyboard input doen't appear in text field

Expected results:

the opposite :)

Additional info:
set input method for this to anything. Write, it now works normally
Comment 1 Ondrej Vasik 2012-08-06 06:19:26 EDT
Setup component is definitely wrong one - for the multicomponent issues it is the best way to file this as tracker against distribution and single bugzilla per affected component. As I'm not sure if this is really the purpose of the bugzilla, only reassigning to distribution component.
Comment 2 morrigan 2012-08-06 07:23:19 EDT
Okay, sorry, didn't know I could file against distribution.

FWIW, I don't think it's really a multicomponent issue. It's just the overall input method handling. If I had to guess, I'd say it's probably just some default setting that doesn't exist in some/most configs and isn't caught by the overall framework...once you set it to anything, it works.

Not sure how and where to debug this, though...never played around with input methods before.
Comment 3 fujiwara 2012-08-08 21:13:10 EDT
I don't understand your problem.
Would you attached the screenshot?

% gnome-screenshot -i
Comment 4 Freddy Willemsen 2012-08-13 06:03:01 EDT
I am observing the exact same issue. Only noticed this in Pidgin though. Will try the workaround with the input method selection next time.

setup: F17 x86_64, lxde, pidgin 2.10.6-3.fc17 (recompiled from rawhide to see if this fixes the issue). I have no ibus packages installed.
Comment 5 Freddy Willemsen 2012-08-13 09:40:29 EDT
Upstream bug report:
http://developer.pidgin.im/ticket/15220
Comment 6 fujiwara 2012-08-13 22:59:50 EDT
(In reply to comment #4)
> I am observing the exact same issue. Only noticed this in Pidgin though.
> Will try the workaround with the input method selection next time.
> 
> setup: F17 x86_64, lxde, pidgin 2.10.6-3.fc17 (recompiled from rawhide to
> see if this fixes the issue). I have no ibus packages installed.

I don't see any problems in pidgin.
If you could see your problem without ibus, the problem is not in ibus.
Comment 7 Freddy Willemsen 2012-08-23 14:10:14 EDT
I have filed a bug againts gtk2 (https://bugzilla.gnome.org/show_bug.cgi?id=682563). Downgrading to 2.24.10 solves the issue.
Comment 8 Michael Cronenworth 2012-10-11 10:08:52 EDT
I believe this is a duplicate of bug 843296.
Comment 9 Freddy Willemsen 2012-10-11 10:12:01 EDT
Upgrading to gtk-2.24.12 definitely solved the issue for me!
Comment 10 fujiwara 2012-10-11 21:31:02 EDT
(In reply to comment #8)
> I believe this is a duplicate of bug 843296.

OK, thanks.

*** This bug has been marked as a duplicate of bug 843296 ***

Note You need to log in before you can comment on or make changes to this bug.