Bug 845973 - Assertion 'new_length >= 3' failed at src/shared/util.c:3724, function ellipsize_mem(). Aborting.
Assertion 'new_length >= 3' failed at src/shared/util.c:3724, function ellips...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-06 06:57 EDT by Jan Hutař
Modified: 2012-10-07 18:44 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-07 18:44:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2012-08-06 06:57:44 EDT
Description of problem:
I have noted this failure.


Version-Release number of selected component (if applicable):
systemd-44-17.fc17.x86_64
systemd-sysv-44-17.fc17.x86_64
osa-dispatcher-5.11.4-1.fc17.noarch


How reproducible:
always on mine one setup


Steps to Reproduce:
1. Have system with osa-dispatcher failing to start (=> in "Active: failed (Result: exit-code)" state)
2. Attempt to get its state in cron or somewhere
   (maybe fact it do not have terminal is important here)
   # at now
   at> systemctl status  osa-dispatcher.service
   at> <EOT>
   job 3 at Tue Aug  7 21:08:00 2012
3. Check result of the job


Actual results:
Message  3:
From root@<fqdn>  Tue Aug  7 21:08:58 2012
Return-Path: <root@<fqdn>>
Date: Tue, 7 Aug 2012 21:08:58 -0400
From: root <root@<fqdn>>
Subject: Output from your job        3
To: root@<fqdn>
Status: R

Assertion 'new_length >= 3' failed at src/shared/util.c:3724, function ellipsize_mem(). Aborting.
osa-dispatcher.service - OSA Dispatcher daemon
	  Loaded: loaded (/usr/lib/systemd/system/osa-dispatcher.service; enabled)
	  Active: failed (Result: exit-code) since Tue, 07 Aug 2012 20:59:22 -0400; 9min ago
	 Process: 30194 ExecStart=/usr/sbin/osa-dispatcher --pid-file $PIDFile (code=exited, status=1/FAILURE)
	  CGroup: name=systemd:/system/osa-dispatcher.service

Aug 07 20:59:22 hp-bl280cg6-01.rhts.eng.bos.redhat.com osa-dispatcher[30194]/bin/bash: line 1: 30422 Aborted                 systemctl status osa-dispatcher.service


Expected results:
Should work.


Additional info:
This commit have related commit message, but have not tested:
http://cgit.freedesktop.org/systemd/systemd/commit/?id=b61a4660fcfb76f062c081110fb18424b0bb7b23
Comment 3 Michal Schmidt 2012-08-06 08:41:03 EDT
> This commit have related commit message, but have not tested:
> http://cgit.freedesktop.org/systemd/systemd/commit/
> ?id=b61a4660fcfb76f062c081110fb18424b0bb7b23

Neither have I, but it's likely to be the fix.
Comment 4 Fedora Update System 2012-09-20 15:55:15 EDT
systemd-190-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/systemd-190-1.fc18
Comment 5 Fedora Update System 2012-09-22 02:36:26 EDT
Package systemd-191-2.fc18, rtkit-0.11-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-191-2.fc18 rtkit-0.11-3.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14581/rtkit-0.11-3.fc18,systemd-191-2.fc18
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-09-27 20:16:53 EDT
Package glibc-2.16-17.fc18, systemd-192-1.fc18, selinux-policy-3.11.1-23.fc18, rtkit-0.11-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing glibc-2.16-17.fc18 systemd-192-1.fc18 selinux-policy-3.11.1-23.fc18 rtkit-0.11-3.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14581/selinux-policy-3.11.1-23.fc18,rtkit-0.11-3.fc18,systemd-192-1.fc18,glibc-2.16-17.fc18
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-10-01 16:08:55 EDT
Package glibc-2.16-17.fc18, rtkit-0.11-3.fc18, systemd-193-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing glibc-2.16-17.fc18 rtkit-0.11-3.fc18 systemd-193-1.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14581/rtkit-0.11-3.fc18,systemd-193-1.fc18,glibc-2.16-17.fc18
then log in and leave karma (feedback).

Note You need to log in before you can comment on or make changes to this bug.