Bug 845994 - [3.x] [vdsm hooks] - run VM failure after successfully file upload
[3.x] [vdsm hooks] - run VM failure after successfully file upload
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm (Show other bugs)
6.3
Unspecified Unspecified
medium Severity high
: rc
: 6.3
Assigned To: Gal Hammer
Larisa Ustalov
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-06 08:32 EDT by Larisa Ustalov
Modified: 2014-02-09 18:05 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-12 04:55:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm log file (721.36 KB, application/x-xz)
2012-08-06 08:35 EDT, Larisa Ustalov
no flags Details

  None (edit)
Description Larisa Ustalov 2012-08-06 08:32:54 EDT
Failed to run VM after successful file injection to the VM disk.
Guest FS is not unmounted after successful write.

Steps to Reproduce:
1.create VM with custom properties - fileinject
2.start VM

Additional info:
see the attached vdsm log
Comment 1 Larisa Ustalov 2012-08-06 08:35:31 EDT
Created attachment 602502 [details]
vdsm log file
Comment 3 Gal Hammer 2012-08-06 10:11:38 EDT
A proposed fix: http://gerrit.ovirt.org/#/c/6956/
Comment 4 Itamar Heim 2012-08-07 02:41:28 EDT
larisa - we don't build/ship this hook.
why is this bug on rhel rather than on ovirt?
(that's not to say we shouldn't fix this issue in upstream vdsm repo)
Comment 5 Yaniv Kaul 2012-08-07 02:45:42 EDT
(In reply to comment #4)
> larisa - we don't build/ship this hook.
> why is this bug on rhel rather than on ovirt?

It was found on RHEL, so filed on RHEL.

> (that's not to say we shouldn't fix this issue in upstream vdsm repo)
Comment 7 Larisa Ustalov 2012-08-07 05:19:12 EDT
This is vdsm hook package installed on rhel.
vdsm-hook-fileinject-1.0-1.fc14.x86_64
Comment 8 Michal Skrivanek 2012-08-14 03:13:24 EDT
not shipping this hook, pushing out of 3.1
Comment 9 Michal Skrivanek 2012-09-12 04:55:42 EDT
merged upstream so should be in next release after the rebase (not 3.1)
Comment 10 Itamar Heim 2012-09-12 06:48:56 EDT
actually, just upstream, since we don't ship these.

Note You need to log in before you can comment on or make changes to this bug.