Bug 846006 - [RFE] auto-add Hot Key combos to "Send key" menu
Summary: [RFE] auto-add Hot Key combos to "Send key" menu
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer
Version: 3.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.3.0
Assignee: Marc-Andre Lureau
QA Contact: Desktop QE
URL:
Whiteboard: spice
Depends On: 846005 922716
Blocks: 1019470
TreeView+ depends on / blocked
 
Reported: 2012-08-06 13:10 UTC by David Jaša
Modified: 2016-02-10 20:20 UTC (History)
8 users (show)

Fixed In Version: mingw-virt-viewer-0.5.6-6.el6_4
Doc Type: Enhancement
Doc Text:
Hot Key combinations are now automatically added to the "Send Key" menu when remote-viewer is launched. These hot key menu entries can be used to pass key combinations to the guest.
Clone Of: 846005
Environment:
Last Closed: 2014-01-21 14:44:25 UTC
oVirt Team: Spice
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0034 0 normal SHIPPED_LIVE mingw-virt-viewer enhancement update 2014-01-21 19:41:37 UTC

Description David Jaša 2012-08-06 13:10:28 UTC
just to have this tracked in windows builds...


+++ This bug was initially created as a clone of Bug #846005 +++

Description of problem:
auto-add Hot Key combos to "Send key" menu. Because Hot Keys are always captured by virt-viewer, there is currently no way to pass them to the guest.

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-9.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. run remote-viewer from RHEV-M User Portal OR from spice-xpi test page with "Hot Keys" field including "release-cursor=shift+f12"
2. try to make shift-f12 key combo reach the guest
3.
  
Actual results:
there's no way to make shift-f12 reach the guest

Expected results:
user can send shift-f12 to the guest

Additional info:
* shift-f12 is a default keyboard shortcut for cursor release in RHEV-M/oVirt
* shift-f12 is used in web browsers to run web developer tools
* shift-f12 is used in OpenOffice/LibreOffice to toggle bullet lists

Comment 1 Andrew Cathrow 2013-02-19 22:42:03 UTC
Dependent bug missed 6.4, when this goes into 6.5 we can see if we can get a .Z but it's not likely.

Comment 3 Marc-Andre Lureau 2013-07-22 17:52:59 UTC
Sent patches to the ML:
https://www.redhat.com/archives/virt-tools-list/2013-July/msg00124.html

Comment 12 Charlie 2013-11-28 01:26:41 UTC
This bug is currently attached to errata RHEA-2013:15512. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.

Comment 14 errata-xmlrpc 2014-01-21 14:44:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0034.html


Note You need to log in before you can comment on or make changes to this bug.