Bug 846016 - [vdsm] [Setup Host Networks] After changing nics for network, both ifcfg files are left with BRIDGE=<networkName>
[vdsm] [Setup Host Networks] After changing nics for network, both ifcfg file...
Status: CLOSED DUPLICATE of bug 845193
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Dan Kenigsberg
Meni Yakove
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-06 10:01 EDT by Muli Salem
Modified: 2012-08-07 02:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-07 02:37:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Muli Salem 2012-08-06 10:01:18 EDT
Description of problem:
When changing interfaces for a network, ifcfg file in old interface is left with BRIDGE=<networkName>.

Version-Release number of selected component (if applicable):
4.10.0-0.254

How reproducible:
always

Steps to Reproduce:
From WebAdmin:
1. Add host with more than 1 NIC to setup.
2. Add a network which is defined as a vm network.
3. In Setup Host Networks, assign this network to a nic and click OK.
4. In Setup Host Networks, drag the network to another nic and click OK.
  
Actual results:
Both /etc/sysconfig/network-scripts/ifcfg-<originalNicName>
and /etc/sysconfig/network-scripts/ifcfg-<newNicName>
have BRIDGE=<networkName>

Expected results:
The line should be removed from /etc/sysconfig/network-scripts/ifcfg-<originalNicName>

Additional info:
Also need to make sure the bridge that is up is not connected to both nics.
Comment 1 lpeer 2012-08-07 02:37:19 EDT

*** This bug has been marked as a duplicate of bug 845193 ***

Note You need to log in before you can comment on or make changes to this bug.