Bug 846047 - BUG: unable to handle kernel paging request at ffffffffffffffe8 hidraw_report_event
BUG: unable to handle kernel paging request at ffffffffffffffe8 hidraw_report...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.3
x86_64 Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Don Zickus
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-06 12:33 EDT by Orion Poplawski
Modified: 2015-10-04 23:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-04 23:26:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lsusb -v output (31.28 KB, application/octet-stream)
2012-08-06 12:33 EDT, Orion Poplawski
no flags Details

  None (edit)
Description Orion Poplawski 2012-08-06 12:33:13 EDT
Created attachment 602540 [details]
lsusb -v output

Description of problem:

I've been getting these pretty regularly (every couple of days):

BUG: unable to handle kernel paging request at ffffffffffffffe8
IP: [<ffffffff81415848>] hidraw_report_event+0x48/0xe0
PGD 1a87067 PUD 1a88067 PMD 0 
Oops: 0000 [#1] SMP 
last sysfs file: /sys/devices/pci0000:00/0000:00:1d.7/usb2/2-5/2-5.4/2-5.4:1.1/bInterfaceNumber
CPU 2 
Modules linked in: cryptd aes_x86_64 aes_generic cbc cts ip6table_filter ip6_tables ebtable_nat e
btables ipt_MASQUERADE iptable_nat nf_nat nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack 
ipt_REJECT xt_CHECKSUM iptable_mangle iptable_filter ip_tables nfs fscache nfsd lockd nfs_acl exp
ortfs autofs4 w83627hf hwmon_vid coretemp ipmi_si ipmi_msghandler rpcsec_gss_krb5 auth_rpcgss sun
rpc cpufreq_ondemand acpi_cpufreq freq_table mperf bridge stp llc ipv6 vhost_net macvtap macvlan 
tun kvm_intel kvm raid1 microcode i2c_i801 i2c_core iTCO_wdt iTCO_vendor_support e1000e sg snd_hd
a_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm snd_timer sn
d soundcore snd_page_alloc ioatdma dca i7core_edac edac_core shpchp ext4 mbcache jbd2 raid10 fire
wire_ohci firewire_core crc_itu_t sr_mod cdrom sd_mod crc_t10dif ahci mptsas mptscsih mptbase scs
i_transport_sas dm_mirror dm_region_hash dm_log dm_mod [last unloaded: scsi_wait_scan]

Pid: 0, comm: swapper Not tainted 2.6.32-279.2.1.el6.x86_64 #1 Supermicro X8DA3/X8DA3
RIP: 0010:[<ffffffff81415848>]  [<ffffffff81415848>] hidraw_report_event+0x48/0xe0
RSP: 0018:ffff880028283aa8  EFLAGS: 00010082
RAX: 0000000000000000 RBX: fffffffffffffbe8 RCX: 0000000000000000
RDX: 0000000000020001 RSI: 000000000000001d RDI: ffff8805cc128c08
RBP: ffff880028283ae8 R08: 0000000000000046 R09: 0000000000000000
R10: 0000000000000001 R11: ffff88003780c180 R12: 0000000000000000
R13: ffff88062dd643f8 R14: 0000000000000008 R15: ffff88003780c180
FS:  0000000000000000(0000) GS:ffff880028280000(0000) knlGS:0000000000000000
CS:  0010 DS: 0018 ES: 0018 CR0: 000000008005003b
CR2: ffffffffffffffe8 CR3: 0000000c1d5a6000 CR4: 00000000000026e0
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Process swapper (pid: 0, threadinfo ffff880630648000, task ffff880c30e60aa0)
Stack:
 ffff88062dd643c0 0000000000000008 ffff880028283ae8 ffff88003780c180
<d> 0000000000000008 0000000000000000 0000000000000008 0000000000000008
<d> ffff880028283ba8 ffffffff81410426 000000210000000f 0000001000000002
Call Trace:
 <IRQ> 
 [<ffffffff81410426>] hid_report_raw_event+0x4a6/0x5c0
 [<ffffffff8127cf44>] ? snprintf+0x34/0x40
 [<ffffffff81411226>] hid_input_report+0x226/0x380
 [<ffffffff8141b4f5>] hid_irq_in+0x1f5/0x240
 [<ffffffff81271a29>] ? cpumask_next_and+0x29/0x50
 [<ffffffff813a6af4>] usb_hcd_giveback_urb+0x64/0xe0
 [<ffffffff813c0170>] ehci_urb_done+0x90/0xe0
 [<ffffffff813c05d5>] qh_completions+0x415/0x690
 [<ffffffff813c3230>] ehci_work+0x480/0xaf0
 [<ffffffff8106067c>] ? rebalance_domains+0x3cc/0x5a0
 [<ffffffff813c433a>] ehci_irq+0x22a/0x530
 [<ffffffff81057ffe>] ? scheduler_tick+0x11e/0x260
 [<ffffffff810e1244>] ? __rcu_process_callbacks+0x54/0x330
 [<ffffffff8106089c>] ? run_rebalance_domains+0x4c/0x160
 [<ffffffff813a597f>] usb_hcd_irq+0x3f/0x90
 [<ffffffff810db930>] handle_IRQ_event+0x60/0x170
 [<ffffffff810de1e8>] handle_fasteoi_irq+0x88/0xf0
 [<ffffffff8100df09>] handle_irq+0x49/0xa0
 [<ffffffff81505c1c>] do_IRQ+0x6c/0xf0
 [<ffffffff8100ba53>] ret_from_intr+0x0/0x11
 <EOI> 
 [<ffffffff812cd9fe>] ? intel_idle+0xde/0x170
 [<ffffffff812cd9e1>] ? intel_idle+0xc1/0x170
 [<ffffffff8109914d>] ? sched_clock_cpu+0xcd/0x110
 [<ffffffff81407757>] cpuidle_idle_call+0xa7/0x140
 [<ffffffff81009e06>] cpu_idle+0xb6/0x110
 [<ffffffff814f6e0f>] start_secondary+0x22a/0x26d
Code: 49 89 f7 41 89 d6 48 89 7d c0 48 8b 47 38 49 89 fd 49 83 c5 38 49 39 c5 48 8d 98 e8 fb ff f
f 74 75 48 63 c2 48 89 45 c8 0f 1f 00 <4c> 63 a3 00 04 00 00 48 8b 75 c8 ba 20 00 00 00 4c 89 ff 
e8 40 
RIP  [<ffffffff81415848>] hidraw_report_event+0x48/0xe0
 RSP <ffff880028283aa8>
CR2: ffffffffffffffe8

I have a 4 port USB hub connected to 4 USB temperature sensors that I am reading regularly which I suspect is triggering this.
Comment 2 Orion Poplawski 2012-08-07 16:31:07 EDT
I have a  4.6GB vmcore file at http://sw.cora.nwra.com/test/vmcore.xz if that will help.
Comment 3 RHEL Product and Program Management 2012-12-14 03:37:39 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 Don Zickus 2013-07-18 11:13:15 EDT
Hi,

I believe this has been fixed in the latest 6.3.z kernels and 6.4 with
bz839973.  Please try those kernels and let me know if the problem
still persists.

Cheers,
Don
Comment 6 Orion Poplawski 2013-07-19 13:08:08 EDT
Thanks, I'll try to someday, but I'm currently prevented from running newer kernels on this machine due to bug #949166
Comment 7 Don Zickus 2013-07-19 14:27:34 EDT
Hi,

That bz says you are running 2.6.32-279.22.1.el6, which should include the fix
for this bz.  Are you still seeing this issue with that kernel?

Cheers,
Don
Comment 9 Orion Poplawski 2014-06-25 17:29:19 EDT
I'll try to test this out soon.
Comment 10 Orion Poplawski 2014-07-30 12:11:40 EDT
Seems to be working fine now with the -431 kernels.

Note You need to log in before you can comment on or make changes to this bug.