Bug 846065 - Enable dlopen-type DLZ modules in Bind
Enable dlopen-type DLZ modules in Bind
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bind (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Tomáš Hozza
qe-baseos-daemons
: Patch
Depends On:
Blocks: 1096688
  Show dependency treegraph
 
Reported: 2012-08-06 13:20 EDT by Giuseppe Ragusa
Modified: 2014-10-14 00:34 EDT (History)
2 users (show)

See Also:
Fixed In Version: bind-9.8.2-0.26.rc1.el6
Doc Type: Bug Fix
Doc Text:
Cause: Previously BIND was not configured with --with-dlopen=yes option before build. Consequence: As a result, external DLZ drivers could not be dynamically loaded. Fix: BIND is now configured with the --with-dlopen=yes option before build. Result: As a result, external DLZ drivers can now be dynamically loaded.
Story Points: ---
Clone Of:
: 1096688 (view as bug list)
Environment:
Last Closed: 2014-10-14 00:34:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Giuseppe Ragusa 2012-08-06 13:20:01 EDT
Description of problem:
Now that Bind has been rebased to 9.8.x it is possible to provide support for the Samba4-provided external DLZ module for AD-backed zones (currently the only DNS solution capable of secure DDNS in Samba4); unfortunately, this support is not enabled in current builds of Bind in RHEL6.

Version-Release number of selected component (if applicable):
9.8.2-0.10.rc1.el6_3.2

How reproducible:
Try to configure the Bind DLZ module in Samba4.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
External DLZ modules not supported.


Expected results:
Samba4-provided external DLZ module is correctly loaded.

Additional info:
Simply adding the "--with-dlopen=yes" option to the %configure part of the spec enabled such support; no adverse effects are expected for the other already shipped parts of Bind.
Note that bind-chroot support for the Samba4-provided module could require additional careful configuration.
Comment 2 Giuseppe Ragusa 2012-09-04 06:16:08 EDT
After additional testing I suspect that the failures where probably due to other problems on the Samba4 side of things.

Furthermore Bind docs suggest that "--with-dlopen=yes" should be the default in versions >= 9.8.1

I'm going to test with the standard Bind package again asap and will report back.
Comment 5 RHEL Product and Program Management 2013-10-13 20:32:01 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 11 errata-xmlrpc 2014-10-14 00:34:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1373.html

Note You need to log in before you can comment on or make changes to this bug.