Bug 846085 - systemd-logind ignores an empty ResetControllers variable, still tries to reset cpu controller
systemd-logind ignores an empty ResetControllers variable, still tries to res...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-06 15:04 EDT by Robert Kennedy
Modified: 2012-10-07 18:44 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-07 18:44:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Kennedy 2012-08-06 15:04:32 EDT
Description of problem:

We run a custom 3.1 kernel that does not enable CONFIG_CGROUP_* like the stock Fedora kernel. When we upgraded to systemd-37-25.fc16.x86_64 from systemd-37-13.fc16.x86_64 we started getting these messages in our /var/log/messages:

Aug  6 13:48:16 dev3 systemd-logind[1240]: Failed to reset controller cpu: No such file or directory

It would seem that modifying /etc/systemd/systemd-logind.conf so it has

ResetControllers=

instead of

ResetControllers=cpu

should prevent this, but it does not.

Version-Release number of selected component (if applicable):
systemd-37-25.fc16.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Run a 3.1 kernel without CONFIG_CGROUP_SCHED=y (I think it's this one)
2. Attempt to quell sending a reset to a nonexistent resource controller with systemd-logind.conf
  
Actual results:

systemd-logind still tries to send a reset to the cpu resource controller

Expected results:

systemd-logind should not try to send a reset to a nonexistent resource controller

Additional info:
Comment 1 Lennart Poettering 2012-09-14 09:13:12 EDT
This is fixed in F18.
Comment 2 Shawn Bohrer 2012-09-14 11:08:43 EDT
Hey Lennart,

Will this be fixed in F16 as well?  I hope so since F16 should still be receiving updates and this was a regression between systemd-37-13.fc16.x86_64 to systemd-37-25.fc16.x86_64
Comment 3 Fedora Update System 2012-09-20 15:55:09 EDT
systemd-190-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/systemd-190-1.fc18
Comment 4 Fedora Update System 2012-09-22 02:36:20 EDT
Package systemd-191-2.fc18, rtkit-0.11-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-191-2.fc18 rtkit-0.11-3.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14581/rtkit-0.11-3.fc18,systemd-191-2.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-09-27 20:16:46 EDT
Package glibc-2.16-17.fc18, systemd-192-1.fc18, selinux-policy-3.11.1-23.fc18, rtkit-0.11-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing glibc-2.16-17.fc18 systemd-192-1.fc18 selinux-policy-3.11.1-23.fc18 rtkit-0.11-3.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14581/selinux-policy-3.11.1-23.fc18,rtkit-0.11-3.fc18,systemd-192-1.fc18,glibc-2.16-17.fc18
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-10-01 16:08:46 EDT
Package glibc-2.16-17.fc18, rtkit-0.11-3.fc18, systemd-193-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing glibc-2.16-17.fc18 rtkit-0.11-3.fc18 systemd-193-1.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14581/rtkit-0.11-3.fc18,systemd-193-1.fc18,glibc-2.16-17.fc18
then log in and leave karma (feedback).

Note You need to log in before you can comment on or make changes to this bug.