Bug 84609 - X can not load fonts (using unix:7100) after latest upgrade
X can not load fonts (using unix:7100) after latest upgrade
Status: CLOSED DUPLICATE of bug 79106
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-19 10:59 EST by Benoit Dionne
Modified: 2007-04-18 12:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:51:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Benoit Dionne 2003-02-19 10:59:23 EST
Description of problem:

Since I did the upgrade of my system (from kernel 2.14.18-14 to 
2.14.18-24.8.0), X (I should say xfs) can not load the fonts anymore.

I get the following error message at the end of the log file XFree86.0.log:
   Fatal server error:
   could not open default font 'fixed'

In the log file messages, I get:
   Feb 17 10:51:22 mollux xfs: listening on port 7100
   Feb 17 10:51:22 mollux xfs: ignoring font path element  
/usr/X11R6/lib/X11/fonts/misc:unscaled (unreadable)
   Feb 17 10:51:22 mollux xfs: ignoring font path element 
/usr/X11R6/lib/X11/fonts/misc (unreadable)
   Feb 17 10:51:22 mollux xfs: ignoring font path element 
/usr/X11R6/lib/X11/fonts/cyrillic (unreadable)
   Feb 17 10:51:22 mollux xfs: xfs startup succeeded

To be able to start the X server, I have commented out the line
FontPath  "unix:7100"  in the configuration file  XF86Config  and explicitely 
listed the font paths in this configuration file.  None of the RedHat tools 
(i.e. redhat-config-xfree86 in RedHat 8.0) was useful to solve the problem.

How reproducible:
We have gotten the same problem when upgrading RedHat 8.0 on other computers 
in the department (I should say IBM computers).

Steps to Reproduce:
1. Do the full (network) upgrade from the original distribution of RedHat 8.0 
using RedHat tools.
2.
3.
    
Actual results:
The X server does not start at all.  You have to work in text mode.

Expected results:
The X server should start (it uses to).

Additional info:
Comment 1 Mike A. Harris 2003-02-19 20:57:03 EST
There has been no XFree86 update for Red Hat Linux 8.0, so there is no
way possible that XFree86 is at fault here.  More likely, during your
update, kdebase was updated, which contains a known bug where new fonts
got added to kdebase with broken RPM installation scripts, which causes
the problem you describe above.  This problem has been around for about
3 months and should get fixed in future kdebase erratum.

Reassigning to kdebase.
Comment 2 Benoit Dionne 2003-02-20 11:30:34 EST
I did not look at the "kdebase" component section before to send my bug report.

Please see bugs 79106 and 79119

*** This bug has been marked as a duplicate of 79106 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:51:52 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.