Bug 846104 - navigation menus shown for wrong permissions
navigation menus shown for wrong permissions
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Tom McKay
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-06 16:16 EDT by Tom McKay
Modified: 2014-03-18 13:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-18 13:38:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom McKay 2012-08-06 16:16:35 EDT
Users w/o proper permissions should not be shown navigation links that lead them to "403 - Permission Denied" pages. In the set up below, the following nav elements should _not_ be shown:

Content
  -> Subscriptions


name=CommunityY

katello org create --name $name
katello environment create --org $name --name Weekly --prior Library

katello client remember --option org --value $name

katello provider create --name "$name Provider"

katello user_role create --name "$name Role"
katello permission create --user_role "$name Role" --name "$name Systems" --scope environments --verbs "register_systems,read_contents" --tag Weekly
katello permission create --user_role "$name Role" --name "$name Provider" --scope providers --verbs "read" --tag "CommunityY" --tag "$name Provider"

katello user create --username $name --password $name --email "thomasmckay@redhat.com" --default_organization $name --default_environment Weekly
katello user assign_role --username $name --role "$name Role"
Comment 1 Mike McCune 2014-03-18 13:38:29 EDT
This bug was closed because of a lack of activity.  If you feel this bug should be reconsidered for attention please feel free to re-open the bug with a comment stating why it should be reconsidered.

Note You need to log in before you can comment on or make changes to this bug.