Bug 846105 - String Update: Update Certificate Status Strings
String Update: Update Certificate Status Strings
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Shwetha Kallesh
Entitlement Bugs
:
Depends On:
Blocks: 771748 827225
  Show dependency treegraph
 
Reported: 2012-08-06 16:18 EDT by Matt Reid
Modified: 2013-01-07 22:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:58:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Keep system up to date by registering (70.13 KB, image/png)
2012-09-18 05:42 EDT, Shwetha Kallesh
no flags Details
System doesnot match subscription limits (71.53 KB, image/png)
2012-09-18 05:43 EDT, Shwetha Kallesh
no flags Details

  None (edit)
Description Matt Reid 2012-08-06 16:18:14 EDT
If possible could we update the current Certificate Status message strings we have in 5.9?

#: ../src/subscription_manager/gui/installedtab.py:308
#, python-format
msgid ""
"You have <b>%s</b> products with <i>invalid</i> entitlement certificates."
Replace with: "%s installed products do not have valid subscriptions." %s being the number of however many there are.

#: ../src/subscription_manager/gui/installedtab.py:312
msgid ""
"You have <b>1</b> product with an <i>invalid</i> entitlement certificate."
Replace with: "1 installed product does not have a valid subscription."

#: ../src/subscription_manager/gui/installedtab.py:319
#, python-format
msgid ""
"You have <b>%s</b> products in need of <i>additional</i> entitlement "
"certificates."
Replace with: "This system does not match subscription limits."

#: ../src/subscription_manager/gui/installedtab.py:323
msgid ""
"You have <b>1</b> product in need of <i>additional</i> entitlement "
"certificates."
Remove this and use same message as above (doesn't match limits)

#: ../src/subscription_manager/gui/installedtab.py:331
#, python-format
msgid "Product entitlement certificates <i>valid</i> until %s"
Replace with: "System is properly subscribed through %s." %s being the earliest end date of attached subscriptions.

#: ../src/subscription_manager/gui/installedtab.py:342
msgid "You must register this system before subscribing."
Replace with: "Keep your system up to date by registering."

#: ../src/subscription_manager/gui/installedtab.py:288
#: ../src/subscription_manager/branding/redhat_branding.py:10
msgid "This system is registered to RHN Classic"
Add a period, "This system is registered to RHN Classic."


I'm guessing that adding in a custom message for expired subscriptions is more then we can do after devel freeze, if not, I can update with that string.
Comment 1 Matt Reid 2012-08-07 15:37:35 EDT
Also this one:

#: ../src/subscription_manager/gui/installedtab.py:338
msgid "No product certificates installed."
Replace with: "No installed products detected."
Comment 2 Bryan Kearney 2012-08-16 09:20:58 EDT
fixed in master at df6569e119b1dc33456117f4133af272cb1c4de8.
Comment 3 RHEL Product and Program Management 2012-08-16 09:38:20 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 5 Shwetha Kallesh 2012-09-18 05:42:41 EDT
Created attachment 613935 [details]
Keep system up to date by registering

Verified!!

[root@dhcp201-110 product]# rpm -qa | grep subscription-manager
subscription-manager-1.0.17-1.el5
subscription-manager-gui-1.0.17-1.el5
subscription-manager-firstboot-1.0.17-1.el5
Comment 6 Shwetha Kallesh 2012-09-18 05:43:35 EDT
Created attachment 613936 [details]
System doesnot match subscription limits
Comment 8 errata-xmlrpc 2013-01-07 22:58:22 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.