Bug 846127 - Virt-Viewer: RHEL 6.3: Can't Change Resolution in Full Screen
Summary: Virt-Viewer: RHEL 6.3: Can't Change Resolution in Full Screen
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer
Version: 6.3
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Marc-Andre Lureau
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 873298
Blocks: 921410 921412
TreeView+ depends on / blocked
 
Reported: 2012-08-06 22:06 UTC by Vimal Patel
Modified: 2013-11-21 08:01 UTC (History)
13 users (show)

Fixed In Version: virt-viewer-0.5.6-1.el6
Doc Type: Bug Fix
Doc Text:
Previously, starting a virtual machine in full screen mode would prevent the guest resolution from being changed; it would always revert to the native monitor resolution. Now, spice-gtk correctly sets the full screen state on start-up in order to disable the guest auto-resize function appropriately.
Clone Of:
: 921410 921412 (view as bug list)
Environment:
Last Closed: 2013-11-21 08:01:33 UTC
Target Upstream Version:


Attachments (Terms of Use)
virsh xmldump of the VM with the full screen issue. (3.31 KB, text/plain)
2012-08-21 14:28 UTC, Vimal Patel
no flags Details
reproduce-log (431.81 KB, text/plain)
2012-08-24 12:37 UTC, yuping zhang
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1578 normal SHIPPED_LIVE virt-viewer bug fix and enhancement update 2013-11-20 21:39:50 UTC

Description Vimal Patel 2012-08-06 22:06:12 UTC
Description of problem:
When using remote-viewer to connect to a guest in full-screen, the VM appears with the resolution of the client.  If the resolution is attempted to be changed (Display Preferences) it cannot be done, The screen flashes with the resolution that you try to change it to, but then reverts to the original resolution.

Version-Release number of selected component (if applicable):
spice-gtk-python-0.11-11.el6.x86_64
spice-usb-share-4.9-9.el6.x86_64
spice-server-0.10.1-10.el6.x86_64
spice-gtk-0.11-11.el6.x86_64
spice-client-0.8.2-15.el6.x86_64
spice-vdagent-0.8.1-3.el6.x86_64
kmod-kspiceusb-rhel60-4.9-14.el6.x86_64
spice-glib-0.11-11.el6.x86_64
spice-xpi-2.7-20.el6.x86_64
usbredir-0.4.3-1.el6.x86_64
qemu-kvm-tools-0.12.1.2-2.295.el6.x86_64
qemu-kvm-0.12.1.2-2.295.el6.x86_64
xorg-x11-drv-qxl-0.0.14-13.el6_2.x86_64
virt-viewer-0.5.2-9.el6.x86_64
libvirt-client-0.9.10-21.el6_3.1.x86_64
libvirt-python-0.9.10-21.el6_3.1.x86_64
libvirt-0.9.10-21.el6_3.1.x86_64

How reproducible:
100%

Steps to Reproduce:
1.  Connect to a guest in full-screen (remote-viewer spice://<host>?port-<port> --full-screen &
2.
3.
  
Actual results:
Flashing of modified resolution, but it won't be kept, so it reverts back to the original resolution, and it cannot be changed by the user.

Expected results:
User can change resolution, should be kicked out of full screen if the Display can't handle it.

Additional info:

Comment 2 yuping zhang 2012-08-17 09:03:25 UTC
Hi Vimal,
I can not reproduce this issue with:
virt-viewer-0.5.2-9.el6.x86_64
libvirt-0.9.10-21.el6_3.3.x86_64
qemu-kvm-0.12.1.2-2.295.el6_3.1.x86_64
spice-server-0.10.1-10.el6.x86_64
spice-gtk-0.11-11.el6.x86_6

#remote-viewer spice://10.66.*.*:5901 --full-screen
I used win7 as guest,running on RHEL.
I changed the resolution between 1024*768 and 800*600,it works well.
Did you connect to a RHEV guest? What's the graphics XML? And any other configuration?

Comment 3 Vimal Patel 2012-08-17 11:46:21 UTC
Hi Yuging,

I created the guest from Virt Manager (client and host on the same machine), and I am connecting from a RHEL 6.3 client to a RHEL 6.3 guest, but I just tried it also on a Windows 7 guest, and I see the same issue it shows the changed resolution for a couple seconds flashes, and then goes back to the original full screen resolution.

Where do I find the graphics XML info?

Here's what I see from Xorg.0.log:

[323250.209] (II) intel(0): Printing DDC gathered Modelines:
[323250.209] (II) intel(0): Modeline "1920x1080"x0.0  148.50  1920 2008 2052 2200  1080 1084 1089 1125 +hsync +vsync (67.5 kHz)
[323250.209] (II) intel(0): Modeline "800x600"x0.0   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz)
[323250.209] (II) intel(0): Modeline "800x600"x0.0   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz)
[323250.209] (II) intel(0): Modeline "640x480"x0.0   30.24  640 704 768 864  480 483 486 525 -hsync -vsync (35.0 kHz)
[323250.209] (II) intel(0): Modeline "640x480"x0.0   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz)
[323250.209] (II) intel(0): Modeline "720x400"x0.0   28.32  720 738 846 900  400 412 414 449 -hsync +vsync (31.5 kHz)
[323250.209] (II) intel(0): Modeline "1024x768"x0.0   75.00  1024 1048 1184 1328  768 771 777 806 -hsync -vsync (56.5 kHz)
[323250.209] (II) intel(0): Modeline "1024x768"x0.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz)
[323250.209] (II) intel(0): Modeline "1152x864"x0.0  108.00  1152 1216 1344 1600  864 865 868 900 +hsync +vsync (67.5 kHz)
[323250.209] (II) intel(0): Modeline "1280x1024"x0.0  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync (64.0 kHz)
[323250.209] (II) intel(0): Modeline "1280x800"x0.0   83.50  1280 1352 1480 1680  800 803 809 831 -hsync +vsync (49.7 kHz)
[323250.209] (II) intel(0): Modeline "1440x900"x0.0  106.50  1440 1520 1672 1904  900 903 909 934 -hsync +vsync (55.9 kHz)
[323250.209] (II) intel(0): Modeline "1920x1080"x60.0  172.80  1920 2040 2248 2576  1080 1081 1084 1118 -hsync +vsync (67.1 kHz)

-Vimal

Comment 4 yuping zhang 2012-08-20 10:58:04 UTC
(In reply to comment #3)
> Hi Yuging,
> 
> I created the guest from Virt Manager (client and host on the same machine),
> and I am connecting from a RHEL 6.3 client to a RHEL 6.3 guest, but I just
> tried it also on a Windows 7 guest, and I see the same issue it shows the
> changed resolution for a couple seconds flashes, and then goes back to the
> original full screen resolution.

Hi Vimal,
I still can not reproduce this issue with win 7 installed by virt-manager.

> Where do I find the graphics XML info?

#virsh dumpxml <guest>

Comment 5 Vimal Patel 2012-08-21 14:27:17 UTC
Hi Yuping,

Thanks for the assistance.
I will attach the xml file for the RHEL63 image I was seeing the issue with.  The virsh commands worked after restarting libvirtd.

-Vimal

Comment 6 Vimal Patel 2012-08-21 14:28:23 UTC
Created attachment 605951 [details]
virsh xmldump of the VM with the full screen issue.

Comment 7 yuping zhang 2012-08-24 11:30:04 UTC
Hi Vimal,
I can reproduce this bug with your XML.I will update logs later.

Comment 8 yuping zhang 2012-08-24 12:37:55 UTC
Created attachment 606855 [details]
reproduce-log

Reproduce steps:
1.Install a guest with spice + qxl,please select qxl and spice in installation steps.

2.#virt-viewer -f rhel63-1 --debug --debug-spice
3.The guest will auto adjust the resolution to 1920*1080.
4.Change the resolution to 1024*768-> fail,it returns to 1920*1080.

Attach the log.

Comment 10 Marc-Andre Lureau 2013-05-09 14:55:30 UTC
this was fixed in bug 873298 ->  POST

Comment 15 tingting zheng 2013-07-04 08:19:36 UTC
I can reproduce this issue with:
virt-viewer-0.5.2-9.el6.x86_64
libvirt-0.9.10-21.el6_3.3.x86_64
spice-server-0.10.1-10.el6.x86_64
spice-gtk-0.11-11.el6.x86_6

Tested with:
virt-viewer-0.5.6-1.el6.x86_64
libvirt-0.10.2-18.el6_4.9.x86_64
spice-server-0.12.3-1.el6.x86_64
spice-gtk-0.20-1.el6.x86_64

Connect a guest with full screen,the resolution can be changed,so move the bug to VERIFIDE.

Comment 16 errata-xmlrpc 2013-11-21 08:01:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1578.html


Note You need to log in before you can comment on or make changes to this bug.