Bug 846152 - [PATCH] Please adapt slim for display manager rework feature
[PATCH] Please adapt slim for display manager rework feature
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: slim (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pavel Alexeev
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18DisplayManager
  Show dependency treegraph
 
Reported: 2012-08-06 20:09 EDT by Lennart Poettering
Modified: 2013-02-27 12:54 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-12 06:18:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (2.86 KB, patch)
2012-08-07 11:59 EDT, Lennart Poettering
no flags Details | Diff

  None (edit)
Description Lennart Poettering 2012-08-06 20:09:17 EDT
Heya,

please update the slim package to follow the new logic explained in the DisplayManagerRework page:

https://fedoraproject.org/wiki/Features/DisplayManagerRework

This requires shipping a systemd unit file in the slim package as well as changes to the .spec file.

Please ping us if you need help, or have questions.

Note that this is an accepted F18 feature, we'd be thankful if you could complete this update in time for the F18 release.
Comment 1 Lennart Poettering 2012-08-07 11:59:05 EDT
Created attachment 602793 [details]
proposed patch

Here's a patch that includes the necessary service file and hooks it up in the .spec file.
Comment 2 Lennart Poettering 2012-08-08 11:34:18 EDT
We will shortly upload a new version of systemd to F18, which removes support for prefdm. This means that slim will not work on F18 anymore until this bug is fixed.
Comment 3 Lennart Poettering 2012-08-08 17:17:36 EDT
A new systemd version without prefdm has now been uploaded to F18. This means slim is now broken on F18 until this bug is fixed. Please update your packages! Thanks!
Comment 4 Pavel Alexeev 2012-08-12 06:18:19 EDT
Thank you for the patch and sorry for the delay.

It had landed to rawhide: http://koji.fedoraproject.org/koji/taskinfo?taskID=4380326

One only question - should we inform upstream about such changes or it treated as Fedora specific?
Comment 5 Glen Gray 2013-02-27 12:54:50 EST
This still hasn't been pushed to F18, the latest version seems to be 1.3.3-2 and there's no slim.service etc. there.

Note You need to log in before you can comment on or make changes to this bug.