Bug 846188 - SELinux is preventing /usr/lib64/xulrunner-2/plugin-container from using the 'ipc_lock' capabilities.
SELinux is preventing /usr/lib64/xulrunner-2/plugin-container from using the ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:6f51dce692a81e148fd960a9ec3...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-07 01:11 EDT by Dennis
Modified: 2012-09-18 01:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-27 19:02:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis 2012-08-07 01:11:07 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.5.0-2.fc17.x86_64
time:           Tue 07 Aug 2012 12:06:40 AM CDT

description:
:SELinux is preventing /usr/lib64/xulrunner-2/plugin-container from using the 'ipc_lock' capabilities.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that plugin-container should have the ipc_lock capability by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep plugin-containe /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Objects                 [ capability ]
:Source                        plugin-containe
:Source Path                   /usr/lib64/xulrunner-2/plugin-container
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           xulrunner-14.0.1-3.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-142.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.0-2.fc17.x86_64 #1 SMP Mon Jul 30
:                              14:48:59 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    Mon 06 Aug 2012 07:07:29 PM CDT
:Last Seen                     Mon 06 Aug 2012 07:07:35 PM CDT
:Local ID                      442c8711-ce51-461a-9504-4b39375e2e1f
:
:Raw Audit Messages
:type=AVC msg=audit(1344298055.240:84): avc:  denied  { ipc_lock } for  pid=22037 comm="plugin-containe" capability=14  scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tclass=capability
:
:
:type=SYSCALL msg=audit(1344298055.240:84): arch=x86_64 syscall=mlock success=yes exit=0 a0=7f1522440000 a1=1000 a2=7fffb55fdfbc a3=1 items=0 ppid=1696 pid=22037 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=1 comm=plugin-containe exe=/usr/lib64/xulrunner-2/plugin-container subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: plugin-containe,mozilla_plugin_t,mozilla_plugin_t,capability,ipc_lock
:
:audit2allow
:
:#============= mozilla_plugin_t ==============
:allow mozilla_plugin_t self:capability ipc_lock;
:
:audit2allow -R
:
:#============= mozilla_plugin_t ==============
:allow mozilla_plugin_t self:capability ipc_lock;
:
Comment 1 Dennis 2012-08-07 12:42:30 EDT
I was running the google talk client and in a hangout at the time.
Comment 2 Miroslav Grepl 2012-08-08 06:36:47 EDT
Do you have mozilla_plugin_t as permissive domain?


syscall=mlock success=yes
Comment 3 Dennis 2012-08-09 02:21:57 EDT
I haven't changed anything from the stock install.  How do I check?
Comment 4 Daniel Walsh 2012-08-13 15:51:18 EDT
We should dontaudit.  Not sure how this can happen without a setuid app.
Comment 5 Daniel Walsh 2012-08-13 15:52:47 EDT
This could be a case where the SELinux check is done before the DAC check.  The syscall is failing with success, because mlock probably checks the capability and falls back to a safe mode.
Comment 6 Fedora Update System 2012-08-20 09:09:11 EDT
selinux-policy-3.10.0-146.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/selinux-policy-3.10.0-146.fc17
Comment 7 Fedora Update System 2012-08-21 05:49:58 EDT
Package selinux-policy-3.10.0-146.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.10.0-146.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-12355/selinux-policy-3.10.0-146.fc17
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-08-27 19:02:56 EDT
selinux-policy-3.10.0-146.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Dennis 2012-09-18 01:31:00 EDT
This appears to have resolved my issue -- thanks :-)

Note You need to log in before you can comment on or make changes to this bug.