Bug 84621 - assertion failures with ext3 filesystems
assertion failures with ext3 filesystems
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Stephen Tweedie
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-19 13:35 EST by Summer Maynard
Modified: 2013-12-15 18:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-25 04:56:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Complete /var/log/messages, as requested. (238.90 KB, text/plain)
2003-02-21 13:12 EST, Summer Maynard
no flags Details

  None (edit)
Description Summer Maynard 2003-02-19 13:35:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
From customer:

What I was doing to cause this error was running a I/O benchmark program called
IOZONE (www.iozone.org).

In particular, I was running 4 parallel instances of this program - all four
directed at one I/O card. This one I/O card is attached to two filesystems (one
filesystem per channel).

The parameters I used for the iozone exection are as follows:  "iozone -a -g 4G
-o - i 0 - i 1"



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. heavy I/O caused by benchmarking software...
2.
3.
    

Actual Results:  kernel panic with errors above

Expected Results:  no kernel panic

Additional info:
Comment 1 Summer Maynard 2003-02-19 13:35:48 EST
Following is the section of the /var/log/messages file which pertains to the panic:

Feb 11 14:07:09 msrdev1 kernel: Assertion failure in
journal_commit_transaction() at commit.c:526: "buffer_jdirty(bh)"
Feb 11 14:07:09 msrdev1 kernel: ------------[ cut here ]------------
Feb 11 14:07:09 msrdev1 kernel: kernel BUG at commit.c:526!
Feb 11 14:07:09 msrdev1 kernel: invalid operand: 0000
Feb 11 14:07:09 msrdev1 kernel: Kernel 2.4.9-e.10smp
Feb 11 14:07:09 msrdev1 kernel: CPU:    3
Feb 11 14:07:09 msrdev1 kernel: EIP:   
0010:[bcm5700:__insmod_bcm5700_O/lib/modules/2.4.9-e.10smp/kernel/drivers+-2551964/96]
   Not tainted
Feb 11 14:07:09 msrdev1 kernel: EIP:    0010:[<f8858f64>]    Not tainted
Feb 11 14:07:09 msrdev1 kernel: EFLAGS: 00010292
Feb 11 14:07:09 msrdev1 kernel: EIP is at journal_commit_transaction [jbd] 0xa64 
Feb 11 14:07:09 msrdev1 kernel: eax: 0000001f   ebx: 00000009   ecx: c02f2444  
edx: 00007900
Feb 11 14:07:09 msrdev1 kernel: esi: e51809a0   edi: c981d180   ebp: f2298720  
esp: f2849e7c
Feb 11 14:07:09 msrdev1 kernel: ds: 0018   es: 0018   ss: 0018
Feb 11 14:07:09 msrdev1 kernel: Process kjournald (pid: 228, stackpage=f2849000)
Feb 11 14:07:09 msrdev1 kernel: Stack: f886008e 0000020e 00000000 00000fac
d9892054 00000000 f2298720 e10ee820 
Feb 11 14:07:09 msrdev1 kernel:        000016e0 01000000 00000002 00000008
00000001 e94037e0 ea10f180 ea10f6c0 
Feb 11 14:07:09 msrdev1 kernel:        ea12c6c0 ea12bf80 ea12e660 ea12e420
ea1136c0 ea786f20 f2848000 c0351460 
Feb 11 14:07:09 msrdev1 kernel: Call Trace:
[bcm5700:__insmod_bcm5700_O/lib/modules/2.4.9-e.10smp/kernel/drivers+-2522994/96]
.LC63 [jbd] 0x18 
Feb 11 14:07:09 msrdev1 kernel: Call Trace: [<f886008e>] .LC63 [jbd] 0x18 
Feb 11 14:07:09 msrdev1 kernel: [run_local_timers+148/288] run_local_timers
[kernel] 0x94 
Feb 11 14:07:09 msrdev1 kernel: [<c0124e74>] run_local_timers [kernel] 0x94 
Feb 11 14:07:09 msrdev1 kernel: [smp_apic_timer_interrupt+184/208]
smp_apic_timer_interrupt [kernel] 0xb8 
Feb 11 14:07:09 msrdev1 kernel: [<c0114128>] smp_apic_timer_interrupt [kernel] 0xb8 
Feb 11 14:07:09 msrdev1 kernel: [call_apic_timer_interrupt+5/16]
call_apic_timer_interrupt [kernel] 0x5 
Feb 11 14:07:09 msrdev1 kernel: [<c0243509>] call_apic_timer_interrupt [kernel] 0x5 
Feb 11 14:07:09 msrdev1 kernel: [schedule+901/976] schedule [kernel] 0x385 
Feb 11 14:07:09 msrdev1 kernel: [<c0119625>] schedule [kernel] 0x385 
Feb 11 14:07:09 msrdev1 kernel:
[bcm5700:__insmod_bcm5700_O/lib/modules/2.4.9-e.10smp/kernel/drivers+-2542618/96]
kjournald [jbd] 0x146 
Feb 11 14:07:09 msrdev1 kernel: [<f885b3e6>] kjournald [jbd] 0x146 
Feb 11 14:07:09 msrdev1 kernel:
[bcm5700:__insmod_bcm5700_O/lib/modules/2.4.9-e.10smp/kernel/drivers+-2542976/96]
commit_timeout [jbd] 0x0 
Feb 11 14:07:09 msrdev1 kernel: [<f885b280>] commit_timeout [jbd] 0x0 
Feb 11 14:07:09 msrdev1 kernel: [kernel_thread+38/48] kernel_thread [kernel] 0x26 
Feb 11 14:07:09 msrdev1 kernel: [<c0105836>] kernel_thread [kernel] 0x26 
Feb 11 14:07:09 msrdev1 kernel:
[bcm5700:__insmod_bcm5700_O/lib/modules/2.4.9-e.10smp/kernel/drivers+-2542944/96]
kjournald [jbd] 0x0 
Feb 11 14:07:09 msrdev1 kernel: [<f885b2a0>] kjournald [jbd] 0x0 
Feb 11 14:07:09 msrdev1 kernel: 
Feb 11 14:07:09 msrdev1 kernel: 
Feb 11 14:07:09 msrdev1 kernel: Code: 0f 0b 58 5a 6a 04 8b 6c 24 14 55 56 e8 2b
f4 ff ff 8d 47 48 
Feb 11 14:07:09 msrdev1 kernel:  <0>Kernel panic: not continuing
Feb 11 14:07:11 msrdev1 login(pam_unix)[4274]: session opened for user kbisch by
(uid
Comment 2 Larry Woodman 2003-02-19 14:00:17 EST
Please attach the entire /var/log/messages(at least since the latest
boot) so we can look for device errors.

Larry Woodman
Comment 3 Summer Maynard 2003-02-21 13:12:42 EST
Created attachment 90251 [details]
Complete /var/log/messages, as requested.
Comment 4 Summer Maynard 2003-02-24 17:06:59 EST
This issue has disappeared for the customer with the e.12 errata kernel.  You
guys can go ahead and close this one.

Note You need to log in before you can comment on or make changes to this bug.