Bug 846231 - harddrive source installation - The kernel was unable to re-read the partition table
harddrive source installation - The kernel was unable to re-read the partitio...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.8
s390x Linux
medium Severity medium
: rc
: ---
Assigned To: Samantha N. Bueno
Release Test Team
:
Depends On:
Blocks: rhel59rtt 921048 928844
  Show dependency treegraph
 
Reported: 2012-08-07 04:43 EDT by Michal Kovarik
Modified: 2014-01-28 14:16 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
Installing Red Hat Enterprise Linux 5 from a hard drive is possible only if the source partition covers the whole disk. Otherwise, the following warning can appear: The kernel was unable to re-read the partition table on /dev/dasdb (Device or resource busy). This means Linux won't know anything about the modifications you made until you reboot. You should reboot your computer before doing anything with /dev/dasdb.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-28 14:16:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log - source partition cover only part of harddrive (403.86 KB, text/plain)
2012-08-07 04:43 EDT, Michal Kovarik
no flags Details
dmesg - source partition cover only part of harddrive (9.67 KB, text/plain)
2012-08-07 04:44 EDT, Michal Kovarik
no flags Details

  None (edit)
Description Michal Kovarik 2012-08-07 04:43:12 EDT
Created attachment 602682 [details]
anaconda.log - source partition cover only part of harddrive

Description of problem:
Installation from harddrive is possible only when source partition cover whole disk.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Prepare partition with DVD iso file
  a) partition cover whole harddrive
  b) partition cover only part of hardrive (e.g. 4.5 GB)
2. start text or vnc installation, select harddrive as source
3. select 'Remove all partitions on selected drives and select default layout' on partition screen
4. Continue and begin installation
  
Actual results:
Dialog:
'Warning
The kernel was unable to re-read the partition table on /dev/dasdb (Device or resource busy).  This means Linux won't know anything about the modifications you made until you reboot.  You should reboot your computer before doing anything with /dev/dasdb.'

  a) installation continue
  b) installation fail: pvcreate failed for <fsset.PartitionDevice instance at 0x81128d48>

Expected results:
succesfully end of installation without Warnings

Additional info:
/dev/dasdb1 - contains DVD iso
Works on other arches
Comment 1 Michal Kovarik 2012-08-07 04:44:31 EDT
Created attachment 602683 [details]
dmesg - source partition cover only part of harddrive
Comment 11 RHEL Product and Program Management 2014-01-22 11:33:27 EST
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 12 David Cantrell 2014-01-28 13:53:16 EST
Based on the logs, looks like the drive with the partition containing
the ISO image is ext3:

<7>SELinux: initialized (dev dasdb1, type ext3), uses xattr

The installation guide states (for hard drive installations): "This partition must be formatted with a ext2 or vfat filesystem, and cannot be a logical volume." [0]

[0] https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux/5/html/Installation_Guide/s1-begininstall-hd-s390.html
Comment 13 RHEL Product and Program Management 2014-01-28 14:16:36 EST
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.