Bug 846256 - [abrt] sssd-1.8.4-13.fc16: fo_set_port_status: Process /usr/libexec/sssd/sssd_be was killed by signal 11 (SIGSEGV)
[abrt] sssd-1.8.4-13.fc16: fo_set_port_status: Process /usr/libexec/sssd/sssd...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sssd (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stephen Gallagher
Fedora Extras Quality Assurance
abrt_hash:cadd4f1757154eabd4c01c932aa...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-07 05:25 EDT by James Cape
Modified: 2012-09-20 16:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-20 16:40:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (5.65 KB, text/plain)
2012-08-07 05:25 EDT, James Cape
no flags Details
File: maps (27.04 KB, text/plain)
2012-08-07 05:25 EDT, James Cape
no flags Details
File: backtrace (24.80 KB, text/plain)
2012-08-07 05:25 EDT, James Cape
no flags Details

  None (edit)
Description James Cape 2012-08-07 05:25:49 EDT
libreport version: 2.0.10
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/libexec/sssd/sssd_be --domain eladian.com --debug-to-files
comment:        Discovered in abrt.
crash_function: fo_set_port_status
executable:     /usr/libexec/sssd/sssd_be
kernel:         3.4.2-1.fc16.x86_64
pid:            1453
pwd:            /
time:           Sat 28 Jul 2012 11:30:11 PM EDT
uid:            0
username:       root

backtrace:      Text file, 25398 bytes
dso_list:       Text file, 5785 bytes
maps:           Text file, 27690 bytes

build_ids:
:552354979eebf3d6c27346691a5b520ccf8f4e75
:61aea344c391d8ca2c072b40c36b74bc28711038
:ad9b0193632c8cf2055f4d2a76c752360bfb06e9
:28579c89bda7f08dace218884d7a5561f3f5f89d
:5a491e02e37595592ec20c9c8c17442a46d8ddc6
:b06c064de933351790864300dddec868b2a6401e
:e05737728ab732fe7f2fdded4b50aaf4e9463997
:12fdc5a85e732c3f5e8b57d5d2901f36654c88ff
:5083c24b4fd7dbf3cac9cf4c15876b0dfdceb4bb
:bb2eda4e80e107a3874f5cf7612166a1d81cd08b
:fdff2d98463ddd6e8c3883936e12070b2d039e58
:bbb7c497ff14faf6e1a51da91e884427f670517f
:9efd824bf587def50099e2ae657a5cce012fa658
:aec9bd869a2f0c68bb8da6b040002c6a9da4eeca
:3a2c00058f6bc91272c8846d553d3834fab0f3c2
:6502dd4813f98137c70e6e05cc43828f5c2263c1
:0ce9819eb7014de7e72eec40979dd5e4d6566dca
:368c3cee84c23ec196abdf632219adea6bc31f4f
:b1532c8fcd1888fb7dc99186b3b8ec6875c72fa4
:1507cec972ed5cc28e0afd7e646afe0133930db5
:9181b91e3dd3b2786bf09199d2f89ec2a27d3652
:98710ef6382aabb845e5d732c12dfb9d7a26a9f7
:77ca13b377dc2850e7bde1c91e160c0f19421fb1
:60b543bfa22dd6a1f1010b40d6ceee45150ff826
:8c49577fba3c97a9de9331b5245737f6250e831c
:2a7df6dc20821a8e109c2cb56e1fdf4465043e99
:350285d7b5edc1c98cc7774fbf70fbf40de8c611
:2b09b8bb44cdbcce3b7e6a786adb0c0ffb4a27b9
:c33244f1d5bb3e0cfb8665c7408e934082cad015
:f84c1593fc686af2cdecea6678301be3029b493b
:3903219097bcd7fef6702a8fc24e50484083e23e
:c95e8094ddf00e9e03f98e4bd796b7c60a50d919
:b9746e6e639b060dcd2809a4c46655ee77838bf1
:8ea3a1b50dfbd33351111dac86cb8d6b6a73976f
:3ed9e0f5bbcd8d9d5b77f7dd4b562ec83d7ea767
:6ba9409fb9f58785e255d94fc533fbf1d1fe35fd
:4b4285058f7f6b39b7e7c45df83fd36c6833bfe4
:dd8106edd02ab9cb84bd426e3e1c24b2e96d7e20
:b52ecaab000fad35642f76aaf4396f4e7ae01c45
:186430a109712d3f99c968fdb8d897a7aca2eb77
:f8f4d8e260ee8f3b262936920270ace01b2da537
:58803db420709341d8e6a713b18e54a6e1824272
:53b01cfc73e8eba8c6af3feefd3f4378439692b9
:96d1d49f80e8de2aecf96e365e6084ddd0fd60c9
:be507c791e34415e8f42f0e6030c889b2895cf9a
:4fc5fba2757ff2e60f581ecb4cc8bd9af5b83eff
:c2692dcb73a5877a23c9b3943bb4603ab19168de
:14063d4a97bae5e96c07a1a7c0e6ca5c982839f3
:ed34ef634d932f2ff3d08a3d37e7d91145ea1469
:debd77c5edb1a46588d7cf80aca3ef2641f518a2
:e814ef8432b7dec42a0b8ec12b9abd9fc7f57b40
:6cded60dd119fb8b8aa41b264e12931cb2c7b67f
:fc684ef0fc723dcb68a88799b8fb98e68e5f7441
:caeeab6968f72c5f76b50b0d94ee93db61784288
:5ac56dbb5866c475e1b0c3e4ceeb390b0f7508c0
:82df68f406427a9efe3b2e41cec4374c1faf8dab
:6cfd35e0ead3e8ae8b000a42efe467c28762a08a
:8822ec50a7ca08984b34af0b3096794a5085c473
:f2e24eed69cdecfdc16ed844c315a295459441ff
:5cb5f8da286abd58aeab3bd6676e661d52ec2b5d
:0bdc61fe19abb41392fc4063868b71d319b5deb2
:ee2f04900ae1f07517d91eba300ef385fccab1b8
:89017ab0b75e533e4294f74ee8f7db3daceea536
:b824b7802995d5bec090260e699812e417068227
:17f981cb9dbb88e65022c2d49ef5f939da321833
:96be920f9f506a5bdcb7c4d7a8565b4f0791fc61

environ:
:BOOT_IMAGE=/vmlinuz-3.4.2-1.fc16.x86_64
:PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
:SYSFONT=latarcyrheb-sun16
:LANG=en_US.UTF-8
:PWD=/
:KEYTABLE=us
:_SSS_LOOPS=NO
:KRB5RCACHEDIR=/var/cache/krb5rcache

var_log_messages:
:Jul 28 23:30:11 qr5-nyc2 kernel: [328387.903851] sssd_be[1453]: segfault at e8150c90 ip 00007f74d1748f33 sp 00007fffcdc92e90 error 4 in sssd_be[7f74d1727000+76000]
:Jul 28 23:30:12 qr5-nyc2 abrt[11280]: Saved core dump of pid 1453 (/usr/libexec/sssd/sssd_be) to /var/spool/abrt/ccpp-2012-07-28-23:30:11-1453 (36610048 bytes)
Comment 1 James Cape 2012-08-07 05:25:52 EDT
Created attachment 602693 [details]
File: dso_list
Comment 2 James Cape 2012-08-07 05:25:55 EDT
Created attachment 602694 [details]
File: maps
Comment 3 James Cape 2012-08-07 05:25:57 EDT
Created attachment 602695 [details]
File: backtrace
Comment 4 Jakub Hrozek 2012-08-07 05:33:29 EDT
Can you please attach your sanitized sssd.conf? Do you use SRV records? I suspect this is a duplicate of #828163 (upstream #1364)
Comment 5 James Cape 2012-08-23 16:41:35 EDT
We do use SRV records, yes. 

[sssd]
debug_level = 0x00E0
services = nss, pam, ssh
config_file_version = 2
domains = example.com

[domain/example.com]
cache_credentials = True
debug_level = 0x00E0
id_provider = ipa
auth_provider = ipa
access_provider = ipa
chpass_provider = ipa

ipa_domain = example.com
ipa_server = ipa1-nyc2.example.com, _srv_
ipa_dyndns_update = True

ldap_tls_cacert = /etc/ipa/ca.crt
ldap_disable_paging = True
ldap_opt_timeout = 30
ldap_purge_cache_timeout = 0
ldap_connection_expire_timeout = 86400

krb5_store_password_if_offline = True

[nss]
debug_level = 0x00E0

[pam]
debug_level = 0x00E0

[ssh]
debug_level = 0x00E0
Comment 6 James Cape 2012-08-23 17:42:07 EDT
Found in ABRT.

backtrace_rating: 4
Package: sssd-1.8.4-13.fc16
OS Release: Fedora release 16 (Verne)
Comment 7 Fedora Update System 2012-09-15 10:14:55 EDT
sssd-1.9.0-22.fc18.rc1 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/sssd-1.9.0-22.fc18.rc1
Comment 8 Fedora Update System 2012-09-16 15:19:29 EDT
Package sssd-1.9.0-22.fc18.rc1:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sssd-1.9.0-22.fc18.rc1'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14025/sssd-1.9.0-22.fc18.rc1
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-09-20 16:40:48 EDT
sssd-1.9.0-22.fc18.rc1 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.