Bug 846274 - Make it possible to individually install and remove GNOME games
Make it possible to individually install and remove GNOME games
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-games (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-07 06:37 EDT by Allan Day
Modified: 2013-03-05 12:59 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-05 12:59:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spec cleanup (686 bytes, patch)
2012-08-08 06:36 EDT, Mathieu Bridon
no flags Details | Diff
Split each game into its own subpackage (25.77 KB, patch)
2012-08-08 06:37 EDT, Mathieu Bridon
no flags Details | Diff
Split each game into its own subpackage (26.83 KB, patch)
2012-08-08 22:18 EDT, Mathieu Bridon
no flags Details | Diff

  None (edit)
Description Allan Day 2012-08-07 06:37:36 EDT
Description of problem:

I want to install or remove a single game, but the packaging of GNOME Games prevents me from doing so.

Steps to Reproduce:
1. Try to install or remove a GNOME game by searching for it in add/remove software
2. You don't get any search results

People are interested in individual games, and might just want to have one or two installed or their system. The way that the games are packaged prevents that from happening.
Comment 1 Mathieu Bridon 2012-08-08 06:36:17 EDT
Created attachment 602990 [details]
Spec cleanup

This is not entirely related, but while I was at it...
Comment 2 Mathieu Bridon 2012-08-08 06:37:06 EDT
Created attachment 602991 [details]
Split each game into its own subpackage

This should fix this bug.
Comment 3 Mathieu Bridon 2012-08-08 06:46:02 EDT
(In reply to comment #2)
> Created attachment 602991 [details]
> Split each game into its own subpackage
> 
> This should fix this bug.

Maybe I should comment on what I did a bit more. :)

Each game is now in its own subpackage. They all require the main gnome-games package as it contains a few things:
- a gsettings schema which is common
- two icons which seem to be used by several games
- translations, hard to split properly :-/

And then, to not break upgrades, there's a new "gnome-games-compat" package which obsoletes the previous monolytic "gnome-games", and requires the new subpackage which used to be bundled:
- gnome-games-gnomine
- gnome-games-iagno
- gnome-games-swell-foop
- gnome-games-sudoku (only if %{have_sudoku})

That's all documented here:
https://fedoraproject.org/wiki/Upgrade_paths_%E2%80%94_renaming_or_splitting_packages
Comment 4 Ray Strode [halfline] 2012-08-08 18:24:25 EDT
I'm totally okay with you committing/building this if you like.  Are you provenpackager ?
Comment 5 Mathieu Bridon 2012-08-08 22:07:20 EDT
(In reply to comment #4)
> I'm totally okay with you committing/building this if you like.  Are you
> provenpackager ?

I'm not.

I just thought about something though: I preserved the upgrade path for people who had installed gnome-games on Fedora <18 : they will get the individual packages for these games.

However, I didn't do the same for gnome-games-extra.

I'll provide a patch with a gnome-games-extra-compat doing just that.
Comment 6 Mathieu Bridon 2012-08-08 22:18:57 EDT
Created attachment 603148 [details]
Split each game into its own subpackage

Here's the new version of the patch, preserving the upgrade path from gnome-games-extra
Comment 7 Mathieu Bridon 2012-08-08 22:34:37 EDT
Also, we need to change comps: (lines irrelevant for this bug report have been stripped out)

  <group>
    <id>games</id>
    <packagelist>
      <packagereq type="default">gnome-games</packagereq>
      <packagereq type="default">gnome-games-help</packagereq>
      <packagereq type="optional">gnome-games-extra</packagereq>
    </packagelist>
  </group>
  <group>
    <id>gnome-desktop</id>
    <packagelist>
      <packagereq type="default">gnome-games</packagereq>
    </packagelist>
  </group>

I'm not sure what games you want to keep installed by default, so I'm not providing a patch for that. Also, Bill Nottingham recently announced on devel@ some changes to the comps format, so I'm not even sure how such a patch would look like.

A few notes for the person who will change comps:

1. gnome-games-help is gone and should just be removed from comps (help for each game is now in each game subpackage)

2. gnome-games should be replace by the individual packages for the games you want to have installed by default. If nothing changes from F17, that would be:
 - gnome-games-gnomine
 - gnome-games-iagno
 - gnome-games-swell-foop
 - gnome-games-sudoku

3. gnome-games-extra should be replaced by all the individual packages not installed by default, i.e all the ones not mentioned in 2. If nothing changes from F17, that would be:
 - gnome-games-glchess
 - gnome-games-glines
 - gnome-games-gnect
 - gnome-games-gnibbles
 - gnome-games-gnobots2
 - gnome-games-gnotravex
 - gnome-games-gnotski
 - gnome-games-gtali
 - gnome-games-lightsoff
 - gnome-games-mahjongg
 - gnome-games-quadrapassel
Comment 8 Ray Strode [halfline] 2012-08-09 17:24:12 EDT
If you request commit access here:

https://admin.fedoraproject.org/pkgdb/acls/name/gnome-games

I'll approve it and you can put these changes in.
Comment 9 Mathieu Bridon 2012-08-10 13:36:05 EDT
I just built the package for Rawhide and F18. Turns out I had forgotten one tiny detail which broke the upgrade path (for people who already had gnome-games or gnome-games-extra installed), but that's fixed now, and I now have only Sudoku and Iagno on my machine. :)

Get the packages from Koji to test it:
http://koji.fedoraproject.org/koji/buildinfo?buildID=347172 (Fedora 18)
http://koji.fedoraproject.org/koji/buildinfo?buildID=347169 (Rawhide)

Or just wait a bit, they should land in the repos very soon.

There's still the issue of updating comps though. I can do that as well if needed, but what games should be installed by default?
Comment 10 Ray Strode [halfline] 2012-08-10 13:55:25 EDT
Allan might be a good person to answer that actually. Allan, what do you think?
Comment 11 Allan Day 2012-08-10 14:10:22 EDT
We probably want a maximum of around three games in total. My suggestion would be to include Swell Foop and Sudoku, plus Solitaire (that's not in gnome-games), since these have general appeal and are relatively high quality.
Comment 12 Ray Strode [halfline] 2012-08-10 16:29:42 EDT
Sounds good to me.  Mathieu are you still up for making those comps changes? (If you're tired of working on this, I can take over).

Allan, by solitaire I assume you mean aisleriot ?
Comment 13 Mathieu Bridon 2012-08-11 03:23:46 EDT
(In reply to comment #12)
> Sounds good to me.  Mathieu are you still up for making those comps changes?
> (If you're tired of working on this, I can take over).

No problem, I can do it. :)

(In reply to comment #11)
> We probably want a maximum of around three games in total. My suggestion
> would be to include Swell Foop and Sudoku, plus Solitaire (that's not in
> gnome-games), since these have general appeal and are relatively high
> quality.

The problem with Solitaire (aisleriot) is that it also comes in with Freecell, so that's 4 games, not 3.

Also, I'm a bit confused by this page:
    https://fedoraproject.org/wiki/Design/F18_Launcher_Purge

It seems to be mixing Solitaire and Freecell, but in both case it says the game quality is not great and they shouldn't be there by default.

So what should I do?
Comment 14 Allan Day 2012-08-11 06:48:07 EDT
(In reply to comment #13)
> The problem with Solitaire (aisleriot) is that it also comes in with
> Freecell, so that's 4 games, not 3.

I'd like to get it down to two: https://bugzilla.gnome.org/show_bug.cgi?id=681645
 
> Also, I'm a bit confused by this page:
>     https://fedoraproject.org/wiki/Design/F18_Launcher_Purge
> 
> It seems to be mixing Solitaire and Freecell, but in both case it says the
> game quality is not great and they shouldn't be there by default.

Yeah, sorry, the games section was a bit confused. I've tidied it up now.

> So what should I do?

Install gnome-games-swell-foop and gnome-games-sudoku by default. We'll deal with Aiselriot separately.
Comment 15 Mathieu Bridon 2012-08-12 12:17:32 EDT
I pushed the comps changes yesterday, and today "yum groupinfo" tells me that Sudoku and Sweel Foop are installed by default instead of the previous "gnome-games".

So I'd say this bug is fixed, but you might want to wait for the next compose to check what actually gets on the ISO.
Comment 16 ccgraham 2012-12-14 19:02:33 EST
This helped me remove most of the games from F17, but AisleRiot and FreeCell are still there. I have used yum to remove gnome-games, gnome-games-debug, gnome-games-devel and similarly for ked-games... 

An Apper search on "game"says I have no "games" installed.

I tried  #yum remove gnome-games-* with *= extra, aisleriot, freecell, and solitaire. All I get is, "No packages marked for removal."

Is there another parameter for yum remove I should be using? Or is this a feature/bug?
Comment 17 Dethlef Madsen 2013-01-18 15:24:30 EST
(In reply to comment #16)
> This helped me remove most of the games from F17, but AisleRiot and FreeCell
> are still there. I have used yum to remove gnome-games, gnome-games-debug,
> gnome-games-devel and similarly for ked-games... 
> 
> An Apper search on "game"says I have no "games" installed.
> 
> I tried  #yum remove gnome-games-* with *= extra, aisleriot, freecell, and
> solitaire. All I get is, "No packages marked for removal."
> 
> Is there another parameter for yum remove I should be using? Or is this a
> feature/bug?

# yum remove aisleriot 

will do it.

But why aisleriot isn't gnome-games-aisleriot and is part of gnome-games group ?

If you remove gnome-games\* aisleriot and freeecell are still installed.

BR

Dethlef
Comment 18 Hans de Goede 2013-03-05 12:59:51 EST
(In reply to comment #17)
> (In reply to comment #16)
> > This helped me remove most of the games from F17, but AisleRiot and FreeCell
> > are still there. I have used yum to remove gnome-games, gnome-games-debug,
> > gnome-games-devel and similarly for ked-games... 
> > 
> > An Apper search on "game"says I have no "games" installed.
> > 
> > I tried  #yum remove gnome-games-* with *= extra, aisleriot, freecell, and
> > solitaire. All I get is, "No packages marked for removal."
> > 
> > Is there another parameter for yum remove I should be using? Or is this a
> > feature/bug?
> 
> # yum remove aisleriot 
> 
> will do it.
> 
> But why aisleriot isn't gnome-games-aisleriot and is part of gnome-games
> group ?
> 
> If you remove gnome-games\* aisleriot and freeecell are still installed.

aisleriot and freecell both are part of the aisleriot package, which is a separate (source) package (separate upstream project, not part of gnome-games) you can remove them both by doing "yum remove aisleriot"

Since gnome-games has been fully split now, and each game can be installed / removed separately, I believe this bug is fixed -> closing.

Note You need to log in before you can comment on or make changes to this bug.