Bug 846297 - ovirt-engine-backend [Quota]: I can define a quota larger than my actual domain size but cannot create a thin provision disk
ovirt-engine-backend [Quota]: I can define a quota larger than my actual doma...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: ofri
Dafna Ron
sla
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-07 07:28 EDT by Dafna Ron
Modified: 2016-02-10 15:15 EST (History)
9 users (show)

See Also:
Fixed In Version: si17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 14:58:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log (291.05 KB, application/x-xz)
2012-08-07 07:28 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-08-07 07:28:50 EDT
Created attachment 602721 [details]
log

Description of problem:

I can define a 100G quota while my actual domain size is 50G but I cannot create thin provision disks so if I create a disk which is 80G as thin and my quota is 100G I will fail on lnot enough resources error (since the quota calculation on disk space are done as preallocated). 

CanDoAction: 
Cannot add Virtual Machine Disk. Quota has no sufficient storage resources.


Version-Release number of selected component (if applicable):

si13

How reproducible:

100%

Steps to Reproduce:
1. create a 50G domain and put a 100G quota
2. create a vm with thin provision disk which is 80G
3.
  
Actual results:

we would fail to create the disk with not enough disk space error because we are calculating the disk space as preallocated once we put quota in enforce. 

Expected results:

we should either block over extending the quota and work completely as preallocated (only allow extend when we actually add more storage). or we should allow the creation of a thin provision disk. 

Additional info: full backend log
Comment 1 ofri 2012-09-03 10:02:47 EDT
This was probably handled in the quota calculation patch (cant reproduce in current downstream). Please retest and reopen if needed.
Comment 2 Dafna Ron 2012-09-09 10:31:55 EDT
verified on si17
I was able to create a thinprovision disk on a 50GB storage and a 100GB quota.

Note You need to log in before you can comment on or make changes to this bug.