Bug 8463 - firewall breaks wu-ftp due to ident
Summary: firewall breaks wu-ftp due to ident
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: wu-ftpd   
(Show other bugs)
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-14 04:04 UTC by kpinc
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-03 21:04:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description kpinc 2000-01-14 04:04:59 UTC
Ident seems to be compiled into wu-ftpd.  We're running a server outside of
our firewall, and couldn't get into it from inside the firewall.  Turns out
the firewall is eating the ident packets and not sending a "icmp
unreachable" response back to the server.  This causes the server to hang
there and never (seemingly) deliver a login prompt.

Adding -I0 to the in.ftpd command line in /etc/inetd.conf fixes this.

I don't know if our firewall configuration is "normal" or not, but we
probably can't get to any 6.1 redhat ftp servers out there on the net
either.  Others may or may not have the same problem.

(FYI: We've had ident problems with sendmail before too...)

P.S.  It's annoying not to be able to search the mailing lists any longer.

Comment 1 kpinc 2000-01-14 04:43:59 UTC
I take it back.  This problem is happening on a RedHat 6.0 system, not 6.1.

Comment 2 Elliot Lee 2000-02-03 21:04:59 UTC
A final policy decision is up to the system administrator - the RH default works
for most people, and the mechanism for selecting policy does work.


Note You need to log in before you can comment on or make changes to this bug.