This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 846316 - Don't use an application launcher for the release notes
Don't use an application launcher for the release notes
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fedora-release-notes (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: eric@christensenplace.us
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-07 08:53 EDT by Allan Day
Modified: 2012-08-14 09:02 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-13 11:10:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Allan Day 2012-08-07 08:53:16 EDT
R why it isn't good to have a launcher for the release notes:

1. It's not an application. 

The model for application switching and launching in GNOME 3 is based on the idea that only applications have launchers. Each launcher is available under the "Applications" heading and gets added to the dash when it is running. The launcher is also represented in app switcher (accessed through alt+tab) and the application menu (found in the top bar). Each of these things reinforces the mental modal that apps == launchers.

The release notes launcher is inconsistent with this behaviour. When you launch it, you get a completely different application.

2. It clutters the application view.

Every unecessary application launcher places a mental burden on the user, since they have to process it when they are looking for applications to launch. While the release notes might be interesting when someone first installs or upgrades their system, it does not hold lasting interest and simply gets in the way.

Note that I'm not saying that the release notes are uninteresting or should not be exposed. There are plenty of other places where they can be made available.
Comment 1 Robyn Bergeron 2012-08-11 09:04:57 EDT
This isn't really acceptable to me, personally, for the following reasons:

#1: This is arguably a change that should go through the Feature Process. There are specific actions that the Documentation team take in building release notes into the final product; their schedule and processes would have to be altered, and the removal would necessitate finding a different alternative, and those changes would additionally impact the translations schedule and work as well.

#2: Final release criteria states:

"The final branded release notes from the Documentation team must be present on ISO media and the appropriately versioned generic release notes must be available in the online release repository."  Changing this criteria would require you to work with the QA team.

I would argue - and perhaps Adam or Tim or anyone from QA might feel otherwise - that simply *having* it on the media is not enough - I think this criterion, as written, assumed that it would be either (a) on the desktop or (b) available as a a launchable app or desktop button in any of the release-blocking desktops, and that this criterion was quite possibly intended to ensure that nobody forgot to upload the release notes.

Regardless - it should be easy to find.  Release notes provide incredibly useful information; they provide information about major changes in all aspects of the operating system, for a variety of different end-user types / audiences. One of the documentation wiki pages provides specific examples here, "Sometimes a package has changed in a way that requires action from a user. Perhaps the user must install an external package, perhaps (s)he must do some sort of file conversion." Burying it in the filesystem and hoping someone finds it if they need it shouldn't be an option.

Ironically enough, the removal of release notes from the Application Launcher is the *exact* type of thing we would put in release notes - or would if it had gone through the Feature Process, which is designed to catch/guide/coordinate major changes such as this.

#3: "Put it in Firefox"

This point comes directly from reading the F18 Launcher Purge wiki page: https://fedoraproject.org/wiki/Design/F18_Launcher_Purge

...wherein you suggested that, "This is already added as a Firefox bookmark. It can potentially be linked to from other webpages, also."

In keeping with the above comments regarding ease of location - we should not assume that all users have access to the internet, or immediate access to the internet at the time they might want to read the release notes because they have discovered that something has changed. Nor should we assume that everyone wants to use Firefox; many people install alternate browsers, which will not have these items bookmarked, and many people remove firefox altogether.  These latter points, IMO, make it an unreasonable option even when if the release notes were pointed to a location on the user's filesystem. It's simply not going to be consistently available, which is unkind for users. 

#4: We have other desktops.

I am not a comps expert, but as far as I can tell, fedora-release-notes is one of the base packages, pulled in for all desktops (again, from what I can tell, I could be dead wrong here.) If that is the case, care should be taken to ensure that we only remove the launcher button from gnome, and not other desktops, and in saying that I am not endorsing the idea of removing it from GNOME itself, either.

#5: I have not seen, in addition to a feature page, any communication anywhere whatsoever proposing this change, inclusive of the list of obvious places that I  would hope to find such a discussion - the documentation mailing list, and the devel mailing list.  This bug, and the aforementioned, largely unseen wiki page, are the only references. The *entire* documentation team, and the translations team, at a bare minimum, should be aware of this proposal, as they are the ones doing the work in this part of the Fedora Project, are the ones who do the most interfacing with the end users of Fedora that you suggest may not have lasting interest. 5 people automatically cc'd on a bugzilla does not make for a discussion that engages the groups listed.

There are numerous stakeholders in this type of decision.  This is precisely why we have the feature process, and why you should approach at least the directly affected groups on their mailing lists with such a proposal.
Comment 2 Allan Day 2012-08-11 13:21:09 EDT
Hi Robert,

(In reply to comment #1)
> This isn't really acceptable to me, personally, for the following reasons:
> 
> #1: This is arguably a change that should go through the Feature Process.

It's a collection of small changes; that doesn't feel like a feature to me. I checked with a few people from the Fedora community when I started this process; no one suggested that it should be a feature.

> There are specific actions that the Documentation team take in building
> release notes into the final product; their schedule and processes would
> have to be altered, and the removal would necessitate finding a different
> alternative, and those changes would additionally impact the translations
> schedule and work as well.

I'm proposing one of the following changes in this bug report:

1) Remove the desktop file for the release notes
2) Set the desktop file to "don't display under GNOME"

I don't see why this would impact on the documentation schedule.

> #2: Final release criteria states:
> 
> "The final branded release notes from the Documentation team must be present
> on ISO media and the appropriately versioned generic release notes must be
> available in the online release repository."  Changing this criteria would
> require you to work with the QA team.

You can continue to ship the release notes as a part of the ISO - fixing this bug wouldn't affect that.

> I would argue - and perhaps Adam or Tim or anyone from QA might feel
> otherwise - that simply *having* it on the media is not enough - I think
> this criterion, as written, assumed that it would be either (a) on the
> desktop or (b) available as a a launchable app or desktop button in any of
> the release-blocking desktops, and that this criterion was quite possibly
> intended to ensure that nobody forgot to upload the release notes.

I'm not suggesting that the release notes should be inacessible from the ISO media. You can have a bookmark for them and link to them from the default homepage - both of which can be done locally.

> Regardless - it should be easy to find.  Release notes provide incredibly
> useful information; they provide information about major changes in all
> aspects of the operating system, for a variety of different end-user types /
> audiences. One of the documentation wiki pages provides specific examples
> here, "Sometimes a package has changed in a way that requires action from a
> user. Perhaps the user must install an external package, perhaps (s)he must
> do some sort of file conversion." Burying it in the filesystem and hoping
> someone finds it if they need it shouldn't be an option.

See above - I'm not suggesting that the release notes should be 'buried in the filesystem'.  I've filed bug 847459 and bug 847461 - fixing these will give the release notes more exposure.

> Ironically enough, the removal of release notes from the Application
> Launcher is the *exact* type of thing we would put in release notes - or
> would if it had gone through the Feature Process, which is designed to
> catch/guide/coordinate major changes such as this.

Don't worry: I'll be sure to contact the relevant teams about this change.

> #3: "Put it in Firefox"
> 
> This point comes directly from reading the F18 Launcher Purge wiki page:
> https://fedoraproject.org/wiki/Design/F18_Launcher_Purge
> 
> ...wherein you suggested that, "This is already added as a Firefox bookmark.
> It can potentially be linked to from other webpages, also."
> 
> In keeping with the above comments regarding ease of location - we should
> not assume that all users have access to the internet, or immediate access
> to the internet at the time they might want to read the release notes
> because they have discovered that something has changed.

Again, we can make sure that this will work offline.

> Nor should we
> assume that everyone wants to use Firefox; many people install alternate
> browsers, which will not have these items bookmarked, and many people remove
> firefox altogether.  These latter points, IMO, make it an unreasonable
> option even when if the release notes were pointed to a location on the
> user's filesystem. It's simply not going to be consistently available, which
> is unkind for users. 

Firefox is the default browser; I think we can safely assume that people will a) have access to it and b) will know that they can get information about Fedora through it.

We also link to the release notes from the Fedora website, and they are accessible from Google. There will be plenty of opportunities for people to choose to read the release notes, should they want to, and they will continue to be adequately advertised.

> #4: We have other desktops.
> 
> I am not a comps expert, but as far as I can tell, fedora-release-notes is
> one of the base packages, pulled in for all desktops (again, from what I can
> tell, I could be dead wrong here.) If that is the case, care should be taken
> to ensure that we only remove the launcher button from gnome, and not other
> desktops, and in saying that I am not endorsing the idea of removing it from
> GNOME itself, either.

I don't have a strong opinion on what we should do for other desktops. As I mentioned above, I'd be happy for them to be hidden under GNOME only.

> #5: I have not seen, in addition to a feature page, any communication
> anywhere whatsoever proposing this change, inclusive of the list of obvious
> places that I  would hope to find such a discussion - the documentation
> mailing list, and the devel mailing list.  This bug, and the aforementioned,
> largely unseen wiki page, are the only references. The *entire*
> documentation team, and the translations team, at a bare minimum, should be
> aware of this proposal, as they are the ones doing the work in this part of
> the Fedora Project, are the ones who do the most interfacing with the end
> users of Fedora that you suggest may not have lasting interest. 5 people
> automatically cc'd on a bugzilla does not make for a discussion that engages
> the groups listed.
> 
> There are numerous stakeholders in this type of decision.  This is precisely
> why we have the feature process, and why you should approach at least the
> directly affected groups on their mailing lists with such a proposal.

I'm not suggesting that the release notes be abondoned or hidden, and the documentation and translation teams can carry on what they are doing unaffected. The only change being proposed is the removal of the application launcher for the release notes, which will continue to be available through many other places. I think I've made a clear case for why this change would be advantageous for the user experience.
Comment 3 eric@christensenplace.us 2012-08-13 09:44:17 EDT
We'll discuss this in this morning's Docs Project meeting.
Comment 4 Allan Day 2012-08-13 10:12:57 EDT
(In reply to comment #3)
> We'll discuss this in this morning's Docs Project meeting.

Thanks Eric; feel free to get in touch if you need any further information.
Comment 5 eric@christensenplace.us 2012-08-13 11:10:32 EDT
As discussed in the Docs Project meeting, we feel that your alternatives aren't really that good to how we currently have developed our way of shipping, and making easily accessible, our Release Notes.

To make someone jump through hoops in order to find the information that they require isn't what we're all about.  We want to make it easy for users to answer their questions and get information about Fedora.

That said, it appears you have some sort of vendetta against many pieces of software that Fedora links to from the Desktop because it is cluttering up GNOME's launch window.  This would appear to be a bug of GNOME 3 and not one of Fedora as Fedora has had this functionality from well before the days of GNOME 3.  An aesthetic fix should not remove functionality.

Oddly enough, I received a request from a user to have ALL documentation be made available from the desktop instead of just the Release Notes just this morning.  It would appear that we have users that are expecting the functionality we are currently providing and your request would have us go the other way.

The Docs Project agreed this morning to reject your request.
Comment 6 Allan Day 2012-08-13 11:38:29 EDT
(In reply to comment #5)
> As discussed in the Docs Project meeting, we feel that your alternatives
> aren't really that good to how we currently have developed our way of
> shipping, and making easily accessible, our Release Notes.

Did you discuss how the release notes launcher breaks the idea of what an application is, or how it degrades the user experience? I have some notes on the wiki [1] - did you reviewed them?

> To make someone jump through hoops in order to find the information that
> they require isn't what we're all about.  We want to make it easy for users
> to answer their questions and get information about Fedora.

Under my proposal there would be a number of ways that someone could access the release notes. These include:

 * A bookmark from the browser
 * A link from the default homepage
 * A link from the Fedora site (especially useful if someone is downloading the installation media, or are interested in a new release)
 * Search the web

I'm not sure what you mean by "jump through hoops". Are these options difficult or non-obvious?

> That said, it appears you have some sort of vendetta against many pieces of
> software that Fedora links to from the Desktop because it is cluttering up
> GNOME's launch window.  This would appear to be a bug of GNOME 3 and not one
> of Fedora as Fedora has had this functionality from well before the days of
> GNOME 3.  An aesthetic fix should not remove functionality.

I don't have a vendetta, and I'm a little surprised to hear you using that kind of language. I'm trying to contribute to Fedora by making the default desktop as good as it can possibly be.

GNOME's use of application launchers is by no means unique; many other operating systems use a similar design pattern, and none of them include a release notes launcher.

> Oddly enough, I received a request from a user to have ALL documentation be
> made available from the desktop instead of just the Release Notes just this
> morning.  It would appear that we have users that are expecting the
> functionality we are currently providing and your request would have us go
> the other way.

GNOME includes a help viewer by default - which has an application launcher of its own; I'd be happy to discuss how we can better integrate that with Fedora's documentation.

> The Docs Project agreed this morning to reject your request.

I'd like to request that you reconsider; my proposal shouldn't have a negative impact, and will help to improve the experience of people using Fedora.

[1] https://fedoraproject.org/wiki/Design/F18_Launcher_Purge
Comment 7 David Nalley 2012-08-13 12:01:33 EDT
First, you raised the bug here, which is fine. The Docs group has decided that they didn't think this was a bug. If you really wish to continue this conversation please move it to the docs mailing list, though personally I don't think that you will change many minds. 

(In reply to comment #6)
> (In reply to comment #5)
> > As discussed in the Docs Project meeting, we feel that your alternatives
> > aren't really that good to how we currently have developed our way of
> > shipping, and making easily accessible, our Release Notes.
> 
> Did you discuss how the release notes launcher breaks the idea of what an
> application is, or how it degrades the user experience? I have some notes on
> the wiki [1] - did you reviewed them?

I, personally, have seen your notes, and I see the hypothesis that you put forward, and like Eric, I think that you are highlighting a bug in Gnome 3 (inefficient to find what you are looking for, inability to handle a larger number of launchers, etc) I also am not sure that all of your hypotheses are true. 


> 
> > To make someone jump through hoops in order to find the information that
> > they require isn't what we're all about.  We want to make it easy for users
> > to answer their questions and get information about Fedora.
> 
> Under my proposal there would be a number of ways that someone could access
> the release notes. These include:

Let me outline some of the problems with your suggestions. (and no offense, but you are trying to suggest solutions that you have no interaction from a project perspective, and that shows) 

> 
>  * A bookmark from the browser

Bookmarks aren't 'upgraded' e.g. once a user is instantiated the bookmarks that are on the system at that point becomes their bookmarks and never get touched again. This means no one upgrading would see such links. 

>  * A link from the default homepage

The default home page (start.fp.o does not currently have links to the release notes. Moreover, this is not within the docs projects purview. 

>  * A link from the Fedora site (especially useful if someone is downloading
> the installation media, or are interested in a new release)

What if they received Fedora pressed media? Moreover, the fedora site is a labyrinth of content. (If you think that too many launchers is a problem and confusing, try looking at the Fedora Project site, there is a ton of content there, a ton of entry points, etc.) 

>  * Search the web

You are assuming they have internet access, or at least access at the time they wish to view the release notes. 


> 
> I'm not sure what you mean by "jump through hoops". Are these options
> difficult or non-obvious?

Difficult, impossible, and many are very non-obvious. 


> 
> > That said, it appears you have some sort of vendetta against many pieces of
> > software that Fedora links to from the Desktop because it is cluttering up
> > GNOME's launch window.  This would appear to be a bug of GNOME 3 and not one
> > of Fedora as Fedora has had this functionality from well before the days of
> > GNOME 3.  An aesthetic fix should not remove functionality.
> 
> I don't have a vendetta, and I'm a little surprised to hear you using that
> kind of language. I'm trying to contribute to Fedora by making the default
> desktop as good as it can possibly be.

Not to call you out here, but, your Fedora account was created in late May, you don't appear to be a member of any other group within the Fedora account system. So while I respect that you want to come in and help Fedora, please do understand that you don't know how things work here yet, and while we welcome people who wish to help fix things, also understand when people disagree with you, especially when those folks have had discussions like this over the course of many years. 



> 
> GNOME's use of application launchers is by no means unique; many other
> operating systems use a similar design pattern, and none of them include a
> release notes launcher.

In Fedora, every desktop that has such a concept gets one for the release notes.
This particular issue is IMHO, bigger than Gnome and the effects are far wider spread. I don't know if you are doing anything with the desktop folks in Fedora, or perhaps work upstream in Gnome, but this is a distribution issue. 

> 
> > Oddly enough, I received a request from a user to have ALL documentation be
> > made available from the desktop instead of just the Release Notes just this
> > morning.  It would appear that we have users that are expecting the
> > functionality we are currently providing and your request would have us go
> > the other way.
> 
> GNOME includes a help viewer by default - which has an application launcher
> of its own; I'd be happy to discuss how we can better integrate that with
> Fedora's documentation.
> 
> > The Docs Project agreed this morning to reject your request.
> 
> I'd like to request that you reconsider; my proposal shouldn't have a
> negative impact, and will help to improve the experience of people using
> Fedora.

I mean this as politely as I can. The Docs project (the people who actually produce the release notes and whose authority on the issue is effectively final) as a whole has concluded that they are not interested in this change, and on this bug alone you have had 3 Fedora Project Board members (including the FPL) outline problems with this proposal. Perhaps it is you that should reconsider your proposal.
Comment 8 John J. McDonough 2012-08-13 13:18:32 EDT
I am disappointed with the tone of some of these responses, but agree wholeheartedly with the sentiment.

I understand that the GNOME 3 launcher is slow, cluttered, and totally clumsy.  But removing applications isn't the solution.  It might make the LiveCD look good, but as soon as someone starts installing applications the problem is back.

ANd the Release Notes aren't the worst problem described on the wiki.  It is proposed to remove much CRITICAL functionality, making the default install virtually useless unless someone has a LOT of expertise to fix it.

As far as the release notes, as other explained, the browser shortcut, even if it points to a file, isn't particularly good.  It doesn't get updated, an issue we have run into before, and there are around a dozen browsers in Fedora. Not everyone uses Firefox.  Many of those browsers provide no way for us to preinstall shortcuts.

Web links are a non starter as well. At the time someone needs the release notes he may well not have an Internet connection.  Indeed, removing nm-connection-editor, as is proposed on the wiki, makes that a certainty for many users.

Now, there are other alternatives, but they involve working with upstream, who has been historically slow to provide response.

Adding a help button next to Windows Applications would be one approach, a very good one.  Another would be accessing the Release Notes from the GNOME help application.  This is something we did in the past, but recent changes to GNOME help have made that impossible.

Also, you seem to miss the point that the Release Notes are, in fact, an application, if a rather small one,  To match the rest of the Fedora experience, the user's selected language is used to launch the release notes.  A tiny bit of code manages that.

Simply removing the launcher is not a solution, and other proposals on the wiki are at least as bad.  But certainly other options might be found.  None, however, look to be something that could be done without a significant amount of work.
Comment 9 Allan Day 2012-08-14 05:31:21 EDT
(In reply to comment #8)
...
> ... Another would be accessing the Release Notes from the GNOME
> help application.  This is something we did in the past, but recent changes
> to GNOME help have made that impossible.

Can you point me to a link for that? I'd be happy to chase it up.
 
> Simply removing the launcher is not a solution, and other proposals on the
> wiki are at least as bad.  But certainly other options might be found. 
> None, however, look to be something that could be done without a significant
> amount of work.

Do you have any notes on the role you expect the release notes to play? Right now they seem to be designed as part of the documentation, rather than, say, a marketing device. Is that right?
Comment 10 John J. McDonough 2012-08-14 09:02:38 EDT
> Can you point me to a link for that? I'd be happy to chase it up.

Last I can find we did that was F8 but I'm pretty sure we did it up to 10 or so.  The new gitweb replacement makes it hard to find stuff

http://git.fedorahosted.org/cgit/docs/release-notes.git/tree/fedora-release-notes.spec?h=f8

Back at the 2010 Desktop Help Summit we had a fairly extensive discussion with Shaun McCance (GNOME Yelp developer) about fixing this regression in the updated (at that time) Yelp, perhaps even integrating Yelp with khelpcenter (there were KDE developers in on the discussion), but nothing ever really developed.

> Do you have any notes on the role you expect the release notes to play?
> Right now they seem to be designed as part of the documentation, rather
> than, say, a marketing device. Is that right?

The Alpha release notes are more of a marketing device, but the installed release notes really document significant changes tht users and administrators can expect when upgrading from the previous version.  That's kind of what "Release Notes" means.  In a perfect world users would review the release notes before install.  Occasionally there are things in the release notes that need to be done before install.  For example, database upgrades sometimes require the administrator to dump the databases before the upgrade.

Originally, the release notes were in the root directory of the install media so a user could review them before install,  However, as Fedora (and the release notes) grew and as the number of languages exploded, that became unweildy.

Note You need to log in before you can comment on or make changes to this bug.