This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 846454 - WARNING: at drivers/gpu/drm/i915/i915_drv.c:485 gen6_gt_check_fifodbg.isra.4+0x3d/0x50 [i915]()
WARNING: at drivers/gpu/drm/i915/i915_drv.c:485 gen6_gt_check_fifodbg.isra.4+...
Status: CLOSED DUPLICATE of bug 809773
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
17
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-07 16:37 EDT by srakitnican
Modified: 2013-01-22 15:03 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-22 15:03:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/messages from foo days back (1.98 MB, application/x-gzip)
2012-08-07 16:37 EDT, srakitnican
no flags Details
/var/log/Xorg.0.log (43.75 KB, application/octet-stream)
2012-08-07 16:40 EDT, srakitnican
no flags Details
~/.xsession-errors when Gnome crash occurs (20.54 KB, application/octet-stream)
2012-08-14 14:28 EDT, srakitnican
no flags Details

  None (edit)
Description srakitnican 2012-08-07 16:37:56 EDT
Created attachment 602850 [details]
/var/log/messages from foo days back

Description of problem:

Ever since I've upgraded to Fedora 17 using preupgrade I have various problems with desktop stability. Gnome is crashing randomly, leaving program windows without title bar. Task bar with activities crashes also. Then if restarted with Ctrl + Alt + Backspace, it starts to use 100% cpu and it's response is not good any more like it's not 3D accelerated any more (fallback to vesa). With recent updates whole system started freezing very often. Console switch Ctrl + Alt + F2 is not working.

Version-Release number of selected component (if applicable):
Currently using latest kernel from updates: 3.5.0-2.fc17.i686

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
i3-2100, MOBO ASRock H67M

Sample from /var/log/messages:
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376122] WARNING: at drivers/gpu/drm/i915/i915_drv.c:485 gen6_gt_check_fifodbg.isr
a.4+0x3d/0x50 [i915]()
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376124] Hardware name: To Be Filled By O.E.M.
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376125] MMIO read or write has been dropped 3
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376126] Modules linked in: bnep bluetooth rfkill be2iscsi iscsi_boot_sysfs bnx2i 
cnic uio cxgb4i cxgb4 cxgb3i cxgb3 mdio libcxgbi ib_iser rdma_cm tpm_bios ib_addr iw_cm ib_cm ib_sa ib_mad ib_core iscsi_tcp libis
csi_tcp libiscsi scsi_transport_iscsi binfmt_misc fuse snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel tuner_simple tuner_t
ypes snd_bt87x tuner snd_hda_codec snd_hwdep snd_pcm snd_page_alloc tvaudio coretemp kvm_intel snd_timer ppdev tda7432 msp3400 i2c
_i801 lpc_ich kvm parport_pc parport snd bttv btcx_risc tveeprom videobuf_dma_sg videobuf_core v4l2_common videodev media rc_core 
mei soundcore microcode uinput crc32c_intel i915 video i2c_algo_bit drm_kms_helper drm i2c_core [last unloaded: scsi_wait_scan]
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376169] Pid: 683, comm: Xorg Tainted: G        W    3.5.0-2.fc17.i686 #1
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376170] Call Trace:
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376175]  [<c0438df2>] warn_slowpath_common+0x72/0xa0
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376188]  [<f820f2ed>] ? gen6_gt_check_fifodbg.isra.4+0x3d/0x50 [i915]
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376199]  [<f820f2ed>] ? gen6_gt_check_fifodbg.isra.4+0x3d/0x50 [i915]
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376202]  [<c0438ec3>] warn_slowpath_fmt+0x33/0x40
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376214]  [<f820f2ed>] gen6_gt_check_fifodbg.isra.4+0x3d/0x50 [i915]
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376228]  [<f820f83b>] __gen6_gt_force_wake_put+0x1b/0x20 [i915]
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376240]  [<f820fbfd>] i915_read32+0xbd/0xe0 [i915]
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376258]  [<f824db56>] intel_ring_get_active_head+0x26/0x40 [i915]
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376274]  [<f824dba7>] gen6_ring_get_seqno+0x37/0x50 [i915]
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376286]  [<f821ef09>] __wait_seqno+0x29/0x210 [i915]
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376291]  [<c0458290>] ? wake_up_bit+0x30/0x30
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376304]  [<f82207c8>] i915_wait_request+0xa8/0xd0 [i915]
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376316]  [<f8220839>] i915_gem_object_wait_rendering+0x49/0x70 [i915]
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376329]  [<f8221aff>] i915_gem_object_set_to_cpu_domain+0x8f/0x160 [i915]
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376342]  [<f8224ae5>] i915_gem_execbuffer_relocate_entry+0x1d5/0x3a0 [i915]
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376354]  [<f82252aa>] ? i915_gem_execbuffer_reserve.isra.4+0x30a/0x3b0 [i915]
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376366]  [<f822625b>] i915_gem_do_execbuffer.isra.7+0xebb/0xfb0 [i915]
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376370]  [<c0660159>] ? rb_insert_color+0xb9/0xf0
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376374]  [<c0666a21>] ? _copy_from_user+0x41/0x60
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376386]  [<f82268b2>] i915_gem_execbuffer2+0x62/0x240 [i915]
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376398]  [<f8226850>] ? i915_gem_execbuffer+0x500/0x500 [i915]
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376409]  [<f7f44cc2>] drm_ioctl+0x422/0x480 [drm]
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376424]  [<f8226850>] ? i915_gem_execbuffer+0x500/0x500 [i915]
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376436]  [<f7f448a0>] ? drm_copy_field+0x80/0x80 [drm]
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376440]  [<c054ae6a>] do_vfs_ioctl+0x7a/0x580
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376444]  [<c060ef4a>] ? inode_has_perm.isra.31.constprop.62+0x3a/0x50
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376447]  [<c0610590>] ? file_has_perm+0xa0/0xb0
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376451]  [<c0610928>] ? selinux_file_ioctl+0x48/0xe0
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376455]  [<c054b3d8>] sys_ioctl+0x68/0x80
Aug  7 21:41:18 00-25-22-b5-7b-09 kernel: [   28.376458]  [<c09472df>] sysenter_do_call+0x12/0x28
Comment 1 srakitnican 2012-08-07 16:40:18 EDT
Created attachment 602851 [details]
/var/log/Xorg.0.log
Comment 2 srakitnican 2012-08-14 14:28:29 EDT
Created attachment 604389 [details]
~/.xsession-errors when Gnome crash occurs

Went to terminal Ctrl+Alt+F2 and copied log file

intel_do_flush_locked failed: Input/output error
** Message: applet now removed from the notification area
** Message: Starting applet secret agent because GNOME Shell disappeared
Comment 3 Roland Roberts 2012-12-03 14:06:01 EST
I have the same symptoms, same message. I had a terminal window open which allowed mouse input so I did a little cut-and-paste there to try to restart gnome-shell, but got the same message:
 
    intel_do_flush_locked failed: Input/output error

Below is part of /var/log/messages from when the problem apparently started; I was away from my screen, so I'm not sure when it actually happened. You'll notice the similarity of the traceback:

Dec  3 13:33:15 aristarchus kernel: [65580.550213] [drm:__gen6_gt_force_wake_get] *ERROR* Force wake wait timed out
Dec  3 13:33:15 aristarchus kernel: [65580.552995] [drm:__gen6_gt_wait_for_thread_c0] *ERROR* GT thread status wait timed out
Dec  3 13:33:15 aristarchus kernel: [65580.554926] [drm:__gen6_gt_force_wake_get] *ERROR* Force wake wait timed out
Dec  3 13:33:15 aristarchus kernel: [65580.557439] [drm:__gen6_gt_wait_for_thread_c0] *ERROR* GT thread status wait timed out
Dec  3 13:33:15 aristarchus kernel: [65580.558867] [drm:__gen6_gt_force_wake_get] *ERROR* Force wake wait timed out
Dec  3 13:33:15 aristarchus kernel: [65580.560861] [drm:__gen6_gt_wait_for_thread_c0] *ERROR* GT thread status wait timed out
Dec  3 13:33:15 aristarchus kernel: [65580.566587] [drm:__gen6_gt_force_wake_get] *ERROR* Force wake wait timed out
Dec  3 13:33:15 aristarchus kernel: [65580.571273] [drm:__gen6_gt_wait_for_thread_c0] *ERROR* GT thread status wait timed out
Dec  3 13:33:15 aristarchus kernel: [65580.578097] [drm:__gen6_gt_force_wake_get] *ERROR* Force wake wait timed out
Dec  3 13:33:15 aristarchus kernel: [65580.580502] [drm:__gen6_gt_wait_for_thread_c0] *ERROR* GT thread status wait timed out
Dec  3 13:33:21 aristarchus kernel: [65586.565264] [drm:i915_hangcheck_hung] *ERROR* Hangcheck timer elapsed... GPU hung
Dec  3 13:33:21 aristarchus kernel: [65586.567236] [drm:__gen6_gt_force_wake_get] *ERROR* Force wake wait timed out
Dec  3 13:33:21 aristarchus kernel: [65586.569231] [drm:__gen6_gt_wait_for_thread_c0] *ERROR* GT thread status wait timed out
Dec  3 13:33:21 aristarchus kernel: [65586.574459] ------------[ cut here ]------------
Dec  3 13:33:21 aristarchus kernel: [65586.574521] WARNING: at drivers/gpu/drm/i915/intel_pm.c:4059 __gen6_gt_wait_for_fifo+0x89/0x90 [i915]()
Dec  3 13:33:21 aristarchus kernel: [65586.574524] Hardware name: 4170CTO
Dec  3 13:33:21 aristarchus kernel: [65586.574527] Modules linked in: fuse nfsv4 nfs dns_resolver fscache rfcomm bnep xt_pkttype nf_conntrack_ipv4 nf_defrag_ipv4 ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 xt_state nf_conntrack ip6table_filter ip6_tables snd_hda_codec_hdmi snd_hda_codec_conexant btusb uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core videodev media arc4 iwldvm mac80211 bluetooth snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm iTCO_wdt iTCO_vendor_support iwlwifi snd_page_alloc mei e1000e snd_timer cfg80211 lpc_ich i2c_i801 mfd_core coretemp microcode thinkpad_acpi snd soundcore rfkill vhost_net tun macvtap macvlan kvm uinput nfsd auth_rpcgss nfs_acl lockd sunrpc crc32c_intel ghash_clmulni_intel sdhci_pci sdhci mmc_core wmi i915 video i2c_algo_bit drm_kms_helper drm i2c_core
Dec  3 13:33:21 aristarchus kernel: [65586.574612] Pid: 10750, comm: kworker/u:1 Tainted: G        W    3.6.8-2.fc17.x86_64 #1
Dec  3 13:33:21 aristarchus kernel: [65586.574615] Call Trace:
Dec  3 13:33:21 aristarchus kernel: [65586.574629]  [<ffffffff8105c8ef>] warn_slowpath_common+0x7f/0xc0
Dec  3 13:33:21 aristarchus kernel: [65586.574636]  [<ffffffff8105c94a>] warn_slowpath_null+0x1a/0x20
Dec  3 13:33:21 aristarchus kernel: [65586.574666]  [<ffffffffa00b25b9>] __gen6_gt_wait_for_fifo+0x89/0x90 [i915]
Dec  3 13:33:21 aristarchus kernel: [65586.574689]  [<ffffffffa007002d>] i915_write32+0xfd/0x130 [i915]
Dec  3 13:33:21 aristarchus kernel: [65586.574718]  [<ffffffffa00b5a4b>] init_ring_common+0x5b/0x390 [i915]
Dec  3 13:33:21 aristarchus kernel: [65586.574742]  [<ffffffffa00812de>] ? i915_gem_reset_fences+0x4e/0xd0 [i915]
Dec  3 13:33:21 aristarchus kernel: [65586.574769]  [<ffffffffa00b6455>] init_render_ring+0x35/0x300 [i915]
Dec  3 13:33:21 aristarchus kernel: [65586.574790]  [<ffffffffa00706b2>] i915_reset+0xf2/0x190 [i915]
Dec  3 13:33:21 aristarchus kernel: [65586.574811]  [<ffffffffa00756e3>] i915_error_work_func+0xc3/0x110 [i915]
Dec  3 13:33:21 aristarchus kernel: [65586.574827]  [<ffffffff81078cb7>] process_one_work+0x147/0x4a0
Dec  3 13:33:21 aristarchus kernel: [65586.574848]  [<ffffffffa0075620>] ? gen6_pm_rps_work+0xd0/0xd0 [i915]
Dec  3 13:33:21 aristarchus kernel: [65586.574856]  [<ffffffff8107aa1e>] worker_thread+0x15e/0x480
Dec  3 13:33:21 aristarchus kernel: [65586.574863]  [<ffffffff8107a8c0>] ? manage_workers+0x2f0/0x2f0
Dec  3 13:33:21 aristarchus kernel: [65586.574869]  [<ffffffff8107fde3>] kthread+0x93/0xa0
Dec  3 13:33:21 aristarchus kernel: [65586.574877]  [<ffffffff81627f04>] kernel_thread_helper+0x4/0x10
Dec  3 13:33:21 aristarchus kernel: [65586.574884]  [<ffffffff8107fd50>] ? kthread_freezable_should_stop+0x70/0x70
Dec  3 13:33:21 aristarchus kernel: [65586.574889]  [<ffffffff81627f00>] ? gs_change+0x13/0x13
Dec  3 13:33:21 aristarchus kernel: [65586.574893] ---[ end trace 5f071d3bdfdf4080 ]---


[root@aristarchus log]# uname -a
Linux aristarchus.rlent.pnet 3.6.8-2.fc17.x86_64 #1 SMP Tue Nov 27 19:35:02 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
Comment 4 Roland Roberts 2013-01-09 12:35:43 EST
Interestingly, this has not happened recently, meaning not at all in the past couple of weeks. Given the number of updates, it is possible it was fixed incidentally or that whatever triggered it no longer happens.
Comment 5 Adam Jackson 2013-01-22 15:03:49 EST

*** This bug has been marked as a duplicate of bug 809773 ***

Note You need to log in before you can comment on or make changes to this bug.