Bug 846479 - KVM: x86: apply kvmclock offset to guest wall clock time (upstream backport)
KVM: x86: apply kvmclock offset to guest wall clock time (upstream backport)
Status: CLOSED DUPLICATE of bug 817243
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Marcelo Tosatti
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-07 17:37 EDT by Marcelo Tosatti
Modified: 2012-08-08 11:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-08 11:58:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcelo Tosatti 2012-08-07 17:37:32 EDT
commit 4b6486659a7defef82ea51b276024b3aa357fefc
Author: Bruce Rogers <brogers@suse.com>
Date:   Fri Jul 20 10:44:24 2012 -0600

    KVM: x86: apply kvmclock offset to guest wall clock time
    
    When a guest migrates to a new host, the system time difference from the
    previous host is used in the updates to the kvmclock system time visible
    to the guest, resulting in a continuation of correct kvmclock based guest
    timekeeping.
    
    The wall clock component of the kvmclock provided time is currently not
    updated with this same time offset. Since the Linux guest caches the
    wall clock based time, this discrepency is not noticed until the guest is
    rebooted. After reboot the guest's time calculations are off.
    
    This patch adjusts the wall clock by the kvmclock_offset, resulting in
    correct guest time after a reboot.


--- 

Lack of this fix can result in application crashes in guests which are difficult
to debug, when migration is used.
Comment 2 Marcelo Tosatti 2012-08-08 11:58:23 EDT

*** This bug has been marked as a duplicate of bug 817243 ***

Note You need to log in before you can comment on or make changes to this bug.