Bug 846489 - SELinux is preventing /usr/lib/nspluginwrapper/plugin-config from 'read' accesses on the file /opt/jre1.7.0_04-i586/lib/i386/libnpjp2.so.
SELinux is preventing /usr/lib/nspluginwrapper/plugin-config from 'read' acce...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:8ed7d76e35e338642186ccc5ccb...
:
: 1062902 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-07 18:50 EDT by thonatas
Modified: 2014-02-11 12:23 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-08 06:10:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description thonatas 2012-08-07 18:50:21 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.5.0-2.fc17.i686
time:           Ter 07 Ago 2012 18:49:27 AMT

description:
:SELinux is preventing /usr/lib/nspluginwrapper/plugin-config from 'read' accesses on the file /opt/jre1.7.0_04-i586/lib/i386/libnpjp2.so.
:
:*****  Plugin restorecon (99.5 confidence) suggests  *************************
:
:If você deseja reparar este rótulo.
:/opt/jre1.7.0_04-i586/lib/i386/libnpjp2.so rótulo padrão deve ser textrel_shlib_t.
:Then você pode executar o restorecon.
:Do
:# /sbin/restorecon -v /opt/jre1.7.0_04-i586/lib/i386/libnpjp2.so
:
:*****  Plugin catchall (1.49 confidence) suggests  ***************************
:
:If você acredita que o plugin-config deva ser permitido acesso de read em libnpjp2.so file  por default.
:Then você precisa reportar este como um erro.
:Você pode gerar um módulo de política local para permitir este acesso.
:Do
:permitir este acesso agora executando:
:# grep plugin-config /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_config_t:
:                              s0-s0:c0.c1023
:Target Context                unconfined_u:object_r:admin_home_t:s0
:Target Objects                /opt/jre1.7.0_04-i586/lib/i386/libnpjp2.so [ file
:                              ]
:Source                        plugin-config
:Source Path                   /usr/lib/nspluginwrapper/plugin-config
:Port                          <Desconhecido>
:Host                          (removed)
:Source RPM Packages           nspluginwrapper-1.4.4-9.fc17.i686
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-142.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.0-2.fc17.i686 #1
:                              SMP Mon Jul 30 15:41:00 UTC 2012 i686 i686
:Alert Count                   4
:First Seen                    Seg 06 Ago 2012 20:58:03 AMT
:Last Seen                     Ter 07 Ago 2012 18:48:04 AMT
:Local ID                      9abc87e3-4425-4dc3-9b04-3e169241ba19
:
:Raw Audit Messages
:type=AVC msg=audit(1344379684.467:73): avc:  denied  { read } for  pid=1925 comm="plugin-config" name="libnpjp2.so" dev="dm-1" ino=525191 scontext=unconfined_u:unconfined_r:mozilla_plugin_config_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:admin_home_t:s0 tclass=file
:
:
:type=AVC msg=audit(1344379684.467:73): avc:  denied  { open } for  pid=1925 comm="plugin-config" path="/opt/jre1.7.0_04-i586/lib/i386/libnpjp2.so" dev="dm-1" ino=525191 scontext=unconfined_u:unconfined_r:mozilla_plugin_config_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:admin_home_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1344379684.467:73): arch=i386 syscall=open success=yes exit=EINTR a0=bfa090a5 a1=0 a2=2 a3=0 items=0 ppid=1923 pid=1925 auid=1000 uid=1000 gid=1000 euid=0 suid=0 fsuid=0 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=plugin-config exe=/usr/lib/nspluginwrapper/plugin-config subj=unconfined_u:unconfined_r:mozilla_plugin_config_t:s0-s0:c0.c1023 key=(null)
:
:Hash: plugin-config,mozilla_plugin_config_t,admin_home_t,file,read
:
:audit2allow
:
:#============= mozilla_plugin_config_t ==============
:allow mozilla_plugin_config_t admin_home_t:file { read open };
:
:audit2allow -R
:
:#============= mozilla_plugin_config_t ==============
:allow mozilla_plugin_config_t admin_home_t:file { read open };
:
Comment 1 Miroslav Grepl 2012-08-08 06:10:01 EDT
You need to run restorecon on it.

/sbin/restorecon -v /opt/jre1.7.0_04-i586/lib/i386/libnpjp2.so

How is /opt/jre1.7.0_04-i586 labeled?

# ls -dZ /opt/jre1.7.0_04-i586
Comment 2 Miroslav Grepl 2014-02-11 12:23:08 EST
*** Bug 1062902 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.