Bug 846552 - RFE: Validate Topic Title and ID in Human-readable Relationships
RFE: Validate Topic Title and ID in Human-readable Relationships
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Lee Newson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-08 02:35 EDT by Joshua Wulf
Modified: 2014-10-19 19:01 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-24 17:39:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2012-08-08 02:35:46 EDT
As of 0.26.2-1, the topic title used in Human-readable relationships is not validated with the topic ID specified. This can cause unpredictable output when a human readable title does not match the topic specified by the ID.

Two tasks to align this:

1. Validate topic title and topic ID of all human-readable relationships and produce an error list when they do not match.
2. Add logic to --permissive, -p to realign relationship block titles with the canonical title based on the ID specified.
Comment 1 Joshua Wulf 2012-08-08 02:37:27 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=837960#c3 is the Human-readable relationships feature request
Comment 2 Joshua Wulf 2012-08-08 05:05:18 EDT
[Feature Status Note added to docs, needs to be updated when feature is ready:

http://deathstar1.usersys.redhat.com:8080/TopicIndex/Books/Content_Spec_Processor_Guide/index.html#Referto_relationship

Topic ID: 6252]
Comment 3 Lee Newson 2014-02-24 17:39:12 EST
This has been in csprocessor for some time (I'm not sure what version it got added), however due to the change we did in 1.0 this now works in reverse. ie It will print a warning by default, and error when strict title processing is in place.

Note You need to log in before you can comment on or make changes to this bug.