Bug 846606 - timidity -iA -Oj broken in fc17 with rosegarden
timidity -iA -Oj broken in fc17 with rosegarden
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: timidity++ (Show other bugs)
17
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-08 04:45 EDT by David W. Legg
Modified: 2013-07-02 19:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 757316
Environment:
Last Closed: 2012-08-10 11:04:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David W. Legg 2012-08-08 04:45:38 EDT
+++ This bug was initially created as a clone of Bug #757316 +++

Description of problem:

The command:-

rosegarden & (sleep 10;timidity -iA -Oj)

used to work under FC14 and FC15 to start rosegarden and get sound out when clicking on notes, playing using the jack transport etc.

I have no info about FC16.

Under FC17, all the processes start, the connections of ports are made, but no sound is emitted.

Pavucontrol and kmix do not show any connection to pulseaudio being made (not sure whether that is relevant or not.)

Would really like to move from FC14 to FC17 now ...

rosegarden i686 12.04
timidity++ i686 2.13.2-31 cvs fc17 build
Comment 1 Hans de Goede 2012-08-08 06:08:05 EDT
If you want to hear sound through pulseaudio, you should not specify -Oj , -Oj makes timidity send the synthesised midi sound to jack rather then to pulse, so of course timidity won't show up in pavucontrol.

If I do:

1) Start timidity:

sudo timidity -iA

2) start rosegarden:

rosegarden

3) go to studio->Manage midi devices

4) Select General MIDI device, Timidity port 0 as output

5) play a midi file

It works fine
Comment 2 David W. Legg 2012-08-10 08:04:30 EDT
Thanks Hans, that seems to work nicely on FC17 i686.

You do not need the sudo; "timidity -iA" works ok as a normal user.

Jack seems to be installed as dependency, but can be ignored.

FC17 here I come ...

This bug may now be closed, thanks.
Comment 3 David W. Legg 2012-08-10 09:49:30 EDT
Oh, the other thing that needs to be said so that record is complete for anyone who stumbles across this report is that you need to add all the timidity users to the 'audio' group in fc17.  Otherwise the command

timidity -iA 

will simply yield the error message:

permission denied /dev/ etc.

This seems better than running timidity as root.

Thanks.
Comment 4 Hans de Goede 2012-08-10 11:04:27 EDT
(In reply to comment #3)
> Oh, the other thing that needs to be said so that record is complete for
> anyone who stumbles across this report is that you need to add all the
> timidity users to the 'audio' group in fc17.  Otherwise the command
> 
> timidity -iA 
> 
> will simply yield the error message:
> 
> permission denied /dev/ etc.
> 
> This seems better than running timidity as root.

Agreed! I did not know about the audio group.

Note You need to log in before you can comment on or make changes to this bug.