Bug 846617 - Version 1.7 is out
Version 1.7 is out
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-networkx (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Conrad Meyer
Fedora Extras Quality Assurance
:
Depends On: 849713
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-08 05:03 EDT by Volker Fröhlich
Modified: 2012-12-20 10:40 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:40:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Volker Fröhlich 2012-08-08 05:03:41 EDT
Version 1.7 came out in July. Can you please update?
Comment 1 Jerry James 2012-08-08 10:44:59 EDT
I actually prepared an update on Monday, but the build failed due to the current Python 3.3 situation:

Getting requirements for python-networkx-1.7-1.fc18.src
 --> gdal-python-1.9.1-10.fc18.i686
 --> graphviz-python-2.28.0-21.fc18.i686
 --> pydot-1.0.28-2.fc18.noarch
 --> pyparsing-1.5.6-6.fc18.noarch
 --> python3-pyparsing-1.5.6-6.fc18.noarch
 --> python-devel-2.7.3-12.fc18.i686
 --> python3-devel-3.3.0-0.1.b1.fc18.i686
 --> python-decorator-3.3.3-4.fc18.noarch
 --> python3-decorator-3.3.3-4.fc18.noarch
 --> python-matplotlib-1.0.1-21.fc18.i686
 --> python-nose-1.1.2-5.fc18.noarch
 --> python-sphinx-1.1.3-2.fc18.noarch
 --> PyYAML-3.10-6.fc18.i686
 --> python3-PyYAML-3.10-6.fc18.i686
 --> scipy-0.10.1-3.fc18.i686
 --> python3-scipy-0.10.1-3.fc18.i686
 --> texlive-latex-2007-73.fc18.i686
Error: Package: python3-scipy-0.10.1-3.fc18.i686 (fedora)
           Requires: python(abi) = 3.2
           Installed: python-2.7.3-12.fc18.i686 (@fedora/$releasever)
               python(abi) = 2.7
               python(abi) = 2.7
           Installing: python3-3.3.0-0.1.b1.fc18.i686 (fedora)
               python(abi) = 3.3
Error: Package: python3-scipy-0.10.1-3.fc18.i686 (fedora)
           Requires: libpython3.2mu.so.1.0
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Once the underlying packages are fixed, I'll push a build of python-networkx through.
Comment 2 Jerry James 2012-08-20 12:46:49 EDT
This bug now depends on the numpy bug that is blocking the scipy rebuild.
Comment 3 Jerry James 2012-10-08 13:37:12 EDT
Hurrah!  A good scipy build finally hit the F18 repository over the weekend.  Now we can finally get somewhere with this.
Comment 4 Fedora Update System 2012-10-08 13:40:30 EDT
python-networkx-1.7-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-networkx-1.7-1.fc18
Comment 5 Fedora Update System 2012-10-08 19:53:44 EDT
Package python-networkx-1.7-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-networkx-1.7-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15663/python-networkx-1.7-1.fc18
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-12-20 10:40:34 EST
python-networkx-1.7-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.